Please support VectorLinux!

Author Topic: Slackware-12 X Logout Blanks  (Read 5197 times)

Pita

  • Vectorian
  • ****
  • Posts: 1324
Slackware-12 X Logout Blanks
« on: September 26, 2007, 11:06:53 pm »
I have upgraded to sw-12 and installed 2 other distros based on sw-12, namely absolute-linux and slax the latter as a bootable CD.

In all 3 boxes if I try to leave X (icewmaker, fluxbox, wmaker,kde, etc) clicking on quit or logout the screen blanks and nohting on the keyboard is accessible except ctrl-alt-del to reboot if I do it on time. If I delay apparently everything freezes.
Ctrl-alt-Backspace blanks the screen too, however, ctr-alt-F2 gives me a console.

I do not think that this is a coincidence for all 3 distros, it must be a bug in sw-12.

I am reporting this just for developers toward VL based on sw-12 to be aware of. May be it's already old hat.

Regards

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Slackware-12 X Logout Blanks
« Reply #1 on: October 19, 2007, 11:37:41 pm »
I have upgraded to sw-12 and installed 2 other distros based on sw-12, namely absolute-linux and slax the latter as a bootable CD.

In all 3 boxes if I try to leave X (icewmaker, fluxbox, wmaker,kde, etc) clicking on quit or logout the screen blanks and nohting on the keyboard is accessible except ctrl-alt-del to reboot if I do it on time. If I delay apparently everything freezes.
Ctrl-alt-Backspace blanks the screen too, however, ctr-alt-F2 gives me a console.

I do not think that this is a coincidence for all 3 distros, it must be a bug in sw-12.

I am reporting this just for developers toward VL based on sw-12 to be aware of. May be it's already old hat.

Regards
Unquote

And true enough, I installed VL-5.9-Beta* and the same as mentioned happens, blank screen when trying to leave X.

Is this particular to my system which I think is kind of standard? I just wonder since there was no reply.

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Slackware-12 X Logout Blanks
« Reply #2 on: October 19, 2007, 11:43:46 pm »
pita,
What kind of video card do you have?

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Slackware-12 X Logout Blanks
« Reply #3 on: October 20, 2007, 11:56:34 am »
I haven't had any screen blanking and loss of keyboard when I leave X (XFce) on my desktop. I start in runlevel 2 and my video card is an ATI Radeon 9200.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Slackware-12 X Logout Blanks
« Reply #4 on: October 20, 2007, 05:18:01 pm »
pita,
What kind of video card do you have?

Unquote

My video card is on the mother board P4VMM2 of Elitegroup.

Built-in Graphic System: P4M266/A integrates S3's Savag4 graphics acceleration into a single chip.....with leading-edge 2D, 3D and DVD video acceleration.
Maximum shared memory size is 32 MB.

Graphics: This mainboard includes an AGP slot that provides four times the bandwidth of the original AGP specification.AGP technologu provides a direct connection between the graphics sub-stystem and memory so that the graphics do not have to compete for processor time with other devices on the PCI bus.

Should I get an external graphic (video?) card and would that improve as well video streaming?

My run level is 3.

Regards

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Slackware-12 X Logout Blanks
« Reply #5 on: October 20, 2007, 06:28:58 pm »
a good quality AGP video card would improve your video streaming.
you could try upgrading your xorg from slack-current to see if it fixes the problems you are having though.

let us know how it goes

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Slackware-12 X Logout Blanks
« Reply #6 on: October 20, 2007, 08:50:06 pm »
a good quality AGP video card would improve your video streaming.
you could try upgrading your xorg from slack-current to see if it fixes the problems you are having though.

let us know how it goes
Unquote

Thanks!

It went badly. Can't open X any more.

(EE) module ABI major version (1) doesn't match the server's version (2)
(EE) Failed to load module "savage" (module requirement mismatch, 0)
dlopen: /usr/X11R6/lib/modules/input//mouse_drv.so: undefined symbol: miPointerGetMotionEvents
(EE) Failed to load /usr/X11R6/lib/modules/input//mouse_drv.so
(EE) Failed to load module "mouse" (loader failed, 7)
(EE) module ABI major version (0) doesn't match the server's version (2)
(EE) Failed to load module "kbd" (module requirement mismatch, 0)
(EE) No drivers available.

Fatal server error:
no screens found
giving up.

Me too, glad to be back in VL-5.8.

It is the xorg-server-1.4-i486-2.tgz I upgraded to.

Regards

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Slackware-12 X Logout Blanks
« Reply #7 on: October 20, 2007, 08:58:06 pm »
Sry pita I should have said you need to upgrade all the xorg packages not just the server 

Pita

  • Vectorian
  • ****
  • Posts: 1324
Re: Slackware-12 X Logout Blanks
« Reply #8 on: October 20, 2007, 10:05:10 pm »
Sorry pita I should have said you need to upgrade all the xorg packages not just the server 
Unquote

That is what I did first in SW-12, then in VL-5.9 only the server after I could not open X any longer in SW getting the same errors as in VL-5.9 now. I mean all the xorg-* except the xorg-doc* using in both boxes pkgtool for the upgrade.

Pita

  • Vectorian
  • ****
  • Posts: 1324
[Solved]Re: Slackware-12 X Logout Blanks
« Reply #9 on: October 21, 2007, 07:34:42 pm »
Finally solved!

This time I did not only upgrade all the xorg-* but everything that starts with an x/X and X comes-up now and I can exit/quit/logout to a functioning console.

Thanks a lot uelsk!
« Last Edit: October 21, 2007, 07:38:28 pm by Pita »