Please support VectorLinux!

Author Topic: updgrading glibc to 2.4 or greater.  (Read 1631 times)

mediahaze

  • Member
  • *
  • Posts: 3
updgrading glibc to 2.4 or greater.
« on: September 27, 2007, 10:20:12 am »
Hello all,

I need glibc 2.4 but looks like I only have access to 2.3 through VL.

What is the proper installation procedure to upgrade the files?


Thanks in advance,

Gav

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: updgrading glibc to 2.4 or greater.
« Reply #1 on: September 27, 2007, 10:23:52 am »
Mediahaze
glibc is a very delicate part of the distro. A propper glibc upgrade would include a gcc, binutils, and glibc upgrade. This would also break compatibility with some things.

Which version of VL do you have installed? and what if I may ask is asking you to install a new glibc ?

Regards, M0E

mediahaze

  • Member
  • *
  • Posts: 3
Re: updgrading glibc to 2.4 or greater.
« Reply #2 on: September 27, 2007, 10:44:02 am »
Thanks MOE,

I am running VL 5.8 SOHO final.

I need 2.4 for developing Java applications using JOGL (Java Open GL).

How much breaking would go on with an upgrade to the latest version of glibc 2.6?

If I did want to do the upgrade, what would be the best way to go about it.

I really like VL but without being able to develop jogl, I cannot continue using it.

Thanks again,



The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: updgrading glibc to 2.4 or greater.
« Reply #3 on: September 27, 2007, 10:52:17 pm »
Quote
How much breaking would go on with an upgrade to the latest version of glibc 2.6?
Probably the whole thing.

Quote
If I did want to do the upgrade, what would be the best way to go about it.
You could try one of the VL 5.9 development releases,it comes with glibc 2.5.
Most music on my soundcloud page was arranged in programs running on VL.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: updgrading glibc to 2.4 or greater.
« Reply #4 on: September 28, 2007, 03:31:57 am »
the_headacher is right. That would be the easiest way to do it. I'm currently using one of those development releases to develop vpackager. it's not as polished up as what you have now but it's a beast under the hood