Please support VectorLinux!

Author Topic: firefox doesn't run  (Read 3612 times)

nulll

  • Member
  • *
  • Posts: 33
    • nulll
firefox doesn't run
« on: October 14, 2007, 11:23:52 am »
the system crashed while i was running firefox.
now firefox doesn't start anymore.
when i runnit from the console this message is returned:
Quote
line 131:  3329 Segmentation fault      "$prog" ${1+"$@"}
what can i do?

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: firefox doesn't run
« Reply #1 on: October 14, 2007, 03:16:34 pm »
What version of Firefox is it? What VL are you running again?  :)

nulll

  • Member
  • *
  • Posts: 33
    • nulll
Re: firefox doesn't run
« Reply #2 on: October 15, 2007, 02:59:46 am »
firefox 2.0 on VL SOHO 5.8

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: firefox doesn't run
« Reply #3 on: October 15, 2007, 03:58:12 am »
I should of read your first post more clearly.  If you system crashed while running Firefox, then I guess it could be possible your FIrefox is buggered up now.  Have you tried re-installing Firefox?  Or updating to the latest version?
Firefox-2.0.0.7 is in the testing repo now.

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: firefox doesn't run
« Reply #4 on: October 15, 2007, 04:10:43 am »
Trying to open firefox with a new profile could be an option to see if it's a profile issue.

firefox -help for flags and options

nulll

  • Member
  • *
  • Posts: 33
    • nulll
Re: firefox doesn't run
« Reply #5 on: October 15, 2007, 04:17:42 am »
Quote
Have you tried re-installing Firefox?  Or updating to the latest version?
i would like to leave this option as a last chance...i'm afraid to loose my firefox add-ons and preference...

Quote
Trying to open firefox with a new profile could be an option to see if it's a profile issue.
firefox -help for flags and options
ok when i'm back home after work i'll give it a try...

Have u got more info about this segmentation fault error?
i'm getting it several times with a couple of apps ... what is about?
« Last Edit: October 15, 2007, 04:19:21 am by nulll »

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: firefox doesn't run
« Reply #6 on: October 15, 2007, 04:55:24 am »
Personally, I've only had segmentation faults when I had a bad stick of ram.

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: firefox doesn't run
« Reply #7 on: October 15, 2007, 06:22:04 am »
Quote
Have u got more info about this segmentation fault error?
segmentation fault (segfault) is a very general error, that's not very useful for troubleshooting or debugging. It means something went wrong trying to read from or write to memory. Usually, it has to do with a program trying to read past the end of data, or otherwise read memory that doesn't contain correct info.

For more info, read http://en.wikipedia.org/wiki/Segmentation_fault .

Quote
Personally, I've only had segmentation faults when I had a bad stick of ram.
I've had them a lot trying to run a program I wrote myself in C. It had to do with trying to read past the end of an array one time.

[edit]
Or was it past the end of a file? I'm not too sure anymore, it was quite a toughy to figure out the first time.
[/edit]

segfaults don't necessarily mean bad memory, it often means something is trying to do something bad with the contents of the memory.

« Last Edit: October 15, 2007, 07:26:58 am by The Headacher »
Most music on my soundcloud page was arranged in programs running on VL.

nulll

  • Member
  • *
  • Posts: 33
    • nulll
Re: firefox doesn't run
« Reply #8 on: October 15, 2007, 10:52:37 am »
thanks for the good explanation Headacher!

i don't know why but after a day of black out FF is running again...and i have done nothing!  :o