VectorLinux
July 29, 2014, 02:27:19 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Please put lyx on 5.9 standard (Solved)  (Read 3148 times)
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #15 on: July 18, 2008, 02:56:37 am »

Hi, there.

To add tetex to the slack-required you can set the ADD variable before requiredbuilder like this:

Code:
echo "Finding dependencies..."
ADD="tetex >= 3.0" requiredbuilder -v -y -s $RELEASEDIR $PKG
echo "Creating package $NAME-$VERSION-$ARCH-$BUILD.tlz"
makepkg -l y -c n $RELEASEDIR/$NAME-$VERSION-$ARCH-$BUILD.tlz

I'm not sure about putting tetex as a dependency, though. The reason being that tetex is only one possible latex distribution (I'm using lyx with texlive).

I'm not sure about what's best though. I think it might be best to leave it without the dependency, because you can inadvertently forget to uncheck tetex for install, and end up with downloading and installing tetex, when you already have some other latex distribution in your machine. On the other hand, if you just install lyx, it wouldn't work because you need latex. But then again, you would know that you need latex if you want lyx, I guess.

Yea, I guess not putting a particular latex as dependency is best... I think the only reason tetex is the only one in the repo is that the whole texlive is massive in terms of size.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!