VectorLinux
November 28, 2014, 09:48:52 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: gslapt not listing xfce as installed, slapt-get --upgrade--> unmet deps errors  (Read 4749 times)
Nick_13ro
Member
*
Posts: 26


« on: October 26, 2007, 06:26:58 pm »

  I just installed Vector 5.8 standard and I have the above problems. gslapt saying that xfce is not installed and, among other things, slapt-get --upgrade says it can't install new xfce because of missing deps. I added the cd as source for packages, it didn't fix anything. Is slapt-get rather broken or somebody removed important packages from the ftp or what ? It's true that I selected not to install a lot of the optional stuff but still shouldn't slapt-get be able to get what it needs ?

  Damn- just saw that one of the things it says it is needed glib2 >= 2.12.10 is not on the ftp at all.  Shocked Same thing with gtk2. Is there another source I need to add or is 5.8 standard no longer supported or something ?

  Output from slapt-get:

root:# slapt-get --upgrade
Reading Package Lists... Done
Excluding gksu, use --ignore-dep to override
Excluding pygtk, use --ignore-dep to override
Excluding librsvg, use --ignore-dep to override
Excluding libglade, use --ignore-dep to override
Excluding gamin, use --ignore-dep to override
Excluding vte, use --ignore-dep to override
Excluding vim, use --ignore-dep to override
Excluding enchant, use --ignore-dep to override
Excluding glibmm, use --ignore-dep to override
Excluding xfce, use --ignore-dep to override
Excluding gtk-engines, use --ignore-dep to override
The following packages have unmet dependencies:
  ORBit2: Depends: glib2 >= 2.12.10
  libglade: Depends: gtk+2 >= 2.10.11
  librsvg: Depends: gtk+2 >= 2.10.11
  gamin: Depends: glib2 >= 2.12.10
  vte: Depends: gtk+2 >= 2.10.11
  vim: Depends: acl >= 2.2.39_1
  enchant: Depends:   glib2 >= 2.12.10
  glibmm: Depends: glib2 >= 2.12.4
  PolicyKit: Depends: glib2 >= 2.12.4
  gtk-engines: Depends:   gtk+2 >= 2.10.11
The following packages have been EXCLUDED:
  gksu pygtk librsvg libglade gamin vte vim enchant glibmm xfce gtk-engines
  kernel-headers
The following NEW packages will be installed:
  dbus-glib dbus-qt3 dbus-python
The following packages will be upgraded:
  unrar gnome-doc-utils parted vl-hot xfce4-xkb-plugin icon-naming-utils x264
  alsa-lib libxml2 libxslt fox dbus gnome-icon-theme gpgme xfce4-notes-plugin
  xfce4-mount-plugin vcpufreq xfe codecs-win32
19 upgraded, 3 newly installed, 0 to remove and 12 not upgraded.
Need to get 22MB of archives.
After unpacking 25MB of additional disk space will be used.
Do you want to continue? [y/N]

Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #1 on: October 26, 2007, 06:46:01 pm »

http://www.vectorlinux.com/forum2/index.php?topic=3681.0
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Nick_13ro
Member
*
Posts: 26


« Reply #2 on: October 26, 2007, 08:41:29 pm »

  Hmm. Weird. Just adding the patches repository solved most of the problems. xfce is suddenly listed as installed too in gslapt. Only one dep error left:

root:# slapt-get --upgrade
Reading Package Lists... Done
Excluding abiword-plugins, use --ignore-dep to override
The following packages have unmet dependencies:
  abiword-plugins: Depends:   aiksaurus >= 1.2.1
The following packages have been EXCLUDED:
  abiword-plugins kernel-headers

EDIT: What ?! But why does it want to install gnome-menus gnome-vfs gnome-desktop nautilus and related stuff ?

The following NEW packages will be installed:
  ORBit2 openldap-client cyrus-sasl GConf dbus-glib dbus-qt3 dbus-python
  gnome-keyring libgtop libgksu gail gnome-menus attr acl samba Linux-PAM
  PolicyKit hal avahi gnome-vfs libbonobo libgnome libbonoboui libgnomeui
  gnome-desktop eel nautilus jack mysql libexif-gtk ctags pycairo pygobject
« Last Edit: October 26, 2007, 08:43:55 pm by Nick_13ro » Logged
hata_ph
Packager
Vectorian
****
Posts: 3259


-- Just being myself --


« Reply #3 on: October 26, 2007, 11:09:48 pm »

did you enable the testing repository in gslapt/slapt-get?
Logged
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1553


I like the bass to go BOOM!


WWW
« Reply #4 on: October 26, 2007, 11:33:33 pm »

You might want to reconsider doing --upgrade... it won't get you much new functionality,  but IS hazardous to your system. And you'll get all those weird packages you don't need Smiley.

Quote
did you enable the testing repository in gslapt/slapt-get?
I'm not a great fan of --upgrade to start with, but I certainly wouldn't do it with testing enabled. The aiksaurus package can be found here:
http://vectorlinux.osuosl.org/veclinux-5.8/testing/x-apps/aiksaurus-1.2.1-i586-2vl58.tlz

You can install it with
Quote
slapt-get --install aiksaurus-1.2.1-i586-2vl58.tlz
Logged

Most music on my soundcloud page was arranged in programs running on VL.
Nick_13ro
Member
*
Posts: 26


« Reply #5 on: October 27, 2007, 06:22:55 am »

did you enable the testing repository in gslapt/slapt-get?

  Nope. It said risky.
Logged
Nick_13ro
Member
*
Posts: 26


« Reply #6 on: October 27, 2007, 06:23:36 am »

  So to update xfce I should just use slapt-get --install xfce or how ?
EDIT: That only installs xfce and a few other things, and it wants to install hal and some new dbus packages.
« Last Edit: October 27, 2007, 06:26:26 am by Nick_13ro » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #7 on: October 27, 2007, 09:02:15 am »

EDIT: What ?! But why does it want to install gnome-menus gnome-vfs gnome-desktop nautilus and related stuff ?

The following NEW packages will be installed:
  ORBit2 openldap-client cyrus-sasl GConf dbus-glib dbus-qt3 dbus-python
  gnome-keyring libgtop libgksu gail gnome-menus attr acl samba Linux-PAM
  PolicyKit hal avahi gnome-vfs libbonobo libgnome libbonoboui libgnomeui
  gnome-desktop eel nautilus jack mysql libexif-gtk ctags pycairo pygobject
I've never tried a --upgrade, seeing as I'm a micro-management freak, but I thought it was only supposed to upgrade the instaled packages, not add new ones. Maybe one of these newer versions has bad dependency info in the package?
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Nick_13ro
Member
*
Posts: 26


« Reply #8 on: October 27, 2007, 11:02:50 am »

EDIT: What ?! But why does it want to install gnome-menus gnome-vfs gnome-desktop nautilus and related stuff ?

The following NEW packages will be installed:
  ORBit2 openldap-client cyrus-sasl GConf dbus-glib dbus-qt3 dbus-python
  gnome-keyring libgtop libgksu gail gnome-menus attr acl samba Linux-PAM
  PolicyKit hal avahi gnome-vfs libbonobo libgnome libbonoboui libgnomeui
  gnome-desktop eel nautilus jack mysql libexif-gtk ctags pycairo pygobject
I've never tried a --upgrade, seeing as I'm a micro-management freak, but I thought it was only supposed to upgrade the instaled packages, not add new ones. Maybe one of these newer versions has bad dependency info in the package?

  I think I narrowed the problem down to gksu- looks like that's what was compiled with gnome support for some reason, that or one of gksu's deps. And I found another problem- the xarchiver package installed was named Xarchiver while the new one was xarchiver, I had to remove the old one myself before upgrade.

Logged
Nick_13ro
Member
*
Posts: 26


« Reply #9 on: October 27, 2007, 11:06:18 am »

  Damn.  Angry After upgrading xfce I can at most get minimized applications icons on desktop. How do I get my desktop back ? And that speakers applet for sound on the taskbar is gone too, I think there may have been another one as well for clipboard maybe also gone (actually from screenshots I think it was calendar).  Undecided Yeahin the menu Mixer settings doesn't work either- says no such plugin sound.
« Last Edit: October 27, 2007, 11:15:35 am by Nick_13ro » Logged
Nick_13ro
Member
*
Posts: 26


« Reply #10 on: October 27, 2007, 12:21:12 pm »

  Thunar wont start now with:

thunar: error while loading shared libraries: libexo-0.3.so.0: cannot open shared object file: No such file or directory

and the Terminal link on the taskbar says it can't find "Terminal"
Logged
Nick_13ro
Member
*
Posts: 26


« Reply #11 on: October 27, 2007, 03:52:01 pm »

  Alright, I decided it was probably too broken so I installed the 5.9 beta2. I miss the link on the taskbar to the system section in 5.8. Anybody got an idea how to change the keymap in xfce ? The xorg.conf setting doesn't work. Configuring it in kcontrol did work, but this is on xfce.
EDIT: It seems there's no romanian quertz keymap installed...  Huh
« Last Edit: October 27, 2007, 03:55:48 pm by Nick_13ro » Logged
hata_ph
Packager
Vectorian
****
Posts: 3259


-- Just being myself --


« Reply #12 on: October 27, 2007, 06:15:09 pm »

did you enable the testing repository in gslapt/slapt-get?

  Nope. It said risky.

some packages that you install using gslapt/slapt-get require some other packages that only avaiable in the testing repository......
actaully it is not risky to enable the testing repository as long as you know what packages you are trying to install or upgrade

You might want to reconsider doing --upgrade... it won't get you much new functionality,  but IS hazardous to your system. And you'll get all those weird packages you don't need Smiley.

Quote
did you enable the testing repository in gslapt/slapt-get?
I'm not a great fan of --upgrade to start with, but I certainly wouldn't do it with testing enabled. The aiksaurus package can be found here:
http://vectorlinux.osuosl.org/veclinux-5.8/testing/x-apps/aiksaurus-1.2.1-i586-2vl58.tlz

You can install it with
Quote
slapt-get --install aiksaurus-1.2.1-i586-2vl58.tlz

upgrading all in VL can harm or even broke your system......just install/upgrade what you really want only...Smiley
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #13 on: October 27, 2007, 06:31:50 pm »

upgrading all in VL can harm or even broke your system....
It really shouldn't for 5.8, as long as you stick to the patches repo. I think a newer gksu package slipped through the packages "quality control", something we had avoided building before because they went full-gnome after the version released on the iso.
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Nick_13ro
Member
*
Posts: 26


« Reply #14 on: October 28, 2007, 08:56:06 am »

  Anybody knows a fix for using scp tp get stuff from Vector and getting this:

 xmodmap:  unable to open display ''

 I did it now on Vector but it gives an error like that from a remote box as well.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!