VectorLinux
November 25, 2014, 06:38:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: VL 5.9beta2 VASM Will Not Allow Copy & Paste For WPA Passcode  (Read 2084 times)
raven
Member
*
Posts: 11


Never more!


« on: October 28, 2007, 03:05:12 pm »

I use a 63 character random passcode for my WPA passcode.  The only way to enter it into VASM without manually typing it is to copy & paste from a text file holding the passcode.

It doesn't work.

Is there a good solution to get the passcode into the wireless config using copy/paste?

Thanks.
Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #1 on: October 28, 2007, 03:33:14 pm »

Just a suggestion as I haven't actually tried it.  But have you tried the "ctrl+c" (copy) and "ctrl+v" (paste) key combo's ?
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #2 on: October 28, 2007, 04:48:43 pm »

Have you tried swiping the passcode with the mouse in the text editor and then hitting the middle mouse button or wheel at the right spot to paste it into VASM? That works in almost all Linux programs, even those that don't understand "paste."
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #3 on: October 28, 2007, 04:52:18 pm »

That too!
Logged
saulgoode
Vectorite
***
Posts: 340



« Reply #4 on: October 28, 2007, 06:36:53 pm »

Try the following:

Select your WPA code using left-click drag then use SHIFT-middle-click to paste it into VASM.

I have not tried this but the theory is that ncurses-based VASM is masking off unmodded mouse events (the above technique is necessary for pasting in MCEDIT, for example).
Logged

A complex system that works is invariably found to have evolved from a simple system that works.
raven
Member
*
Posts: 11


Never more!


« Reply #5 on: October 28, 2007, 07:29:49 pm »

Wow!  What a great bunch of replies!

The ctrl-x , ctrl-v thing works just fine.  Using the mouse for copy/paste does work in the terminal, though.

Now that I can get my passcode into VASM, and VASM tells me I am connected, it is not connected.  Iwconfig in the terminal tells me that the encryption key is off, and I haven't been able to get it to show "on".

As a matter of fact, I am not sure I am getting an IP address from the network.  I can run "dhcpcd ath0", and get no return.

thanks, folks, for the help.

Now, I gotta figure out what else is going on,

Wireless card:  Atheros 5005 Chipset
Compaq Evo P4 computer, 

It is hard to copy the iwconfig and other terminal outputs so that I can go to another computer that is connected to the network.   Vector will not let me access my flash memory thumb drive which is my data transport mode in this project.



Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #6 on: October 29, 2007, 08:11:59 am »

did you try vwifi in the network category in the menu?
try choosing manual and then enter your essid and password
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!