Please support VectorLinux!

Author Topic: Which Uncompression Tool  (Read 2454 times)

Pita

  • Vectorian
  • ****
  • Posts: 1323
Which Uncompression Tool
« on: October 29, 2007, 06:33:21 pm »
Doing "installpkg file.tlz"
I get

Unable to install the package because of missing uncompression tool.

Which uncompressing tool is needed?

Thanks & regards

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Which Uncompression Tool
« Reply #1 on: October 29, 2007, 10:50:39 pm »
tlz packages use lzma compression. The package you're looking for should be called lzma.
Most music on my soundcloud page was arranged in programs running on VL.

Pita

  • Vectorian
  • ****
  • Posts: 1323
Re: Which Uncompression Tool
« Reply #2 on: October 29, 2007, 11:56:44 pm »
tlz packages use lzma compression. The package you're looking for should be called lzma.

Unquote

That's what I thought all the while and it is there:
:$ whereis lzma
lzma: /usr/bin/lzma

Something seemed to have broken. I just used the installpkg command in VL59-BETA-2.4 and it worked.

How will I fix in in VL5.8?

Regards

saulgoode

  • Vectorite
  • ***
  • Posts: 340
Re: Which Uncompression Tool
« Reply #3 on: October 30, 2007, 12:10:34 am »
Your Vector Standard install should have included the packages you need. Do the following files exist?

/var/log/packages/pkgtools-tukaani-1.2_rc1-i486-4vl58
/var/log/packages/lzma-4.32.0_b1-i586-4vl58


EDIT: Missed your previous post. You appear to have the appropriate packages but I would suggest reinstalling them just to be sure that some file has not been deleted.
« Last Edit: October 30, 2007, 12:22:33 am by saulgoode »
A complex system that works is invariably found to have evolved from a simple system that works.

Pita

  • Vectorian
  • ****
  • Posts: 1323
Re: Which Uncompression Tool
« Reply #4 on: October 30, 2007, 01:40:57 am »
It seems to be a merry-go-round:

.-----.-----------------------------------------------------------------------.
| 1/1 | Upgrading lzma-4.32.0_b1-i586-4vl58 using lzma-4.32.0_b1-i586-4vl58.t |
'-----'-----------------------------------------------------------------------'
ERROR: Package is corrupt: /home/ftp/pub/veclinux/packages/./base/lzma-4.32.0_b1-i586-4vl58.tgz

Failed to execute command: [/sbin/upgradepkg --reinstall /home/ftp/pub/veclinux/packages/./base/lzma-4.32.0_b1-i586-4vl58.tgz]


.-----.-----------------------------------------------------------------------.
| 1/1 | Installing pkgtools-tukaani-1.2_rc1-i486-4vl58.tgz                    |
'-----'-----------------------------------------------------------------------'
ERROR: Package is corrupt: /home/ftp/pub/veclinux/packages/./base/pkgtools-tukaani-1.2_rc1-i486-4vl58.tgz
Failed to execute command: [/sbin/installpkg /home/ftp/pub/veclinux/packages/./base/pkgtools-tukaani-1.2_rc1-i486-4vl58.tgz

whereis upgradepkg
upgradepkg: /sbin/upgradepkg /usr/sbin/upgradepkg

Both pkgtool and lzma have been newly placed now into /home/ftp/pub/veclinux/packages/base using gslapt.

Have to make dinner now.

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Which Uncompression Tool
« Reply #5 on: October 30, 2007, 07:13:49 am »
Pita,
Looks like your having fun there.

try installing pkgtools and lzma like this:
Code: [Select]
cd /
tar xvf home/ftp/pub/veclinux/packages/base/pkgtools-tukaani-1.2_rc1-i486-4vl58.tgz
sh install/doinstall.sh
rm -rf install
tar xvf /home/ftp/pub/veclinux/packages/base/lzma-4.32.0_b1-i586-4vl58.tgz
sh install/doinstall.sh
rm -rf install

HTH,
Uelsk8s

jimwill

  • Member
  • *
  • Posts: 43
Re: Which Uncompression Tool
« Reply #6 on: October 30, 2007, 12:33:38 pm »
I've gotten the "ERROR: Package is corrupt" message before too. Then I found that what it really meant was that there was not enough space in root to uncompress it! (almost Windowish!) After removing some stuff (in various folders) under root, the packages installed.

Pita

  • Vectorian
  • ****
  • Posts: 1323
Re: Which Uncompression Tool
« Reply #7 on: October 30, 2007, 07:36:09 pm »
Pita,
Looks like your having fun there.

try installing pkgtools and lzma like this:
Code: [Select]
cd /
tar xvf home/ftp/pub/veclinux/packages/base/pkgtools-tukaani-1.2_rc1-i486-4vl58.tgz
sh install/doinstall.sh
rm -rf install
tar xvf /home/ftp/pub/veclinux/packages/base/lzma-4.32.0_b1-i586-4vl58.tgz
sh install/doinstall.sh
rm -rf install

HTH,
Uelsk8s

Unquote

Thanks a lot! Worked like a charm. Whatever was broken was mended, installpkg etc are working again.

Fun yes, 3 young kids (not mine) on vaccation for 2 weeks. How they can eat!

Regards