VectorLinux
April 24, 2014, 06:19:13 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Starting programs suddenly very slow.  (Read 4491 times)
Pita
Vectorian
****
Posts: 1285


« Reply #15 on: November 22, 2007, 02:54:05 am »

I have never seen Firefox or Seamonkey on the first launch come up in less then 15 seconds with a blank page in any distro. The second launching takes usually 7 sec.
Logged
Kerstin
Member
*
Posts: 26


« Reply #16 on: November 22, 2007, 03:17:19 am »

Anyhow.. starting Enemy territory, usually takes 5-8 sec, takes about a 1 min now. Starting a virtual machine in Virtualbox takes about the same. It's clearly something wrong...
Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #17 on: November 22, 2007, 07:54:32 am »

Kerstin: in my first response to this thread you started I asked you some questions (Nov 8) which you still haven't answered, the answers to some of those and the output posted to this thread might help you resolve your problem. We need some more details from your system to help you.

Also, are you multi-booting that machine and if so, do you get the same slow response on other distros? Try a Live Linux CD, such as Slax, and see if you get the same poor performance from opening programs.

There seems to be a definite network problem. Please post the output also from the following commands run as root in a terminal:

ifconfig
route -n
cat /etc/resolv.conf
cat /etc/rc.d/rc.inet1
cat /etc/rc.d/rc.inet2

« Last Edit: November 22, 2007, 07:57:40 am by lagagnon » Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Kerstin
Member
*
Posts: 26


« Reply #18 on: November 22, 2007, 08:35:25 am »

Kerstin: in my first response to this thread you started I asked you some questions (Nov Cool which you still haven't answered, the answers to some of those and the output posted to this thread might help you resolve your problem. We need some more details from your system to help you.

Also, are you multi-booting that machine and if so, do you get the same slow response on other distros? Try a Live Linux CD, such as Slax, and see if you get the same poor performance from opening programs.

There seems to be a definite network problem. Please post the output also from the following commands run as root in a terminal:

ifconfig
route -n
cat /etc/resolv.conf
cat /etc/rc.d/rc.inet1
cat /etc/rc.d/rc.inet2



Sorry about that, believe me that i appreciate all the help.

ok here we go:

root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:DC:F3:CB:50
          inet addr:83.XXX.XX.127  Bcast:83.XXX.XX.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:800 errors:0 dropped:0 overruns:0 frame:0
          TX packets:756 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:513268 (501.2 KiB)  TX bytes:263437 (257.2 KiB)
          Interrupt:19 Base address:0x6d00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

root:# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
83.XXX.XX.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         83.XXX.XX.1     0.0.0.0         UG    0      0        0 eth0

root:# cat /etc/resolv.conf
# Generated by dhcpcd for interface eth0
nameserver 82.209.169.71
nameserver 82.209.169.72

root:# cat /etc/rc.d/rc.inet1

#!/bin/sh
# This file is supposed to be created by vnetadd
# and modified by vnetset.
# You can modify it by hand, but be careful ;-)
#
# GNU GPL  (c) Eko M. Budi, 2004
#          (c) Vector Linux, 2004
#

###########################################################
## The settings
DEVICE='eth0'
DHCP='yes'
IPADDR='127.0.0.1'
NETMASK='255.255.255.0'
GATEWAY=''
PROBE='no'

###########################################################
## The script

## You may make customized script here
## If not, source the standard network
. /etc/rc.d/functions-network "$@"

Edit: I ran ubuntu live-cd and everything is ok there.
« Last Edit: November 22, 2007, 08:50:42 am by Kerstin » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #19 on: November 22, 2007, 05:11:38 pm »

Kerstin: there is nothing particularly obviously wrong with your network configuration files, at least from what I can see. You mentioned that a ping to your server was fast - was it in the order of 10's of milliseconds? Try that and report back.

The only thing I can think of now is you somehow have a corrupt system for one reason or other. I asked you before but you never replied - did you do a system upgrade with gslapt? Do you have a lot of data? Could you not try a re-install perhaps?  This is a last resort but what you experiencing is not normal and suggests a bad install or bad setup originally or a corruption from some bad upgrade process....
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Kerstin
Member
*
Posts: 26


« Reply #20 on: November 22, 2007, 11:15:59 pm »

I did a system upgrade. Going to follow your recommendation and do a reinstall before I go nuts. Anyway thanks for all the effort :-)
Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #21 on: November 23, 2007, 07:37:42 am »

I did a system upgrade.
Kerstin: system upgrades are not really recommended, nor necessary in the Linux world. It is possible to do them of course with gslapt, but they are rarely necessary and tend to cause more problems than they solve. The only valid reasons for upgrading would be to upgrade a specific package due to serious security concerns with an old version or to enable new features in a new version of a package.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Kerstin
Member
*
Posts: 26


« Reply #22 on: November 23, 2007, 08:14:28 am »

Ok.. But i did that AFTER the problem to seen if that would make any difference. I'm aware of that it is not necessary to upgrade(in that case i would stick to ubuntu  Wink)
Logged
Kerstin
Member
*
Posts: 26


« Reply #23 on: December 19, 2007, 09:27:45 am »

Alright. did a complete reinstall and now everything is just fine  Cheesy . Firefox etc. starts in a few seconds as it suppose to do in vectorlinux, you just gotta love it :-D
Logged
newt
Vectorian
****
Posts: 1132



« Reply #24 on: December 19, 2007, 11:40:29 am »

Regarding slow Firefox performance:
FWIW, I recently noticed that if root uses the built-in 'Upgrade' feature of Firefox that the responsiveness of firefox (and all other gecko-related programs) is negatively affected.  I don't know if you had performed this action prior to your complete reinstall, but if you had then that could be the culprit for the slow responsiveness of firefox.  I had done this myself and noticed the degraded performance, however it was easily fixed by upgrading the installed firefox package through gslapt to the latest.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!