Please support VectorLinux!

Author Topic: new kernel to try.----2.6.23.1  (Read 4967 times)

vector

  • Administrator
  • Vectorite
  • *****
  • Posts: 479
new kernel to try.----2.6.23.1
« on: November 10, 2007, 10:43:19 pm »
all of you testing vl59 I would like you to test a new kernel. It's usually a bad idea to swap kernels late in the development cycle but there are enough reports of strange hw related problems that I would like to give this a test. This is the latest from Linus and friends and only contains the bootsplash patch. I would especially encourage granny geek to try this on her problematic laptop as I really would like one kernel to work for all. Links are below just run /sbin/lilo after the install and you should be good to go.
http://vectorlinux.osuosl.org/Uelsk8s/kernel-STD-2.6.23.1-i586-1vl59.tlz
http://vectorlinux.osuosl.org/Uelsk8s/kernel-modules-2.6.23.1-i586-1vl59.tlz
Install kernel first then modules then run lilo.
Please test and let us know if this helps hinders or anything else you can report.

Thanks,
Vec
« Last Edit: November 10, 2007, 10:51:40 pm by vector »

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: new kernel to try.----2.6.23.1
« Reply #1 on: November 11, 2007, 09:36:37 am »
The 2.6.23.1 kernel works for me. ;-)

Cheers,
John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: new kernel to try.----2.6.23.1
« Reply #2 on: November 11, 2007, 09:51:49 am »
Haven't tried these packages in particular, but kernel 2.6.23.1 + TuxOnIce works like magic.

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: new kernel to try.----2.6.23.1
« Reply #3 on: November 11, 2007, 11:28:29 am »
2.6.23.1 works fine here (though testing has been a bit limited so far...).

I'm still having to explicitly load the Intel Pro 100 ethernet driver. Tried pulling out the /sbin/modprobe e100 from /etc/rc.d/rc.modules, but, whether I've got the e100 or the eepro100 module blacklisted, none of them load without being called through rc.moudes.

More later...

paul.

MikeCindi

  • Tester
  • Vectorian
  • ****
  • Posts: 1073
Re: new kernel to try.----2.6.23.1
« Reply #4 on: November 11, 2007, 09:57:01 pm »
No problems here even with my Intel Pro 100 VE (built-in laptop chip). I'm in the middle of using the config file to add TuxOnIce support and customizing for my laptop and noted that there is support for rtl-8187 wireless chipsets. Looks like I'll be working on trying to get my TRENDnet USB wireless working with VL too.
The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: new kernel to try.----2.6.23.1
« Reply #5 on: November 12, 2007, 10:51:01 pm »
I'm very eager to try this kernel, but I don't think I can until it's incorporated into the next ISO. The laptop that has proved troublesome has Windows Vista installed on it and I don't want to put LILO or GRUB in the MBR. If anything went wrong, I don't think I could get back into Vista without running the Restore Disk--a horrid thought because I'd have to repartition the drive and reinstall everything. Vista does not use the boot.ini method like earlier versions of NT did (hence no fixmbr) and I haven't been able to figure out how to add a non-Windows OS to the way Vista boots. Vista does not offer the Recovery Console.

So I boot with the VL CD this way: sata2 root=/dev/hda6 ro

I don't think I can boot to the new kernel with the VL CD for rc1.

If anyone has a solution, please let us know.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: new kernel to try.----2.6.23.1
« Reply #6 on: November 13, 2007, 03:28:14 am »
GrannyGeek: Why not try LILO with a floppy?  Up until recently I was doing it that way as my MBR was on a defunked drive that I couldn't yank until I recovered some data off of it.  Floppy worked very well with only a slight delay.
Your Vista wouldn't even have to know about it.

stoichyu

  • Packager
  • Vectorite
  • ****
  • Posts: 369
Re: new kernel to try.----2.6.23.1
« Reply #7 on: November 13, 2007, 05:02:33 am »
There's no place like ~.
VL 5.8 PentiumD 2.8Ghz Registered Linux User #432836

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: new kernel to try.----2.6.23.1
« Reply #8 on: November 13, 2007, 01:46:34 pm »
GrannyGeek: Why not try LILO with a floppy?  Up until recently I was doing it that way as my MBR was on a defunked drive that I couldn't yank until I recovered some data off of it.  Floppy worked very well with only a slight delay.
Your Vista wouldn't even have to know about it.

Have you bought a computer in the past few years? Floppy drives have become a rarity, first on laptops and now on desktops. I have four computers now, two desktops and two laptops. Only one computer has a floppy drive. My newer desktop does not offer booting from a USB floppy drive as an option and my older laptop wants only a certain Toshiba USB floppy drive for booting. My new Gateway laptop (the one that is picky about kernels) would probably boot from a USB floppy drive, but I wouldn't spend $20 or more just for booting when I have other options (i.e., the VL installation CD).

My older desktop does have a floppy drive and I boot VL betas and release candidates from it. Once a Gold version comes out, I modify my XP boot.ini file and use the XP boot loader, which works splendidly. Vista, alas, has done away with the boot.ini file and uses some sort of boot table that is obscure and that I can't figure out. I did download a program called EasyBCD that's a front end to the new Vista boot thing but I haven't looked into it yet.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: new kernel to try.----2.6.23.1
« Reply #9 on: November 13, 2007, 01:54:37 pm »
@GrannyGeek: I think this is what you need: http://raviratlami1.blogspot.com/2007/03/windows-vista-multiboot-nightmare.html

Thanks for that link. I downloaded EasyBCD a few weeks ago when I first started researching a dual-boot Vista and Linux, but I haven't done anything with it yet. My plan was to wait until VL went Gold and then look into my dual-boot options. I booted my old laptop through the VL installation CD for years and it's fine. However, you can't modify it the way you can with LILO, so if you want to add another kernel you're out of luck.

I hope EasyBCD will provide what I'm looking for.
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: new kernel to try.----2.6.23.1
« Reply #10 on: November 13, 2007, 04:57:45 pm »
Quote
Have you bought a computer in the past few years? Floppy drives have become a rarity,
That's a valid point!  :)
No I haven't "bought" one. I've been building them for awhile, although it's been a couple years since building my best one (God rest it's soul).  I'm on a relic until I get the $$ for a replacement cpu.

Pita

  • Vectorian
  • ****
  • Posts: 1325
Re: new kernel to try.----2.6.23.1
« Reply #11 on: November 18, 2007, 12:40:53 am »
Has anyone tried to print with this kernel?

For me it does not print neither in VL5.9 nor in VL5.8!

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: new kernel to try.----2.6.23.1
« Reply #12 on: November 18, 2007, 06:04:16 am »
Has anyone tried to print with this kernel?

For me it does not print neither in VL5.9 nor in VL5.8!

I'm using kernel 2.6.23.1 on a box with VL 5.9 RC1 and am able to print from it. Ensure that the CUPS service is running on your box by pointing your web browser to 127.0.0.1:631 and see whether the CUPS administrative panel shows up.

HTH,
John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: new kernel to try.----2.6.23.1
« Reply #13 on: November 18, 2007, 07:23:31 am »
Also make sure to check that lp is listed in lsmod.

Bigpaws

Pita

  • Vectorian
  • ****
  • Posts: 1325
Re: new kernel to try.----2.6.23.1
« Reply #14 on: November 18, 2007, 05:08:36 pm »
I put the output of lsmod in the bugs discussion of VL59-RC1.3 and lp is there.

I can print with kernel 2.6.21.1, why not with kernel 2.6.23.1 with the identical settings in cups both in VL5.9 and VL5.8-STD. I try to print with 2.6.23.1 and the print queue shows what should be printed yet nothing happens. Changing to kernel 2.6.21.1 and all what is in the print queue left from kernel 2.6.23.1 is printed even before the booting is fully completed.

So where isn the bug in kernel 2.6.23.1?

My Epson LQ300 printer is connected to an USB port via an adaptor cable from the parallel outlet at the printer. Is it that kernel 2.6.23.1 cannot read that usb port?
« Last Edit: November 18, 2007, 05:11:06 pm by Pita »