VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [SOLVED] Cdrom mount trouble  (Read 1767 times)

gafran

  • Member
  • *
  • Posts: 23
[SOLVED] Cdrom mount trouble
« on: November 17, 2007, 03:42:17 pm »

When i try to mount a cdrom in my cdrom drive nothing happens.What can i do,pls?This is my /etc/fstab
Code: [Select]
# /etc/fstab: static file system information.
#
# The following is an example. Please see fstab(5) for further details.
# Please refer to mount(1) for a complete description of mount options.
#
# Format:
# <file system>   <mount point>   <type>   <options>   <dump> <pass>
#
# dump(8) uses the <dump> field to determine which file systems need
# to be dumped. fsck(8) uses the <pass> column to determine which file
# systems need to be checked--the root file system should have a 1 in
# this field, other file systems a 2, and any file systems that should
# not be checked (such as MS-initrd/mnt or NFS file systems) a 0.

# The Linux partitions
/dev/hda1 / reiserfs  noatime  0  1

# Shared Windows/Linux partition
#/dev/hda1   /mnt/dos  msdos  umask=0   0  0
#/dev/hda1   /mnt/win  vfat   fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
#/dev/hda1   /mnt/win  ntfs   umask=0   0  0

# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.
/dev/fd0   /mnt/floppy auto defaults,noauto,user 0 0
#/dev/fd1  /mnt/floppy auto defaults,noauto,user 0 0

# If you have a ls-120 floppy drive, it could be on /dev/hda b c d etc.
#/dev/hdd /mnt/ls120 auto defaults,noauto,user 0 0

# CDROM, CDWRITER, DVD
/dev/cdrom /mnt/cdrom iso9660 users,noauto,ro
/dev/cdwriter /mnt/cdwriter iso9660 users,noauto,ro
/dev/dvd /mnt/dvd iso9660 users,noauto,ro

# NFS file systems:
#linux01.gwdg.de:/suse/6.3/i386.de  /mnt/nfs  nfs  defaults  0 0

# proc file system:
proc /proc proc defaults 0 0

# Unix98 devpts filesystem:
none  /dev/pts  devpts  gid=5,mode=666  0 0

# Shared memory filesystem:
tmpfs   /dev/shm    tmpfs defaults 0  0

# Basic USB filesystem
sysfs  /sys  sysfs  defaults  0 0

# example of a VFAT USB pendrive
#/dev/sda1  /mnt/pendrive vfat   fmask=111,dmask=0,noauto,user,quiet,shortname=mixed 0 0


# Swap partitions
# The 'sw' option means auto activating with 'swapon -a'.
/dev/hda5   none   swap   sw   0  0
This is the output of mount /dev/cdrom /mnt/cdrom
Code: [Select]
mount /dev/cdrom /mnt/cdrom
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: /dev/cdrom already mounted or /mnt/cdrom busy
mount: according to mtab, /dev/hdc is already mounted on /mnt/cdrom
Thank you in advance.
« Last Edit: November 18, 2007, 10:18:48 pm by JohnB316 »
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1871
Re: Cdrom mount trouble
« Reply #1 on: November 17, 2007, 06:23:55 pm »

Please the version you are using.

After the command mount /dev/cdrom /mnt/cdrom
go to /mnt/cdrom and your files will be there.

Unless you are using a music cd which does not
get mounted.

Bigpaws
Logged

gafran

  • Member
  • *
  • Posts: 23
Re: Cdrom mount trouble
« Reply #2 on: November 18, 2007, 04:37:58 am »

I using the new VL 5.9 rc.How can i open a music cd,pls?
Logged

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: Cdrom mount trouble
« Reply #3 on: November 18, 2007, 06:01:08 am »

I using the new VL 5.9 rc.How can i open a music cd,pls?

Gafran,

Music CD's are not mounted as data CD's, because they don't have a filesystem that can be mounted, as Bigpaws pointed out in his reply to you. Instead, put the music CD into the CD or DVD drive and use something like Mplayer to play the music on the CD.

Hope this helps.
John
Logged
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

gafran

  • Member
  • *
  • Posts: 23
Re: Cdrom mount trouble
« Reply #4 on: November 18, 2007, 08:25:47 am »

Oh yes,it worked with Xine.Thank you very much :)
Logged