Please support VectorLinux!

Author Topic: Keyboard layout  (Read 1478 times)

gafran

  • Member
  • *
  • Posts: 23
Keyboard layout
« on: November 18, 2007, 04:43:03 am »
I am trying to change the layout of my keyboard into the italian one.Then i click on VASM,setup keyboard map,it,ok but nothing changes.What can i do pls?Should i download the italian library?Where can i find it?My VL is 5.9 rc.Thanx.

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: Keyboard layout
« Reply #1 on: November 19, 2007, 03:27:43 am »
A search in the forums for "keyboard layout" will give you many results, solving your problem.
You should edit /etc/X11/xorg.conf (as root) and change the xkbdLayout to your language (IIRC)

No need to install extra libraries.

Best Regards

gafran

  • Member
  • *
  • Posts: 23
Re: Keyboard layout
« Reply #2 on: November 19, 2007, 03:35:08 am »
This is the way i have changed my xorg.conf but no way:
Code: [Select]
Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option     "XkbRules" "xorg"
Option  "XkbLayout"  "it"
Option  "XkbModel" "pc105"
EndSection
Bye.

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: Keyboard layout
« Reply #3 on: November 19, 2007, 05:43:17 am »
5.9 is still in the testing stage. This may be a bug that should be reported here:
http://www.vectorlinux.com/forum2/index.php?board=30.0
Pick the thread that corresponds with the RC version you are using, 1 or 1.3.

If you want a stable version, 5.8 is a good choice. Especially the SOHO version, as KDE has additional international features.

gafran

  • Member
  • *
  • Posts: 23
Re: Keyboard layout
« Reply #4 on: November 19, 2007, 10:12:18 am »
I have reported the bug,Nightflier.My version is 5.9 rc1.