VectorLinux
April 24, 2014, 11:51:38 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: resolution problem on intel board  (Read 1950 times)
prasad
Member
*
Posts: 7


« on: November 27, 2007, 11:24:46 pm »

Hello,

VL 5.8 soho worked fine on my system (mobo:intel 915gav) till I bought a new widescreen lcd monitor with a resolution of 1440x900. The screen area is covered fully, but the fonts are not crisp. Control center shows a resolution of 1024x768 and didn't have 1440x900 as required resolution. I tried things like putting in correct values for HorizSync and VertRefresh and modelines generated by gtf. Sometimes  the resolution changes to 1600x1200 and i have to pan the desktop. I noted from internet that some intel boards have this problem and tried the utility called 915resolution. It changes the bios settings alright, but VL still does not work correctly.

I then tried many other distros and none of them set the resolution correctly at during installation. With Mandriva, I was able to tweak xorg.conf so that the resolution is shown correctly as 1440x900, but the fonts were uglier. I then tried putting this xorg.conf file under VL, but this time the fonts appeared huge and i didn't have the patience to check what the resultiong was.

Any help will be highly appreciated. Thanks.
Prasad.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #1 on: November 28, 2007, 06:23:34 am »

915 resolution does work on VL.. I've used it before. Not sure if it can do your particular resolution, but normally you'll need to isntall it and do some testing ... This is best done from cli

Code:
915resolution -l
will get you a list of the supported modes

You'd pick one that's not being used and patch it with you resolution
Code:
915resolution xx 1440 900 24
where xx = the mode you picked from the list (ie 5d, 4a, etc)

You'd also need to set your /etc/X11/xorg.conf to use that resolution with a 24bit depth

Start X and see if it's right
If it fails, pick another mode from the list and use the same values until it works

When you finally get the one that works, make sure you remember wich mode worked and you'll need to add that to your /etc/rc.d/rc.local to make sure it looks good every time you boot

The manual says to add it as the last line in the file, but I've found that if you do that, sometimes it does not work... so I'd add it right after the
Code:
#!/bin/bash
line to make sure it does get patched.

your line should look like this
Code:
/absolute/path/to/915resolution xx 1440 900 24

HTH.
« Last Edit: December 03, 2007, 06:05:17 am by M0E-lnx » Logged

prasad
Member
*
Posts: 7


« Reply #2 on: December 03, 2007, 02:44:36 am »

Hello
I tried the suggestions. The only way I can force the resolution to 1440x900 seems to be by setting ALL modes using 915resolution. Then the control center does show the resolution correctly, but the fonts are horrible. Also the top and bottom portions of the screen  are not visible (only the top edge of the panel is visible, and so the bubble help is the only way to move around). I checked the monitor controls and verified that wrong setting is not the issue here.

Waiting for any possible way out.

Incidentally, I have Win XP  on the same machine and works without a hitch.

Prasad
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #3 on: December 03, 2007, 06:07:40 am »

You really dont need to set ALL modes.
Just find one that you know for a fact your monitor does not use (ie 800x600 @ 24 or 32bit)

also, make sure your /etc/X11/xorg.conf has the right mode listed under the right resolution

it should be set to DefaultDepth = 24
and under modes it should look like this
Code:
Modes "1440x900"
Logged

prasad
Member
*
Posts: 7


« Reply #4 on: December 06, 2007, 02:30:40 am »

Thanks for the input. If I leave at least one resolution, other than 1440x900, the system takes that. Setting ALL modes to 1440x900 seems to be the only way I can get to the required resolution. ( By the way, if i change the mode setting for any one resolution using 915resolution then all color depths for that resolution changes. I suppose that is normal)

Prasad.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!