VectorLinux
April 17, 2014, 04:46:20 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Multimedia Bonus Disc Alpha 3 Released  (Read 5147 times)
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« on: December 03, 2007, 08:15:17 pm »

Multimedia Bonus Disc Alpha 3 has been released! Bug reports and suggestions would be greatly appreciated. Please report bugs here: http://www.vectorlinux.com/forum2/index.php?topic=4040.msg32356#new

Download the ISO here:
http://vectorlinux.osuosl.org/Uelsk8s/old-pkgs/MultimediaBonusDisc-Alpha3.iso

Complete list of included packages:
Code:
./AMB-plugins-0.3.0-i586-1vl59.tlz
./ardour-2.1-i586-1vl59.tlz
./arts-1.5.8-i586-1vl59.tlz
./audacity-1.3.4-i586-1vl59.tlz
./autotrace-0.31.1-i586-1vl59.tlz
./avidemux-2.4_preview3-i586-1vl59.tlz
./bitmeter-1.2-i586-1vl59.tlz
./blender-2.45-i586-1vl59.tlz
./blop-0.2.8-i586-1vl59.tlz
./caps-plugins-0.4.2-i586-1vl59.tlz
./cinepaint-0.22.1-i586-1vl59.tlz
./cmake-2.4.6-i486-1as.tgz
./csound-5.07.0-i586-1vl59.tlz
./cvs-1.11.22-i586-1vl59.tlz
./denemo-0.7.6-i586-1vl59.tlz
./dssi-0.9.1-i586-1vl59.tlz
./dvdauthor-0.6.14-i586-1vl59.tlz
./dvd-slideshow-0.8.0_1-noarch-1vl60.tlz
./dvgrab-3.0-i586-1vl59.tlz
./ffmpeg2theora-0.19-i586-1vl59.tlz
./fftw-3.1.2-i586-1vl59.tlz
./FIL-plugins-0.1.0-i586-1vl59.tlz
./fltk-1.1.7-i586-1vl59.tlz
./fluidsynth-1.0.8-i586-1vl59.tlz
./fontforge-20071110-i586-1vl59.tlz
./freeglut-2.4.0-i586-1vl59.tlz
./gc-6.8-i586-1vl59.tlz
./glew-1.4.0-i586-1vl59.tlz
./gst-python-0.10.8-i586-1vl59.tlz
./gtick-0.4.1-i586-1vl59.tlz
./guile-1.8.3-i586-1vl59.tlz
./heimdal-1.0.1-i586-2vl59.tlz
./hydrogen-0.9.3-i586-1vl59.tlz
./ilmbase-1.0.1-i586-1vl59.tlz
./Imaging-1.1.6-i586-1vl59.tlz
./jackbeat-0.6.1-i586-1vl59.tlz
./jackEQ-0.4.1-i586-1vl59.tlz
./jack-0.103.0-i586-1vl59.tlz
./jack-rack-1.4.6-i586-1vl59.tlz
./jamin-0.95.0-i586-1vl59.tlz
./jam-2.5-i586-1vl59.tlz
./jdelay-noversion-i586-1vl59.tlz
./kdebase-3.5.8-i586-1vl59.tlz
./kdebindings-3.5.8-i586-1vl59.tlz
./kino-1.1.1-i586-1vl59.tlz
./ladspa-1.12-i586-1vl59.tlz
./lash-0.5.3-i586-1vl59.tlz
./libatomic_ops-1.2-i586-1vl59.tlz
./libavc1394-0.5.3-i586-1vl59.tlz
./libgig-3.1.1-i586-1vl59.tlz
./libgnomecanvas-2.14.0-i586-1vl59.tlz
./libgsasl-0.2.21-i586-1vl59.tlz
./libiec61883-1.1.0-i586-1vl59.tlz
./liblo-0.24-i586-1vl59.tlz
./liblrdf-0.4.0-i586-1vl59.tlz
./liblscp-0.5.3-i586-1vl59.tlz
./libmad-0.15.1b-i586-1vl59.tlz
./libpano12-2.8.6-i586-1vl59.tlz
./libpano13-2.9.12-i586-1vl59.tlz
./libquicktime-1.0.0-i586-1vl59.tlz
./libsamplerate-0.1.2-i586-1vl59.tlz
./libsigc++-2.0.18-i586-1vl59.tlz
./libsndfile-1.0.17-i586-1vl59.tlz
./libxmi-1.2-i586-1vl59.tlz
./lilypond-2.10.33-i586-1vl59.tlz
./linuxsampler-0.4.0-i586-1vl59.tlz
./lives-0.9.8.6-i586-1vl59.tlz
./mandvd-2.4-i686-1vl60.tlz
./manslide-1.9-i586-1vl59.tlz
./MCP-plugins-0.3.0-i586-1vl59.tlz
./mftrace-1.2.14-i586-1vl59.tlz
./mhwaveedit-1.4.13-i586-1vl59.tlz
./mixxx-1.5.0.1-i586-1vl59.tlz
./mjpegtools-1.9.0rc2-i586-1vl59.tlz
./muse-0.9-i586-1vl59.tlz
./mysql-5.0.45-i586-1vl59.tlz
./noteedit-2.8.1-i586-1vl59.tlz
./omins-0.2.0-i586-1vl59.tlz
./openexr-1.6.1-i586-1vl59.tlz
./pigment-0.3.2-i586-1vl59.tlz
./portaudio-20071002-i586-1vl59.tlz
./potrace-1.8-i586-1vl59.tlz
./pulseaudio-0.9.8-i586-1vl59.tlz
./python-setuptools-0.6c7-i586-1vl59.tlz
./qdvdauthor-1.0.0rc3-i586-1vl59.tlz
./qjackctl-0.3.1a-i586-1vl59.tlz
./qsampler-0.1.4-i586-1vl59.tlz
./qsynth-0.3.1-i586-1vl59.tlz
./qt4-4.3.2-i586-1vl59.tlz
./qtractor-0.0.8.762-i586-1vl59.tlz
./raptor-1.4.16-i586-1vl59.tlz
./requiredbuilder-0.16.3-noarch-1stb.tgz
./REV-plugins-0.3.1-i586-1vl59.tlz
./rosegarden-1.5.1-i586-1vl59.tlz
./scons-0.97-i586-1vl59.tlz
./scrollkeeper-0.3.14-i586-1vl59.tlz
./soundtouch-1.3.1-i586-1vl59.tlz
./sox-14.0.0-i586-1vl59.tlz
./swami-0.9.4-i586-1vl59.tlz
./sweep-0.9.2-i586-1vl59.tlz
./swh-plugins-0.4.15-i586-1vl59.tlz
./t1utils-1.32-i586-1vl59.tlz
./tapiir-0.7.2-i586-1vl59.tlz
./tap-plugins-0.7.0-i586-1vl59.tlz
./terminatorX-3.82-i586-1vl59.tlz
./tetex-3.0-i586-1vl59.tlz
./tetex-doc-3.0-i586-1vl59.tlz
./TiMidity++-2.13.2-i586-1vl59.tlz
./tovid-0.31-i586-1vl59.tlz
./transcode-20070917-i586-1vl59.tlz
./tse3-0.3.1-i586-1vl59.tlz
./ttf2pt1-3.4.4-i586-1vl59.tlz
./twolame-0.3.10-i586-1vl59.tlz
./txt2tags-2.4-noarch-1vl59.tlz
./VCO-plugins-0.3.0-i586-1vl59.tlz
./vkeybd-0.1.17a-i586-1vl59.tlz
./wxGTK-2.8.6-i586-1vl59.tlz
./XML-Twig-3.32-i586-1vl59.tlz
./yafray-0.0.9-i586-1vl59.tlz

Have fun!  Smiley
« Last Edit: December 03, 2007, 08:28:04 pm by Dweeberkitty » Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #1 on: December 03, 2007, 09:55:47 pm »

A small update for anyone wishing to use the Multimedia Bonus Disc with gslapt (will let you install individual packages)
the only changes this adds is the package info for slapt-get/gslapt.

 delta is here: http://ftp.osuosl.org/pub/vectorlinux/Uelsk8s/old-pkgs/MMBD-A3toA3.1.delta 80K
iso is here: http://ftp.osuosl.org/pub/vectorlinux/Uelsk8s/old-pkgs/MultimediaBonusDisc-Alpha3.1.iso

after mounting the cd you add the mount point to gslapt and select the packages

Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #2 on: December 04, 2007, 04:21:43 am »

Nice uelsk8s!  That makes the disc more appealing.  IMO
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #3 on: December 04, 2007, 04:40:07 am »

Dweeberkitty, I cant find the enblend package in your contrib, even though there is s source directory for it there.

I'm busy moving the bonus disc stuff now while I have a chance Tongue

EDIT: can't find the fluidsynth-dssi binary either.
EDIT2: wxPython package not there.
« Last Edit: December 04, 2007, 06:15:38 am by easuter » Logged

rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #4 on: December 04, 2007, 06:00:57 am »

Great Job, this is really nice for those who likes to play with this stuff, like me.
Kdelibs is missing. So kdebase, noteedit and others will not install. I disabled all the other repos to test properly, is suposed to work like this? This is, is the cd independent or it will pull deps from the vl repo as well? If the second please ignore this.
Jamin and othe jack apps complains about some plugins missing. I will post the error messages when I get the time, I lost my inet connection at home, again Sad
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #5 on: December 04, 2007, 01:53:43 pm »

Thanks Uelsk8s

Great Job, this is really nice for those who likes to play with this stuff, like me.
Kdelibs is missing. So kdebase, noteedit and others will not install. I disabled all the other repos to test properly, is suposed to work like this? This is, is the cd independent or it will pull deps from the vl repo as well? If the second please ignore this.
Jamin and othe jack apps complains about some plugins missing. I will post the error messages when I get the time, I lost my inet connection at home, again Sad


Kdelibs is included in VL. I don't know what the problem is there. Will look into it though. Some error messages for the missing plugins might be nice. What programs did you install? Everything? or just a few choices?

Dweeberkitty, I cant find the enblend package in your contrib, even though there is s source directory for it there.

I'm busy moving the bonus disc stuff now while I have a chance Tongue

EDIT: can't find the fluidsynth-dssi binary either.
EDIT2: wxPython package not there.

Hmmmm... enblend and fluidsynth-dssi should have been compiled. I'll check on that. The wxPython package doesn't exist yet.
« Last Edit: December 04, 2007, 01:55:18 pm by Dweeberkitty » Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #6 on: December 04, 2007, 02:23:54 pm »

Kdelibs is included in VL. I don't know what the problem is there. Will look into it though. Some error messages for the missing plugins might be nice. What programs did you install? Everything? or just a few choices?

Yes, but seems like the packages are looking for another version of kdelibs. We are experiencing some problems with the kdelibs package. Looks like every package was built against a different version than the shipped in the iso, but for some reasons the apps are not pulling the kdelibs package from testing and they don't work with the one in the iso. The easiest solution could be just upgrade the iso package, since it is used just by k3b.
I will check when I get home, and will post the error messages about the plugins too.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #7 on: December 04, 2007, 02:26:05 pm »

Oh I forgot, I installed some apps only, not the full iso. Ardour, jackd, timidity, blender, yafray, cinepaint, hydrogen, qtractor and perhaps I am missing some others. All of them working exept those with kdelibs as dependencies, like noteedit.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #8 on: December 04, 2007, 02:32:56 pm »

the full kdelibs package is not on the last 5.9 iso
you will need to get it from the testing repo.
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #9 on: December 04, 2007, 03:01:13 pm »

the full kdelibs package is not on the last 5.9 iso
you will need to get it from the testing repo.

Yes, I noted all the kde apps works with the one in testing. The thing is the kde apps are not pulling the package in testing, so they don't work. The kdelibs in testing should be listed as required for all the kde apps, or the full kdelibs package should be in the iso. In other way we will have a bunch of non working apps when 5.9 goes gold.
In addition, if the multimedia bonus disc (from here 'mbd' Grin) is intented as a 'stand alone disc', i.e, it will include the apps and ALL the deps, should include kdelibs.

Dweeberkitty: jackeq complains about dj_eq_1901.so
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #10 on: December 04, 2007, 03:24:23 pm »

Eauster, I fixed enblend and fluidsynth-dssi. The problem with enblend was a problem with glew. I fixed that and re-uploaded glew.

Perhaps the problem with kde apps is that I built everything on RC1.7. Maybe something changed with kdelibs since then? What version of VL are you using rbistolfi?
Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #11 on: December 04, 2007, 03:25:20 pm »

I am using the latest RC3 right now.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #12 on: December 04, 2007, 03:26:43 pm »

Okay, I probably need to update.
Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #13 on: December 05, 2007, 12:34:03 am »

In addition, if the multimedia bonus disc (from here 'mbd' Grin) is intented as a 'stand alone disc', i.e, it will include the apps and ALL the deps, should include kdelibs.
You know very well that it makes no sense to include ALL the deps, it would never fit. Instead, include just the ones that aren't on 5.9 standard already. kdelibs already comes with VL 5.9, no need to have people double download it. The version on 5.9 rc3 SHOULD be updated to the last one in the repo when it's rc4 time though.

The kdebase on this 'mbd' overwrote my perfectly working kdebase (I used the install.sh script). Ultra annoying, had to reinstall the one in the repo to get the VL customized one back.
« Last Edit: December 05, 2007, 12:35:46 am by The Headacher » Logged

Most music on my soundcloud page was arranged in programs running on VL.
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #14 on: December 05, 2007, 06:36:25 am »

You know very well that it makes no sense to include ALL the deps, it would never fit. Instead, include just the ones that aren't on 5.9 standard already. kdelibs already comes with VL 5.9, no need to have people double download it. The version on 5.9 rc3 SHOULD be updated to the last one in the repo when it's rc4 time though.

Yep, I know, when I said 'all' I meant 'all missing in the iso', there was nothing else intented in my post, sorry if it sounded in a wrong way. I understand from the Uel post that the kdelibs package is not the full vanilla kde package. I assume is a trimed one with the necessary stuff for 5.9 Std. In that case, kdelibs becomes a dependency not available in the system. In the other hand, gslapt / slapt-get is not upgrading to the kdelibs in the testing repo automagically. I just wanted to help out pointing there is something to fix there. In other way we will get a bunch of "Amarok is not working" threads at the forum.

LOL I like your new 'Louder than you' sign, nobody could say it doesn't fit with your avatar Smiley. And, after all, a global moderator is who speaks louder Wink
« Last Edit: December 05, 2007, 06:40:37 am by rbistolfi » Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!