VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: VasmCC Bug Report Thread & Introduction  (Read 18796 times)

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
VasmCC Bug Report Thread & Introduction
« on: December 05, 2007, 10:28:32 am »

Many of you have already seen the new Configuration GUI for VL 5.9 called VasmCC.
The original idea came from a conversation uelsk8s and I had on IRC. He asked if this could be done, and I gave it a shot. That's the story of how VasmCC was born.
I think a propper introduction of this application is overdue, so here it goes

What it is
VasmCC is not meant to replace vasm. Instead, VasmCC is simply a small application written in Gambas2 that is extremely expandable. In fact, VasmCC uses the original VASM to do what it does. VasmCC simply dresses up the options (up to some level) and allows easy access to system settings using vasm.

How does it work?
VasmCC reads .desktop files and acts according to the information on these files. You can have as many .desktop files as you want / need for each category.

What's with the name?
VasmCC is for "VASM Control Center"

Now that we've got that cleared out, Please report any bugs / problems you encounter while using this application on VectorLinux 5.9 here on this thread. Please include as many details as you can.

My creativity is somewhat limited sometimes, so suggestions are also welcome
« Last Edit: August 31, 2011, 02:06:28 pm by M0E-lnx »
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: VasmCC Bug Report Thread & Introduction
« Reply #1 on: December 19, 2007, 07:40:32 am »

Maybe this was already reported elsewhere, but I couldn't add a user using VasmCC (although it works using VASM) using VL 5.9 RC3 .
In the UID screen it gives me a message sating that UIDs need to be integers. It didn't accept the default 1001, and I tried typing it myself as well, with no luck.

Thanks.
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VasmCC Bug Report Thread & Introduction
« Reply #2 on: December 19, 2007, 08:11:24 am »

I'm not sure what is causing this problem here... I've heard about, I'll take a look at the code when I get a chance

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: VasmCC Bug Report Thread & Introduction
« Reply #3 on: December 19, 2007, 08:28:33 am »

I'm not sure what is causing this problem here... I've heard about, I'll take a look at the code when I get a chance

I have no idea how the hell vasmCC influences the execution of vuseradd, but it is fixed by replacing line 109 in vuseradd with

Code: [Select]
  elif [ "`echo $U_ID | perl -wnle 'print unless /^\d+$/'`" ]; then
Logged
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VasmCC Bug Report Thread & Introduction
« Reply #4 on: December 19, 2007, 08:41:33 am »

vasmCC does not influence the call to vuseradd. It just executes this line in the .desktop file
Code: [Select]
Exec=<this_is_what_vasmcc_executes>

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: VasmCC Bug Report Thread & Introduction
« Reply #5 on: December 19, 2007, 08:48:13 am »

vasmCC does not influence the call to vuseradd. It just executes this line in the .desktop file
Code: [Select]
Exec=<this_is_what_vasmcc_executes>

Apparently it has some influence  ???
Logged
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months

kidd

  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: VasmCC Bug Report Thread & Introduction
« Reply #6 on: December 24, 2007, 03:08:46 am »

The partitioning program (under Filesystem section) seems its not correctly linked to vasmCC.

VL5.9 std

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VasmCC Bug Report Thread & Introduction
« Reply #7 on: December 26, 2007, 08:15:15 am »

The partitioning program (under Filesystem section) seems its not correctly linked to vasmCC.

VL5.9 std

Look @ the .desktop file and try to execute the partitioning program by hand... if it does, then the .desktop file itself may need some tweaking

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: VasmCC Bug Report Thread & Introduction
« Reply #8 on: January 02, 2008, 05:46:12 am »

The problem is definitely in the partitioning program (vfdisk) . At least here ( 5.9 deluxe), vfdisk does not work in VasmCC, "plain" vasm, or in the command line, and instead shows up Xdialog.
(As I reported, I think in RC3, it worked in normal vasm, but not in VasmCC; none of them work now).
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VasmCC Bug Report Thread & Introduction
« Reply #9 on: January 02, 2008, 07:18:35 am »

The problem is definitely in the partitioning program (vfdisk) . At least here ( 5.9 deluxe), vfdisk does not work in VasmCC, "plain" vasm, or in the command line, and instead shows up Xdialog.
(As I reported, I think in RC3, it worked in normal vasm, but not in VasmCC; none of them work now).
vfdisk works here(5.9 deluxe) in all 3.
how many hard drives do you have?
 
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: VasmCC Bug Report Thread & Introduction
« Reply #10 on: January 02, 2008, 02:39:40 pm »

Quote
vfdisk works here(5.9 deluxe) in all 3.
how many hard drives do you have?

Strnge  :o  I have only one hard drive... a SATA one.
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VasmCC Bug Report Thread & Introduction
« Reply #11 on: January 04, 2008, 09:10:19 am »

Annoyance:
I still have not tried this myself (working together with the entire distro that is), but i read a review where some of the settings listed on vasmCC cannot be ran under X.
I would suggest removing these from vasmCC if they will only lead the user to a dead-end screen.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: VasmCC Bug Report Thread & Introduction
« Reply #12 on: January 04, 2008, 10:28:04 am »

A very minor one: I noticed that changing the window size or maximizing the app has no use and make vasm to look weird. Could the window have a non-modificable size?
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: VasmCC Bug Report Thread & Introduction
« Reply #13 on: January 04, 2008, 10:36:03 am »

We could, but the reason I made it resizable is because of the different desktop sizes. if I make it small enough to fit in a 640x480 then it'll look way too small to the people with big screens. With that said, I think it should be left resizable, that way if you have a large display, you can resize it to whatever you like, dont need to maximize it if you dont want to

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: VasmCC Bug Report Thread & Introduction
« Reply #14 on: January 04, 2008, 10:50:05 am »

Quote
you can resize it to whatever you like, dont need to maximize it if you dont want to

And any chance of having it remember the dimensions (and perhaps desktop position) of the previous run?
I find I have to resize it everytime I use it, using a 1440x900 display, or I get some of the icons not showing and, IIRC, no scroll bar.

Thanks a lot!
Logged
Pages: [1] 2