VectorLinux
November 21, 2014, 09:45:11 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [Solved] Wbar on Startup  (Read 3955 times)
jasmc
Member
*
Posts: 16



« on: December 05, 2007, 09:58:44 pm »

Hi Everybody.........I was wondering is there a way to make wbar start automatically during startup.  I really like the way it works and have figured out how to modify what you can have on the bar, I just would like to have it start and be there when the system starts.  Thanks in advance for any help and advice.

Cheers
« Last Edit: December 10, 2007, 02:07:42 pm by jasmc » Logged

Vector 5.9 Gold on Dell c840
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #1 on: December 06, 2007, 01:54:29 am »

Hi Everybody.........I was wondering is there a way to make wbar start automatically during startup.  I really like the way it works and have figured out how to modify what you can have on the bar, I just would like to have it start and be there when the system starts.  Thanks in advance for any help and advice.

I presume that you are using Xfce as your desktop environment (  Grin if only because wbar does start automatically when you run Fluxbox). Easy to do with Xfce.

Go to Settings > Autostarted Applications. Click on Add and fill in the details. That creates a ~/.config/autostart/wbar.desktop file. If you want to change the way Wbar is loaded, you will need to edit that file, since the Autostarted Apllications menu entry does not permit editing, just adding and removing.

I created a script which is called by ~/.config/autostart/wbar.desktop. I did that because I found that if I log out and then log back in, wbar starts too quickly and does not paint the background correctly. The script s as below:

Code:
#!/bin/bash
sleep 2
wbar -above-desk -p bottom -isize 34 -z 1.8 -j 1.0 -bpress -nanim 3

That 'sleep 2' allows enough delay for Xfce to stabilize before wbar is started. I put the script into a ~/bin directory which is added to my path by ~/.bashrc, but I found that I have to specify an absolute path to it in the wbar.desktop file.

paul.

Logged
jasmc
Member
*
Posts: 16



« Reply #2 on: December 06, 2007, 03:29:18 am »

Thanks Paul,  I tried the Autostart Apps, but it did not work.  I am not sure I have linked it to the right area to start the wbar app.  Would you be able to give me a step by step process on how to use you script?  Being new to Linux I am unsure of some of the commands that you have given.  If you could help me further it would be greatly appreciated.

Cheers
Logged

Vector 5.9 Gold on Dell c840
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #3 on: December 06, 2007, 04:48:07 am »

Thanks Paul,  I tried the Autostart Apps, but it did not work.  I am not sure I have linked it to the right area to start the wbar app.  Would you be able to give me a step by step process on how to use you script?  Being new to Linux I am unsure of some of the commands that you have given.  If you could help me further it would be greatly appreciated.

Sure. There are lots of things to confuse you when you first start with Linux. This is the file produced by Settings > Autostarted Applications:

Code:
[Desktop Entry]
Encoding=UTF-8
Version=0.9.4
Type=Application
Name=wbar
Comment=ToolBar
Exec=/home/red2/bin/startwbar
StartupNotify=false
Terminal=false
Hidden=false

The other thing that you need to do is make sure the script is executable - as below:

Code:
chmod +x /home/red2/bin/startwbar

The other thing you can try, which requires less work is to specify 'vlbar' as the program for Autostarted Applications. I didn't do that because I wanted to change some of the settings for Wbar and didn't want to change a system file, since it would probably be overwritten by any updates. If you are happy with the defaults that are used in /usr/bin/vlstart, you should simply be able to specify it rather than creating your own script - you can leave that until you want to make changes to the Wbar startp options.

Hope that helps. If you're still having problems, let me know....

paul
Logged
jasmc
Member
*
Posts: 16



« Reply #4 on: December 10, 2007, 02:07:02 pm »

Hi.......just to let you know Paul, that with your help I have Wbar working exaclty as I wish, again thanks heaps for your help

Cheers


Jason
Logged

Vector 5.9 Gold on Dell c840
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!