VectorLinux
July 23, 2014, 09:42:16 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Synaptics touchpad 5.9rc3 ( solved )  (Read 1382 times)
dieseldog442
Member
*
Posts: 2


« on: December 06, 2007, 06:30:43 pm »

I receive the following failure in xorg.log when I try to load the synaptics driver.
I'm currently dual booting with Slackware 12 and the driver works fine,so I've ruled out the hardware.
It seems to be related to xorg 7.3.


(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
dlopen: /usr/lib/xorg/modules/input//synaptics_drv.so: undefined symbol: miPointerGetMotionEvents
(EE) Failed to load /usr/lib/xorg/modules/input//synaptics_drv.so
(II) UnloadModule: "synaptics"
(EE) Failed to load module "synaptics" (loader failed, 7)


Any help is appreciated, looking forward to the final release.
Update:

I now have a working touchpad by following the instructions posted here:
http://www.linuxquestions.org/questions/slackware-14/synaptics-driver-on-xorg-7.3-592525/
follow the guide exactly and build your own package, a great learning experience.

Before you begin download and build the package for git here:
http://riksun.riken.go.jp/pub/pub/Linux/slackware/slackware-current/source/d/git/

I don't know if this is the best way or the easiest way to get the synaptics driver working but it worked for me
and it works very well. You will also need to modify the xorg.conf file.

Good Luck







« Last Edit: December 07, 2007, 07:20:35 pm by dieseldog442 » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3177



« Reply #1 on: December 06, 2007, 06:39:18 pm »

how did you install the driver?
Logged

dieseldog442
Member
*
Posts: 2


« Reply #2 on: December 06, 2007, 07:34:33 pm »

First I tried the synaptics driver that was preinstalled in 5.9 with no luck.
I tried compiling the driver from source, synaptics - 0.14.6, but that also failed
as a last resort I copied the driver from my Slack 12 install.
My google research seems to indicate an issue with xorg 7.3 but not much info out there.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!