April 20, 2015, 11:53:39 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: ALSA Hassles  (Read 1898 times)
Posts: 52

« on: December 20, 2007, 06:14:42 pm »

I'm using Vectorlinux-5.8-SOHO-FINAL release on a Dell Optiplex 260 with 1 GB of RAM. I'm using an M-Audio Delta 410 multitrack sound card, which I chose for its compatibility with Linux. It worked just fine with Windows 98SE and Debian, SUSE and Ubuntu.

As I've pointed out in another thread, I've been having problems recording in Audacity, probably due to ALSA issues. I've also had other problems with apps like Mplayer which use ALSA. Switching from ALSA to OSS helped out MPlayer, but I cannot use it with Audacity; it just doesn't work. I get error messages when trying to record, or Audacity freezes. Audacity wants ALSA, all there is to it.

I tried shutting off ifplugd as another user suggested. Nothing happened, no improvement, same skipping while recording from an analogue device (a cassette deck). The VU meters which display audio going through the program, input and output, looked very choppy. It was like Audacity was being prevented from running properly by something else in the system. (No other apps were running).

XMMS plays normally (though it uses the OSS sound drivers). VLC plays sound OK. When Mplayer runs, set to use ALSA, it flashes the message "alsa-control: unable to find simple control 'PCM',0" (the error message box flickers constantly through video playback and the output is really choppy).

This is  either a bug in ALSA itself or a bad setting that I do not know how to fix.

I'm using an M-Audio Delta 410 multitrack sound card. When I go to adjust its parameters either using the terminal version of ALSA, or gamix, nothing is labeled very clearly; I don't really know which sliders and buttons do what. There are way more than the expected number of input and output controls, including some whose functions I never saw while running the card under Windows. It's not straightforward at all, it's very cryptic to me.

How can I fix things here?

The Headacher
Louder than you
Global Moderator
Posts: 1553

I like the bass to go BOOM!

« Reply #1 on: December 21, 2007, 12:31:26 am »

Please don't double post. You can continue with the old thread, there's nothing wrong with it. Having all the info in the same place will help to keep track of possible problems and/or solutions. 2 threads about the same problem is just plain confusing.

Convenient link to the "original" thread:
* The Headacher locks the topic
« Last Edit: December 21, 2007, 12:34:02 am by The Headacher » Logged

Most music on my soundcloud page was arranged in programs running on VL.
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!