VectorLinux
October 31, 2014, 05:57:59 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Is it possible to run compiz-fusion on VL59RC3 with ATI card?  (Read 3316 times)
florut
Member
*
Posts: 34



WWW
« on: December 10, 2007, 03:24:56 pm »

Hi,

I really spent a while to try to install compiz-fusion on VL 5.9 RC3 and cannot make it !

I have an ATI Mobility X700 with latest ati drivers installed and working : 
Quote
root:# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X700
OpenGL version string: 2.1.7059 Release
and here is my xorg.conf

I compiled and installed compiz-fusion 0.52 an 0.6.2 with everything that should be needed (according to both compiz-fusion and VL-wiki documentation)

but when I load compiz window decorations disappears and freezes (i cannot move any window and cannot use anyone under the one in use)
Quote
flo:$ compiz --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0


Anyone could run compiz-fusion on VL59RC3 with ATI card ? Is it only possible ?
Logged

Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG
M0E-lnx
Administrator
Vectorian
*****
Posts: 3187



« Reply #1 on: December 11, 2007, 06:15:41 am »

I have only managed to get it to work with intel cards, but I've seen that error in the past on ATI. That usually indicates a driver problem. You can try a different driver and see if that would work.

See here
http://bbs.archlinux.org/viewtopic.php?pid=297404
Logged

florut
Member
*
Posts: 34



WWW
« Reply #2 on: December 11, 2007, 02:20:36 pm »

Thanks for care Moe !

I've indeed tried oldest ATI driver versions but result is worse :
- versions before 8.42 does not support xorg7.3
- compiz is not supposed to work with 8.42 (i tried anyway and get a beautiful white screen)
- compiz is supposed to work with last 8.43 driver (see here) but I can't make it. Compiz does not want to load itself...
Logged

Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG
M0E-lnx
Administrator
Vectorian
*****
Posts: 3187



« Reply #3 on: December 11, 2007, 02:28:44 pm »

Some ATI cards have problem with AIGLX... it just doesn't work.. you need to run XGL instead, which is an entirely different story... and I can't help you much there... never had to run that.
Logged

uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #4 on: December 11, 2007, 03:52:44 pm »

I did have this working on 5.9 a while back so i am pretty sure its doable.
do you have packages made?
if not it will be a bit before i can try to see if i can get it working on my ati laptop.

let me know,
Uelsk8s
Logged
florut
Member
*
Posts: 34



WWW
« Reply #5 on: December 12, 2007, 02:17:44 pm »

Quote
Some ATI cards have problem with AIGLX... it just doesn't work.. you need to run XGL instead, which is an entirely different story... and I can't help you much there... never had to run that.
Actually compiz ran fine and smoot on my laptot with xorg7.3 on Linux Mint (Ubuntu) with no XGL.
AIGLX support is supposed to be fixed in the last ATI drivers...
Indeed I could try with XGL but it's hard to setup (and not much doc for slackware).

Quote
I did have this working on 5.9 a while back so i am pretty sure its doable.
do you have packages made?
if not it will be a bit before i can try to see if i can get it working on my ati laptop.
I made packages for most of the packages needed. Some like Beryl would not be created by VLpackager  Huh You can get all my packages and sources here.
Logged

Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #6 on: December 12, 2007, 05:56:12 pm »

I get a 404 error trying to get the packages
Logged
florut
Member
*
Posts: 34



WWW
« Reply #7 on: December 13, 2007, 04:41:05 am »

Sorry my mistake. Here you are.
Logged

Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG
florut
Member
*
Posts: 34



WWW
« Reply #8 on: December 25, 2007, 10:27:32 am »

So any news on compiz-fusion running ?

I still can't make it at all !! Even with latest ATI drivers
Logged

Proudly running VL 5.9 DLX GOLD 2.6.22.14 + KDE 3.8
...on my ASUS laptop with Pentium-M @1.8Ghz + ATI Mobility X700 + Intel Wireless 2200BG
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #9 on: December 25, 2007, 10:37:54 am »

no good news from the ati front.
I couldnt get it working with your packages, so I tried them on an nvidia machine and they wouldnt work there either.
I got some new packages with the 5.9 Deluxe and I got them working on nvidia right away, but no luck with ati yet.

from what I have read it is supposed to be a driver problem, but I havent found any drivers that work yet.
I will try to get the new open source radeon drivers put together later in the week and see if they help.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!