VectorLinux
October 24, 2014, 11:22:09 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Kernel Panics on new Vector 5.8 SOHO install  (Read 1684 times)
emi
Member
*
Posts: 21


« on: December 23, 2007, 10:04:59 pm »

hello all and merry xmas.

I have just installed Vector 5.8 SOHO on an Acer Aspire 4520 AMD athalon 64 x2 laptop to dual-boot with vista and I'm having a hell of a time troubleshooting this problem with my kernel.

Kernel panics when trying to load the root (ext3) filesystem:

VFS: Cannot open root device "sda3" or unknown-block(0,0)
Please append a correct "root=" boot option

I've tried putting in sdb3 hda3 hdb3 no luck. I would expect this behavior if sata support was not compiled into the kernel, but i'm using the vector linux default so I know it is. /boot/grub/device.map is:

(hd0) /dev/sda

so that can't be it either.
What really confuses me is that if I boot sda3 off the installation disk by typing

linux root=/dev/sda3 ro

at the prompt then I boot into sda3 no problem. A diff between the $INSTALLCD/isolinux/sata and the kernel on the hard drive came out clean. Since it's the same kernel, why doesn't it boot off the hard drive? For fun I tried copying $INSTALLCD/isolinux/initrd.img to my /boot and using that instead but it didn't work.

Then I tried using lilo instead, but I get:

VFS: Cannot open root device "803" or unknown-block(8,3)
Please append a correct "root=" boot option

Removing the root= altogether yields:

VFS: Cannot open root device "NULL" or unknown-block(8,3)
Please append a correct "root=" boot option

I've tried recompiling the kernel and running mkinitrd, no dice. There is an option in the BIOS to have SATA in IDE mode or AHCI mode, neither one works.

Any help would be much appreciated. Thanks all.
« Last Edit: December 23, 2007, 10:09:41 pm by emi » Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #1 on: December 24, 2007, 03:01:40 am »

Quote
Then I tried using lilo instead, but I get:

How are you trying to boot VL? Did you install
lilo? If you did where did you install it ... MBR?
Is this a new kernel and what file system are did
you use?

The root partition is not being found, so either the
partition map is wrong or the file system is not
compiled into the kernel. After appending lilo did you
run lilo as root to update the changes? That gets
some every once in awhile.

It is assumed the MD5 check was successful.

Bigpaws

Logged
emi
Member
*
Posts: 21


« Reply #2 on: December 24, 2007, 09:15:35 am »

I was using grub first, installed in MBR, but when it didn't work I then tried LILO, also in MBR, but that didn't work either.

For the root filesystem I have an ext3 filesystem on the 3rd partition. I was using the default vector kernel. The MD5 was correct, plus I've installed Vector on 3 other similar laptops with the same installation media without a problem.

The root partition is not being found, so either the
partition map is wrong or the file system is not
compiled into the kernel.

This is exactly what I would expect the problem to be, but of course the default vector kernel has sata and ext3 capabilities, and the disk has a very simple partition scheme:

[ACER RECOVER 9GB]::::[VISTA - NTFS 50GB]::::[EXT3 Linux /  - 50GB ]::::[SWAP 1 GB]

The installation disk recognized these as sda[1-4].  As I mentioned before I can boot sda3 from the installation disk with "linux root=/dev/sda3 ro" so I can't see why the kernel on the hard drive, which is bit for bit exactly the same as the one in isolinux/sata (I checked), would get confused.
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #3 on: December 24, 2007, 10:32:25 am »

I have had problems with grub and a nasty
time removing it.

Lilo does not use hd0 as a parameter.

It would be root = /dev/sda1 <replace with proper partition>
then as root in console lilo -v

As far as grub my experiences have pushed me to lilo
not that grub is bad just that for me I have had problems
with it.

HTH

Bigpaws
Logged
emi
Member
*
Posts: 21


« Reply #4 on: December 26, 2007, 12:08:10 am »

After many hours of testing I finally found the solution so I'll post it for future reference.

My SATA drive (I think it's connected to a nvidia nForce 610m) operates in AHCI or IDE mode depending a setting in the BIOS. I had tried booting with both settings and the default vector kernel but it couldn't find my hard drive either way. The solution was to compile a new kernel with AHCI completely disabled (CONFIG_SATA_AHCI=n) and then boot with the drive in IDE mode. Maybe the kernel ignores the bios setting and assumes AHCI capabilities regardless of how the drive is actually operating, or maybe the kernel doesn't support AHCI in this hardware for some reason....? Well it works now so whatever.

Thanks and happy holidays.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!