VectorLinux
April 25, 2014, 12:24:40 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: 071212 skype-1.4.0.118-noarch  (Read 3533 times)
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« on: December 12, 2007, 07:41:25 pm »

Mr. hanumizzle has packaged skype in a fashion that will keep us from getting in trouble.  It's available for both VL5.8 and VL5.9

Package (VL5.8): http://vectorlinux.osuosl.org/veclinux-5.8/testing/net/skype-1.4.0.118-noarch-2.tlz
Package (VL5.9): http://vectorlinux.osuosl.org/veclinux-5.9/testing/net/skype-1.4.0.118-noarch-2.tlz

Quote
skype: Skype 1.4.0.118 (Internet telephony)
skype:
skype: Skype is an Internet telephony program that allows users to contact
skype: other Skype users online at no charge, as well as connect to land
skype: lines and cell phones at a fee. Skype also incorporates instant
skype: messaging, file transfer and a number of other features.
skype:
skype: SUPER DUPER LEGAL install script written by hanumizzle.

Please let us know if this package works ok for you, or report any problems in this thread.

Edit: Links above edited to reflect newer version of package.
« Last Edit: December 19, 2007, 06:14:35 am by exeterdad » Logged
mr_volvo
Member
*
Posts: 36


« Reply #1 on: December 18, 2007, 09:21:42 pm »

Hi I just tried installing the package and this was the result:

Code:
Executing install script for skype-1.4.0.118-noarch-1...
--12:26:38--  http://download.skype.com/linux/skype-1.4.0.118.tar.bz2
           => `skype-1.4.0.118.tar.bz2'
Resolving download.skype.com... 198.173.5.11, 209.0.200.3
Connecting to download.skype.com|198.173.5.11|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 13,200,492 (13M) [application/octet-stream]

100%[====================================>] 13,200,492    24.49K/s    ETA 00:00

12:40:46 (15.21 KB/s) - `skype-1.4.0.118.tar.bz2' saved [13200492/13200492]

sed: can't read /var/log/setup/tmp/files.skype-1.4.0.118-noarch-1: No such file or directory
BUG in dotnew_add: filelist does not exist. Press enter.

and this is what happened after I pressed enter:
Code:
grep: /var/log/setup/tmp/files.skype-1.4.0.118-noarch-1: No such file or directory
grep: /var/log/setup/tmp/files.skype-1.4.0.118-noarch-1: No such file or directory
grep: /var/log/setup/tmp/files.skype-1.4.0.118-noarch-1: No such file or directory
grep: /var/log/setup/tmp/files.skype-1.4.0.118-noarch-1: No such file or directory

I'm going to try installing the static package from skype.com and see how that works...
Logged

Vector 5.8 SOHO on
Dell Latitude C400 (1Ghz, 256mb)
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #2 on: December 18, 2007, 09:43:26 pm »

I just tried it here on 5.9, and i got no errors installing, but I dont get a menu launcher for it, and running skype from a terminal gets this error
Code:
uel:$ skype
bash: /usr/bin/skype: Permission denied
then after changing permissions on the file I get this
Code:
uel:$ skype
skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #3 on: December 18, 2007, 09:52:55 pm »

http://www.sendspace.com/file/r89vio

Try now

Perhaps you need to run ldconfig, uelsk8s? QtDBus is included in qt4, a dependency.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
mr_volvo
Member
*
Posts: 36


« Reply #4 on: December 18, 2007, 10:53:43 pm »


Worked perfectly. May I ask what the change you made was?
Logged

Vector 5.8 SOHO on
Dell Latitude C400 (1Ghz, 256mb)
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #5 on: December 18, 2007, 11:12:06 pm »

Perhaps you need to run ldconfig, uelsk8s? QtDBus is included in qt4, a dependency.
thats what i get for downloading from the link in the first post.
Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?

Thanks hanumizzle
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #6 on: December 18, 2007, 11:16:47 pm »


Worked perfectly. May I ask what the change you made was?

I gave it the Magic Hanumizzle Touch®. No, actually the only thing I did was set usr/bin/skype in the install skeleton to executable permissions.

Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?

I have continuing problems with the repo, and so I leave sendspace links for exeterdad or easuter.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #7 on: December 19, 2007, 06:17:43 am »

I'm really sorry folks, Hanu updated his package in a timely matter.  I moved it into the repo yesterday, but failed to remove the old one and update the links in this thread.  Should be all set now.  Sorry for the chaos it has caused.
Logged
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #8 on: December 19, 2007, 06:20:13 am »

Quote
Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?
I wonder as well.  Installing the package from the link is asking for troubles as the dependencies aren't resolved.
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #9 on: December 19, 2007, 06:37:02 am »

Quote
Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?
I wonder as well.  Installing the package from the link is asking for troubles as the dependencies aren't resolved.

Ok, exeterdad, I'll send the links to you (cc: easuter) via PM in the future.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #10 on: December 19, 2007, 06:49:18 am »

Quote
Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?
I wonder as well.  Installing the package from the link is asking for troubles as the dependencies aren't resolved.

Ok, exeterdad, I'll send the links to you (cc: easuter) via PM in the future.

That's great Hanu, but "your" links weren't the ones I'm talking about.  I'm talking about the links the "repo-guys" post when announcing a new package.

Your links for package contributions in the packagers board are great IMO as more people that have repo access can assist with moving them to their place. And it's less steps for you when submitting since you'll be making a post anyway over there.
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #11 on: December 19, 2007, 07:28:59 am »

Quote
Why do we post the links, when we should be promoting the use of slapt-get/gslapt anyway?

Well, it was part of the "standard" set in the repo maintainer's guide that JohnB316 wrote. Its was probably relevant to post links in "Ye Olde Days" when package management wasn't so great....
Probably something we could drop (at least for the binary packages). The source links are still useful though; I for one love dissecting exeterdad's scripts for some of the nastier packages Cheesy
Logged

exeterdad
Moderator
Vectorian
*****
Posts: 2046



« Reply #12 on: December 19, 2007, 07:37:23 am »

Quote
I for one love dissecting exeterdad's scripts for some of the nastier packages
I do the same to you guys.  Where do you think much of the code in my templates comes from?  Smiley

Unless anyone objects.  I'll stop including direct links to the packages in the future.  If someone needs to obtain the package, there are plenty of other ways to do so.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3943



« Reply #13 on: December 27, 2007, 10:29:01 am »

VL 5.8 SOHO:

Depends alsa-lib >= 1.0.15   Most recent showing in gslapt is 1.0.14a  I installed anyway.
Had to change permissions on /usr/bin/skype to make it executable.
Now missing libQtDBus.so.4.
Installed Qt4. Next error:
Code:
$ skype
skype: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by skype)
skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by skype)

Edit: Downloaded and installed cxxlibs-6.0.8-i486-4 from slackware.it Works now.
« Last Edit: December 27, 2007, 12:12:50 pm by nightflier » Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #14 on: December 27, 2007, 05:41:02 pm »

VL 5.8 SOHO:

Depends alsa-lib >= 1.0.15   Most recent showing in gslapt is 1.0.14a  I installed anyway.
Had to change permissions on /usr/bin/skype to make it executable.
Now missing libQtDBus.so.4.
Installed Qt4. Next error:
Code:
$ skype
skype: /usr/lib/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by skype)
skype: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.4' not found (required by skype)

Edit: Downloaded and installed cxxlibs-6.0.8-i486-4 from slackware.it Works now.

I made the package for VL 5.9. Anyway, the newest one should not have the executable problem.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!