VectorLinux
September 01, 2014, 10:42:14 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Virtual Box kernel driver not accessible  (Read 2752 times)
Andy Price
Packager
Vectorite
****
Posts: 237


« on: December 18, 2007, 06:23:43 pm »

Hi

I'm running VL5.8. I just installed the latest Virtualbox from the repos. It installed ok, but when I created a virtual machine and tried to run it I got an error message about the kernel driver. So I went back and installed the kernel driver from the repos as well (the one for VL5.Cool, but I still get an error when I try to start a virtual machine:

VirtualBox kernel driver not accessible, permission problem.
VBox status code: -1909 (VERR_VM_DRIVER_NOT_ACCESSIBLE).
Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

I'm new to Virtualbox so I wonder if there's something I overlooked? Do I need to set permissions on the kernel driver, and if so, how?

Thanks for any help
Andy

Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #1 on: December 18, 2007, 07:50:10 pm »

Did you add yourself to voxusers?

Bigpaws
Logged
newt
Vectorian
****
Posts: 1132



« Reply #2 on: December 18, 2007, 08:51:57 pm »

I had similar problems in the past with virtualbox and had to manually load the module every time (as root with virtualbox closed): modprobe vboxdrv
Then start virtualbox and give it a whirl.
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #3 on: December 19, 2007, 04:44:38 pm »

Thanks for the tips. Bigpaws, I found there was no group called voxusers. I created one and added myself just in case, but I still got the error. Newtor, in my case vboxdrv was already loaded, though I did try run the modprobe command as you suggested. Still no joy.

In desperation I uninstalled and reinstalled (showing my Windows background) and.... yep, it works ok now! I would have preferred to know why it didn't work the first time though...

Anyway, thanks for the fast responses. I might have some more VirtualBox questions soon...
Andy
Logged
MikeCindi
Tester
Vectorian
****
Posts: 1073


« Reply #4 on: December 20, 2007, 12:20:17 pm »

I have had similar experience with VirtualBox. After loading the first time get the error the reload and all is well. That is until VL5.9 which I have not yet gotten vbox 1.5.2 to work with yet.
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!