Please support VectorLinux!

Author Topic: ALSA Hassles  (Read 1902 times)

youngtomedison

  • Member
  • *
  • Posts: 52
ALSA Hassles
« on: December 20, 2007, 06:14:42 pm »
I'm using Vectorlinux-5.8-SOHO-FINAL release on a Dell Optiplex 260 with 1 GB of RAM. I'm using an M-Audio Delta 410 multitrack sound card, which I chose for its compatibility with Linux. It worked just fine with Windows 98SE and Debian, SUSE and Ubuntu.

As I've pointed out in another thread, I've been having problems recording in Audacity, probably due to ALSA issues. I've also had other problems with apps like Mplayer which use ALSA. Switching from ALSA to OSS helped out MPlayer, but I cannot use it with Audacity; it just doesn't work. I get error messages when trying to record, or Audacity freezes. Audacity wants ALSA, all there is to it.

I tried shutting off ifplugd as another user suggested. Nothing happened, no improvement, same skipping while recording from an analogue device (a cassette deck). The VU meters which display audio going through the program, input and output, looked very choppy. It was like Audacity was being prevented from running properly by something else in the system. (No other apps were running).

XMMS plays normally (though it uses the OSS sound drivers). VLC plays sound OK. When Mplayer runs, set to use ALSA, it flashes the message "alsa-control: unable to find simple control 'PCM',0" (the error message box flickers constantly through video playback and the output is really choppy).

This is  either a bug in ALSA itself or a bad setting that I do not know how to fix.

I'm using an M-Audio Delta 410 multitrack sound card. When I go to adjust its parameters either using the terminal version of ALSA, or gamix, nothing is labeled very clearly; I don't really know which sliders and buttons do what. There are way more than the expected number of input and output controls, including some whose functions I never saw while running the card under Windows. It's not straightforward at all, it's very cryptic to me.

How can I fix things here?


The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: ALSA Hassles
« Reply #1 on: December 21, 2007, 12:31:26 am »
Please don't double post. You can continue with the old thread, there's nothing wrong with it. Having all the info in the same place will help to keep track of possible problems and/or solutions. 2 threads about the same problem is just plain confusing.

Convenient link to the "original" thread: http://www.vectorlinux.com/forum2/index.php?topic=4876.msg33835#msg33835
* The Headacher locks the topic
« Last Edit: December 21, 2007, 12:34:02 am by The Headacher »
Most music on my soundcloud page was arranged in programs running on VL.