VectorLinux
September 01, 2014, 10:14:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Arts message, but sound working fine; udev?  (Read 1800 times)
qki
Guest
« on: December 21, 2007, 04:08:57 pm »

1. I've installed Vector 5.8 SOHO on my Sony Vaio FE41S. It is using snd-hda-intel module and it was working fine under Slackware 12. Now, when KDE starts up I get this message:

Code:
[i]Informational - artsmessage[/i]
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for capture (Permission denied)
The sound server will continue, using the null output device.

The sound is working fine - KDE's sounds, amarok, mplayer etc. Also, I can change volume normally with kmix, but this message irritates me. I've checked permissions for /dev/dsp - it belongs to audio group, just like my user account. What could be wrong? Huh

2. Second problem is with udev. I had this problem on Slackware too, but I didn't have enough time to search for solution or to try to solve it by myself. When udev service is enabled, on boot, screen goes black and it stays like that. There is no any activity at all and I had to restart it manually. The only way to boot up system is to boot it without udev. I had similar problem with other distros, including Knoppix. I could boot knoppix with nopcmcia option. I've checked /var/log/messages but I couldn't see anything in there. Any ideas? Undecided

Thank You in advance!

Alex
Logged
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1545


I like the bass to go BOOM!


WWW
« Reply #1 on: December 21, 2007, 04:47:38 pm »

Quote
The sound is working fine - KDE's sounds, amarok, mplayer etc. Also, I can change volume normally with kmix, but this message irritates me.
This is aRts acting up. But since it's not working, and is really quite useless anyways you can turn it off in KDE's "Control Center" : Sound & Multimedia -> Sound System ->  uncheck "Enable the sound system". This will make sure aRts isn't started, audio usually works fine without it.
Logged

Most music on my soundcloud page was arranged in programs running on VL.
qki
Guest
« Reply #2 on: December 22, 2007, 01:27:13 am »

Thank you very much, no stupid message now. Wink

Udev ideas? Anyone? Undecided

EDIT:

Installed VL 5.9, but the problem remains - black screen after udev starts. Sad
« Last Edit: December 22, 2007, 09:24:51 am by qki » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!