VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)  (Read 6902 times)

bbruecker

  • Member
  • *
  • Posts: 14

Hi,

after a try on a more modern computer I decided to give VectorLinux a try. The live version looks great and I was happy http://vectorlinux.osuosl.org/docs/vl58/manuals/vl5_installation_guide_en.html#iso_linux to finde  an installation method to install by ISO-file. I was very lucky because the notebook doesn't boot from CD-Rom (CD-Rom-drive ist connected via PCMCIA), and that causes a lot of trouble.

I'm currently running damn-small-linux (DSL) version 4.2 on that computer. I want to install VectorLinux with the vinstall-iso script.

When I start the script displays an error: gunzip: invalid option --S. After commenting out the -S-option, the script stops with gunzip: img: No such file or directory.

What do I have to to, to run the script?

Thx, Benjamin
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

just a guess, but make sure you are not using the vinstall-iso script with a live iso.
you need an installable iso like this http://vectorlinux.osuosl.org/veclinux-5.8/iso-release/VL-5.8-std-Gold.iso


HTH,
Uelsk8s
Logged

bbruecker

  • Member
  • *
  • Posts: 14

Hi Uelsk8s,
I try to install with VL-5.8-std-Gold.iso. That' not a not Live-Cd I guess.
Benjamin
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

you are right, it is not a livecd.
I have never ran into any problems using the vinstall-iso, but i have never tried it in DSL.
I can only suggest opening up the script and running each command in a terminal until it gives you an error and if you cant figure that out then post back here and we can help.
Logged

BlueMage

  • Vectorite
  • ***
  • Posts: 274

BlueMage, here to save the day!  Why?  Because I've done this several times now  >:(  Install Vector from a DSL install, I mean.

First off, I would post my (modified) vinstall-iso script, but regretably it's on the slim client I have at home.  That machine has NO cd-drive, hence why I've gotten fairly intimate with this process.  There are a few small modifications, namely commenting out certain checks.  Specifically, I haven't commented out the -S as I've completely buggered it off.  I've also buggered off the bits related to /sys - that frequently caused my install to fail before it even got going.

Code: [Select]
## Copy the initrd.img
    echo "Preparing initrd ..."
    gunzip -c loop/isolinux/initrd.img > $INSTALLRD || \
error_exit "cannot decompress initrd.img from ISO-file"

Putting the gunzip'ing of initrd might work a bit better if you use this.  As best i can tell, the -S is included so that the script doesn't break should the compressed file not be in a format the decompressor expects.

:(  If I was at home I'd be able to give you a bit more help with this as I'd have it right in front of me.  Unfortunately, that's not going to be until sometime mid-to-late January.
Logged
Acer Laptop:  Vector 5.8 SOHO Final & Windows XP Professional & USB (still alive!)
Compaq POS (almost dead): Vector 5.9 Light Beta 5
Quad-core BEAST: Win 7 Ultimate 64-bit & Vector 5.9 64-bit beta-2
Old 500MHz media box:  Vector 5.8 SOHO Final (dead)
701 EeePC:  Puppeee (based on Puppy 4.01)

bbruecker

  • Member
  • *
  • Posts: 14

Thank you all for trying to help me.

BlueMage: The script is mow copying initrd.img with your help.

Now it the script stops here:
mount: special device /sys does not exist
ERROR: cannot mount /sys filesystem


There is a line above: EXT2-fs warns that e2fsck is recommended. I think I can ignore this.

I can cd to the folder loop/sys, but the directory is empty. So I thought the image is bad, but md4sum says  VL-5.8-std-Gold.iso is ok.

What can I do next?
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

you can take the kernel and initrd from the ISO and put them into your boot folder, then add them to lilo and reboot making sure to place your ISO in the root of a partition you dont want to use for the installation. then choose the installer from the lilo menu and it will find the ISO and start the install.
Logged

bbruecker

  • Member
  • *
  • Posts: 14

Hi uelsk8s,

I have Grub installed. I'm sure that will work either, but I'm not very common with linux-booting.

I suppose I have to to start initrd.vinstall. Is that right? Please can you give me an example?

Thx, Benjamin
Logged

bbruecker

  • Member
  • *
  • Posts: 14

Ok I just tryed this:
kernel /home/dsl/initrd.vinstall
the result is: Error 13: Invalid or unsupported executable format.
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

on the ISO you should have a isolinux/kernel/sata  and a isolinux/initrd.img
copy those to /boot
then add something like below to your menu.lst

Code: [Select]
  title vector installer
  root (hd0,0)
  kernel /boot/sata root=/dev/sda1 ro
  initrd /boot/initrd.img
Logged

bbruecker

  • Member
  • *
  • Posts: 14
Re: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)
« Reply #10 on: December 23, 2007, 07:50:12 am »

ok, step-by-step...

This grup-entry helped, until this happens:
VFS: Cannot open root device "sata" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


What is the purpose of "sata"?

Benjamin
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)
« Reply #11 on: December 23, 2007, 09:01:59 am »

sata is the name of the kernel.
isolinux/kernel/sata
Logged

BlueMage

  • Vectorite
  • ***
  • Posts: 274
Re: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)
« Reply #12 on: December 23, 2007, 09:13:56 am »

Thank you all for trying to help me.

BlueMage: The script is mow copying initrd.img with your help.

Now it the script stops here:
mount: special device /sys does not exist
ERROR: cannot mount /sys filesystem


There is a line above: EXT2-fs warns that e2fsck is recommended. I think I can ignore this.

I can cd to the folder loop/sys, but the directory is empty. So I thought the image is bad, but md4sum says  VL-5.8-std-Gold.iso is ok.

What can I do next?

I, um, I kinda cheat here - i comment out the lines that have anything to do with /sys in the vinstall-iso script.  It's a dirty method, but it's worked for me.  As best I can tell, it's a byproduct of using DSL - something about how it's set up compared to other distros.  For example, no such dirty hax are required if you're trying to vinstall-iso from another vector install.

Also, yep, I also get the kernel panic and set-valid-root bit if the install mucks up - unfortunately, I'm not intimate enough with the process to troubleshoot it short of Windows'ing it by reinstalling.

If you can, follow what uelska8s is saying - his method isn't as dirty as mine, and I honestly have no idea what the side effects of how I install it are.  They could be non-existent, they could be timebombs ticking down.
Logged
Acer Laptop:  Vector 5.8 SOHO Final & Windows XP Professional & USB (still alive!)
Compaq POS (almost dead): Vector 5.9 Light Beta 5
Quad-core BEAST: Win 7 Ultimate 64-bit & Vector 5.9 64-bit beta-2
Old 500MHz media box:  Vector 5.8 SOHO Final (dead)
701 EeePC:  Puppeee (based on Puppy 4.01)

bbruecker

  • Member
  • *
  • Posts: 14
Re: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)
« Reply #13 on: December 23, 2007, 10:29:23 am »

Hi uelsk8s,
do you have any idea how to fix my kernel-panic-problem? The sata kernel file is stored correctly at \boot\sata. What's wrong? How can I fix this?
Thx, Benjamin

Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: installation isues on vinstall-iso on Damn-Small-Linux (debian-woody-based)
« Reply #14 on: December 23, 2007, 10:48:05 am »

Hi uelsk8s,
do you have any idea how to fix my kernel-panic-problem? The sata kernel file is stored correctly at \boot\sata. What's wrong? How can I fix this?
Thx, Benjamin

what partition is your /boot on? 
post your menu.lst and we can work it out
Logged
Pages: [1] 2