Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: hp-setup  (Read 27043 times)


  • Member
  • *
  • Posts: 36
Re: hp-setup
« Reply #15 on: February 26, 2008, 06:15:55 am »


I don't know if my addition to this thread is prudent, but I never had to run any of the commands you mention. And I've gotten my HP all-in-one to work on any distro without fail.

Have you looked at localhost:631 yet??
That should bring you to a menu for setting up your printer. It's automagical.

Shouldn't we turn this into a How-To? I had to go through the same procedure to add my printer. The "HP Device Manager" in the Accessories (most likely misspelled, and even misspelled is probably misspelled...) menu does nothing on my machine...
I hope I didn't brain my damage!


  • Member
  • *
  • Posts: 1
Re: hp-setup
« Reply #16 on: March 06, 2008, 08:05:37 am »

I did a reinstall with the default options. I can confirm that cups is runnning. My printer is a HP 8200 photosmart. the output for "hpsetup" is

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
error: Unable to connect to hpiod.
error: Unable to connect to HPLIP I/O. Please (re)start HPLIP and try again.


when I try it, I get the same problem
now I already success setup HP Deskjet F370, by step as below:

plug USB printer cable to USB port.
but still get same problem

root:#whereis hplip
hplip: /usr/share/hplip


and it success
VL5.9 on iPAQ celeron 500 Mhz ram 256MB,
VLsoho 5.8 on fujitsu lifebook, celeron 750Mhz ram 384MB


  • Vectorite
  • ***
  • Posts: 166
Re: hp-setup
« Reply #17 on: January 15, 2011, 10:46:33 am »


I had problems with trying to setup printing with my network HP 6980 in VL 6.0 SOHO.

I tried adding the printer in both from cups in firefox (http://localhost:631/) and hp-setup (hp-setup in 6.0's KDE4 menu is not setup to run as root btw). It would add it, and I could see the printer in cpus and select to print to it while in an application, but when I attempted to print the print process would stop. A quick look at cups in my brower showed a state of "stopped
"/usr/lib/cups/filter/foomatic-rip-hplip failed"".

I ran #/usr/share/hplip/, tried again, and success! Thanks  :D
Pages: 1 [2]