VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Nics keep switching despite rules in /etc/udev/rules.d/network-devices  (Read 2902 times)

RagingGoblin

  • Member
  • *
  • Posts: 3

Hello,
With VL 5.9 I have the switching problem. One NIC is a BroadCom 4318, a wireless pcmcia card, the other a onboard NIC I never use. The BIOS does not give me the possibility to switch of this one. I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. The only solution I see is to write a script that parses the output of iwconfig and sets a symlink to eth0 or eth1 and use this. I do not have the knowledge about bash to do this, so I will have to learn this. Anyone with another idea?
« Last Edit: June 09, 2008, 02:22:44 am by RagingGoblin »
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2323

Please take a look at this: http://www.vectorlinux.com/forum2/index.php?topic=979.0
Let us know if that works for you.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

RagingGoblin

  • Member
  • *
  • Posts: 3

I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. T

No this did not work
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504

IMO the easiest way to do this would be to copy the script /sbin/VLwifi and take out the user prompts and replace them with your essid and such then have it run at boot
Logged

RagingGoblin

  • Member
  • *
  • Posts: 3

Solved, Setting the rules in /etc/udev/rules.d/network-devices.rules behaves strange:

Setting only the onboard card to eth0 -> switching
Setting the onboard to eth0, the pcmcia to eth1 -> switching
Setting only the pcmcia card to eth1 -> no switching !!

 ???

Anyway problem solved
Logged