VectorLinux
October 31, 2014, 10:19:08 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2 3 4
  Print  
Author Topic: VL-5.9-STD Bugs/annoyances  (Read 22288 times)
kidd
Packager
Vectorian
****
Posts: 682


« on: December 24, 2007, 09:32:00 am »

Well, you know what's that thread about, don't you? Smiley

- vasmCC does not start the FileSystem->Partition program

- /usr/bin/X  points to a non-existent dir named Xorg

- /usr/bin/X11  points to iteslf (this may be for compatibility issues but well, I report just in case..)

Logged

el_bot
Member
*
Posts: 1


« Reply #1 on: December 24, 2007, 01:02:08 pm »

(Sorry by my English... It's not my native language)
Hi.I don't know if this problem persists in the last version. Can someone check it? (I have little time these days).
In 192.168.2.2 is running sshd (I run it manually whith: /etc/rc.d/rc.sshd start )
$ sftp bot@192.168.2.2
Connecting to 192.168.2.2...
bot@192.168.2.2's password:
Received message too long 458960945

I think the problem is in scripts who echoes messages and don't check if stdout is a terminal (~/.bashrc or /etc/profile.d/*.sh ? ).
Logged
blurymind
Packager
Vectorian
****
Posts: 1082



« Reply #2 on: December 25, 2007, 03:15:18 am »

vl-hot doesnt want to mount cds/dvds (tried with mont /dev/... and the xfce mount plugin)
Hal mounts cds/dvds, but doesnt want to unmount them,giving me the following:
Quote
Given device "/org/freedesktop/Hal/devices/storage_model_HL_DT_ST_GCE_8526B" is not a volume or drive.
only way over this is goint root and issuing umount Undecided

Other than that i have encountered numerous bugs at vpackager. (which i believe should be reported elsewhere)

its possible for this bug to go away after a reboot? I have to test again with vl-hot.
Logged

status: playing around with new tablet and learning to 3d :p
google page :  http://blurymind.googlepages.com
DA PAGE :  http://www.blurymind.deviantart.com/
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #3 on: December 25, 2007, 09:04:11 am »

vl-hot doesnt want to mount cds/dvds (tried with mont /dev/... and the xfce mount plugin)
Hal mounts cds/dvds, but doesnt want to unmount them,giving me the following:
Quote
Given device "/org/freedesktop/Hal/devices/storage_model_HL_DT_ST_GCE_8526B" is not a volume or drive.
only way over this is goint root and issuing umount Undecided

Same problem here. I reported this back in RC1 or so but apparently it never got fixed.

I installed this on a Dell Dimension 2350 and which had a VL 5.8 SOHO install on it. During the configuration part of the install, the screen went blank (when configuring X) and stayed that way. Well, I shut the thing down and finished the configuration later. Since then, if I switch vt or go from init 4 to init 2, I get that same black screen. This machine has an integrated Intel card 82845G/GL. Also some of the icons look strange, all faded out and with little dots. Especially with VasmCC.

So, to try to get away from the Intel card and go back to my old friend Nvidia, I put an Nvidia Geforce FX 5200 pci card in there. After switching the BIOS to use the PCI card over the integrated one, I began to boot up VL. However, when it got to "Starting udev" it froze up. I rebooted again and tried again only this time looked at the text it outputted. When it got to "Performing Coldplugging" a whole bunch of text was spit out, which looked liked the Kernel had crashed. I think it did crash because it wouldn't reboot or do anything. I'll see if I can get a copy of the text that it outputted. Any suggestions? I would very much like to use the Nvidia card because the Intel drivers seem to have some major problems.
Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
rang501
Member
*
Posts: 6


« Reply #4 on: December 25, 2007, 10:37:07 am »

Some problems:
1. X servers auto configuration option dont work at all, I chosed it and after reboot X won't start.
2. My touchpad is not useable fully(scrolling button dont work, can't drag window by using only touchpad).
3. No GIMP Shocked   Grin

Anyway, shutdown speed is good, only startup speed is a bit slow(winXP is faster). Keep up the good work Wink
Happy new year to everyone!
Logged

Laptop: Fujitsu Siemens Lifebook C-1020 2GHz, 256MB RAM, 30GB hdd, 14", S3 graphics, Level1 WPC-0301 Wireless(Rt61 chip).
Trying to use latest version of Vectorlinux Smiley
InTheWoods
Vectorite
***
Posts: 302


« Reply #5 on: December 25, 2007, 05:37:04 pm »

wireless problems
Vasm cc inserts driver into ndiswrapper but
ndiswrapper -l
shows it as an invalid driver

attempt
ndiswrapper -r drivername.inf
couldn't delete /etc/ndiswrapper/net5416.inf: No such file or directory

removed driver with thunar and ran
ndiswrapper -i drivername.inf
driver now recognized

still unable to use vasm to set up wireless with Vasm cc.
'unable to find internet address'
Set up using Easuter's How to. with the following change
INTERFACES="eth0"
is changed to
INTERFACES="eth0 wlan0"
in 5.9
/etc/ifplugd/ifplugd.conf
instead of
/etc/ifplug.d/ifplugd.conf
as in Vec 5.8



Proprietary fglrx ATI Driver included is too new for my card (9250)! Installing the proper one [8.28.8] failed.
Code:
sh ati-driver-installer-8.28.8.run

Detected configuration:
Architecture: i686 (32-bit)
which: no XFree86 in (/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/bin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/opt/Adobe/Reader8/bin/:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/opt/seamonkey/bin:/usr/local/sbin:/usr/sbin:/sbin)
X Server: unable to detect
Removing temporary directory: fglrx-install
The problem is the latest available driver for this card does not work with Xorg 7.3
The card does work with both of the provided open source drivers but poorly! Slow and less resolution.

Thunar seems terribly slow on my machine!

Logged
raymac46
Member
*
Posts: 32


« Reply #6 on: December 26, 2007, 01:12:52 pm »

I think there might be a problem with the newest 2.6 kernel and acpi on old hardware.
Kernel 2.6.18.5 in VL 5.8 starts and runs the cooling fan on my 1999 Compaq Armada. The installation of 5.9 could not complete because the fan didn't start. The CPU got to a critcal 98 degrees C and the laptop shut down.
I have reinstalled 5.8 and everything is OK.
Logged
nubcnubdo
Vectorian
****
Posts: 675


« Reply #7 on: December 26, 2007, 04:52:54 pm »

raymac46 wrote:
Quote
I think there might be a problem with the newest 2.6 kernel and acpi on old hardware.

The workaround is to disable both ACPI and APM in BIOS, then append lilo.conf for APM power management. The kernel and BIOS compete for control of power management; consequently both abandon PM and the fan stops. Appending lilo.conf passes parameters to the kernel at boot time. See this HOWTO...

http://www.vectorlinux.com/forum2/index.php?topic=4795.0

Here is the line of code that appends lilo.conf for APM
Code:
append="apm=on apm=power-off"

After appending lilo.conf, you must run the command "lilo -v" as root from terminal.

sample
Code:
image=/vmlinuz
    label=linux
    root=/dev/hda1
    append="apm=on apm=power-off"
« Last Edit: December 26, 2007, 07:52:46 pm by nubcnubdo » Logged
raymac46
Member
*
Posts: 32


« Reply #8 on: December 27, 2007, 05:59:03 am »

Hard to modify the BIOS on this old machine because the hard drive was replaced and the partition containing the BIOS parameters was wiped off. The Compaq laptop does support acpi and powers off correctly.
I did try appending "acpi=off apm=on apm=power-off" to lilo.conf.
This stops the fan in Vector 5.8 which I don't want.
The issue is that VL 5.8 does run the fan with acpi enabled and VL 5.9 does not. I'll just stay with VL 5.8 and be happy I guess.
Logged
nubcnubdo
Vectorian
****
Posts: 675


« Reply #9 on: December 27, 2007, 07:26:09 am »

raymac46,
I realize you've reached a stopping place in your efforts. You can reinstall Compaq Setup by generating 3 floppy disks for that purpose. Just plug in the laptop's model number at HP support and find driver downloads for your laptop. There you will find the software for reinstalling Setup. If you reinstall Setup, you will lose all data on the hard disk. On laptops as old as you (didn't) describe, APM works better than ACPI, as ACPI was somewhat flakey in early versions. If you ever get the time and resolve to try again, I'm fairly confident you can find the proper combination to fix power management, ie. the fan stopping.
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #10 on: December 27, 2007, 06:46:06 pm »

I just found that gslapt is not installed and looking for it in
http://vectorlinux.osuosl.org/veclinux-5.9/packages/
I can't find it there either, the same holds true for vasmcc. Ain't that strange?
According to the PACKAGES.TXT gslapt should be found in ./net.
« Last Edit: December 27, 2007, 10:20:03 pm by Pita » Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #11 on: December 27, 2007, 06:50:16 pm »

not installed???

open a console and try:

Code:
kdesu gslapt


and see what happens... It should work.... For me it does (and I have it in my xfce menu)
Logged

Pita
Vectorian
****
Posts: 1311


« Reply #12 on: December 27, 2007, 10:25:14 pm »

It is not in the box. 'Whereis gslapt' returns nothing so does locate and I just run updatedb. Is there another repository?
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #13 on: December 27, 2007, 10:34:05 pm »

Pita,
Gslapt as well as gamin and kdelibs are on the 5.9 gold ISO.
how did you install?
if you used an older RC cd to install the Gold iso it will not install all of the packages because of some installer changes.
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #14 on: December 27, 2007, 11:17:24 pm »

I thought I installed VL5.9-STD-Gold.iso and just checked gslapt is not in http://ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.9/packages/ as well.

gslapt is not in /var/log/packages.

Where do I find what I installed?

Yes I used the oldest RC or Beta to install Gold. So I really have to burn Gold to a CD.
Logged
Pages: [1] 2 3 4
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!