VectorLinux
October 22, 2014, 05:58:51 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Proxy Setting  (Read 1836 times)
gondes
Member
*
Posts: 18



« on: December 20, 2007, 11:35:39 pm »

Hi,
I haven't running VL for a few months, and now I'm trying to run VL 5.9 in my Tosh Satellite. So far running well, but I have a problem with vpackager,  GoogleEarth, XChatIRC connecting through internet. I think the problem is the Global Proxy Setting which I cannot find where and what should be set. Internet programs which individually have their own proxy setting run fine (Firefox, SeaMongkey). I have internet access via LAN (squid proxy) and I've read the /usr/doc/googleearthxxx/readme and find that I should export squid proxy to env. var, but I really don't know how to do this. Anybody please can help me resolving this problem ?

Thanks in advance...
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #1 on: December 21, 2007, 02:52:53 am »

Add something like 'export http_proxy=http://192.168.1.2:3128' to .bashrc, but change the address according to your squid proxy address. Then log in again, and try running Google Earth from command line. That should go, I believe. (Hm, not sure whether .bashrc influences programs run outside terminal...)
« Last Edit: December 21, 2007, 06:34:19 am by hanumizzle » Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #2 on: December 21, 2007, 05:34:58 am »

Can you specify what problems you're having with vpackager?
Logged

gondes
Member
*
Posts: 18



« Reply #3 on: December 23, 2007, 07:58:56 pm »

Sorry for late reply,
Yes, I need to add 'export http_proxy=http://......' to .bashrc and relogin, and Google-earth works well. And as you mentioned, hanumizzle, it only works from terminal. vpackager also works only from terminal as root. So, M0E, is it any other way to modify the vpackager setting to run vpackager from xfce menu? However, It's just fine to run vpackager from terminal (for me, I'm happy enough), but if we can run it from xfce menu, it would be better for reliability. Now, I'm running vpackager for compiz, hope everything works fine.
(Oh, I also have to add 'export FTP_PROXY=ftp://.....' for vpackager to access ftp server).

Thanks for your kind help,

Gondes
Logged
Triarius Fidelis
Vecteloper
Vectorian
****
Posts: 2399


Domine, exaudi vocem meam


WWW
« Reply #4 on: December 23, 2007, 08:44:02 pm »

Sorry for late reply,
Yes, I need to add 'export http_proxy=http://......' to .bashrc and relogin, and Google-earth works well. And as you mentioned, hanumizzle, it only works from terminal.
Gondes

Might function universally if you add it to /etc/profile. If not that, then /etc/rc.d/rc.local. In either case, the setting will apply for all users. Hope that isn't a bother.
Logged

"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months
gondes
Member
*
Posts: 18



« Reply #5 on: December 26, 2007, 01:18:57 am »

It works, thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!