VectorLinux
September 01, 2014, 10:50:55 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: adsl problem with vl 5.9  (Read 1177 times)
federico
Member
*
Posts: 10


« on: December 25, 2007, 10:42:35 am »

adsl problem with vl 5.9

maybe it's a strange situation but i can't work it out.
i use slackware too and i've not the same problem:
the adsl connection does not work in VL 5.9 and in 5.8 too.
I make the usual pppoe-setup.
i inputed the same i inputed in slackware
then
pppoe-start
..connected
good ?
not
i try with firefox, opera, links, everything
but they can't connect to the web

i tryed it again setting the firewall value to 0,
nothing to do
i've copied /etc/ppp from slackware
nada de nada
the same for /etc/resolv.conf
un gni é gnit da fé

from ifconfig seems ethernet card is working


root:# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:19:E0:0B:15:2B 
          inet addr:192.168.1.25  Bcast:255.255.255.255  Mask:255.255.255.224
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5996 (5.8 KiB)  TX bytes:7359 (7.1 KiB)
          Interrupt:10 Base address:0xc800
    
     any suggestion ?
 
Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #1 on: December 25, 2007, 11:21:31 am »

Check ifconfig -a to look for a ppp0
connection in both Vector and Slackware
you may find that pppoe is not connected.

You mention /etc/resolv.conf is copied from
Slackware that may have changed.

Try ping an ip like 64.233.167.99 instead of a name.

Compare lsmod

HTH

Bigpaws
Logged
federico
Member
*
Posts: 10


« Reply #2 on: December 25, 2007, 01:27:50 pm »

ifconfig -a
results
etho, lo,
the same for the both
ther's a difference in ppp0
in vl
ppp0      Link encap:Point-to-Point Protocol 
          inet addr:79.26.247.65

in slack
ppp0      Link encap:Point-to-Point Protocol 
          inet addr:87.6.25.74

lsmod shows less modules in vl than in slack
i added the ones indicated as related to ppp
and now this is the situation

root:# lsmod
Module                  Size  Used by
bsd_comp                6528  0
ipt_LOG                 6912  3
xt_tcpudp               3968  6
iptable_filter          3328  1
ip_tables              11236  1 iptable_filter
x_tables               12548  3 ipt_LOG,xt_tcpudp,ip_tables
ppp_synctty             8576  0
ppp_async              10112  1
crc_ccitt               2816  1 ppp_async
ppp_generic            24212  7 bsd_comp,ppp_synctty,ppp_async
slhc                    6912  1 ppp_generic
radeon                123040  2
drm                    74388  3 radeon
freq_table              4768  0
snd_seq_midi            7200  0
snd_opl3_synth         13956  0
snd_seq_instr           7424  1 snd_opl3_synth
snd_seq_midi_emul       6912  1 snd_opl3_synth
snd_ainstr_fm           3072  1 snd_opl3_synth
lp                     10888  0
parport_pc             37092  1
parport                32072  2 lp,parport_pc
snd_seq_dummy           3716  0
snd_seq_oss            32128  0
snd_seq_midi_event      7168  2 snd_seq_midi,snd_seq_oss
snd_seq                48720  9 snd_seq_midi,snd_opl3_synth,snd_seq_instr,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            38048  0
snd_mixer_oss          15232  1 snd_pcm_oss
fuse                   42388  2
snd_cmipci             32128  2
gameport               12296  1 snd_cmipci
snd_pcm                69764  2 snd_pcm_oss,snd_cmipci
snd_page_alloc          8712  1 snd_pcm
snd_opl3_lib            9600  2 snd_opl3_synth,snd_cmipci
snd_timer              19972  3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep               7812  1 snd_opl3_lib
8139too                23168  0
snd_mpu401_uart         7808  1 snd_cmipci
snd_rawmidi            20128  2 snd_seq_midi,snd_mpu401_uart
mii                     5504  1 8139too
snd_seq_device          7692  7 snd_seq_midi,snd_opl3_synth,snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
serio_raw               6276  0
snd                    45796  19 snd_opl3_synth,snd_seq_instr,snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
i2c_viapro              8340  0
i2c_core               20992  1 i2c_viapro
soundcore               7008  1 snd
via_agp                 9088  1
shpchp                 30228  0
pci_hotplug            28616  1 shpchp
agpgart                28108  2 drm,via_agp
evdev                   8704  4

ping
it's like playng ping-pong alone
Logged
bigpaws
Vectorian
****
Posts: 1847


« Reply #3 on: December 25, 2007, 01:40:53 pm »

According to whois you are connected to an ISP in
Italy.

Did you try to ping via ip address vs using domain name?

/etc/resolv.conf appears to be the problem area.

Bigpaws
Logged
federico
Member
*
Posts: 10


« Reply #4 on: December 25, 2007, 08:40:34 pm »



googling on the web  i found a post about my same problem,
it was solved simply booting with the modem turned off.

it works, i don't know why, but it works

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!