Please support VectorLinux!

Author Topic: Compiz on VL 5.9 Gold  (Read 15086 times)

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: Compiz on VL 5.9 Gold
« Reply #30 on: February 02, 2008, 05:14:50 pm »
That is a known issue with the orbit package name. It will take some time to fix all the packages which depends on it, I think. Perhaps we should start a thread to report all of them there?
If the package is installed just ignore that dep and be sure you install all of them, it should work since, afaik, the binary code is the same, just the pkg name has a problem.
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Compiz on VL 5.9 Gold
« Reply #31 on: February 02, 2008, 07:07:09 pm »
I wasn't aware of the Orbit dep in Compiz.  I'll rebuild with the fix right away.  Stay tuned  :)

JohnB316

  • Administrator
  • Vectorian
  • *****
  • Posts: 1346
  • Registered Linux User #386728
Re: Compiz on VL 5.9 Gold
« Reply #32 on: February 02, 2008, 07:19:43 pm »
There is a package of compiz-fusion from cvs in the testing repo. Ignore the orbit issue and it should work fine.

HTH,
John
VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Compiz on VL 5.9 Gold
« Reply #33 on: February 02, 2008, 07:27:42 pm »
I fixed the orbit dep and re-upped the new package. Look for compiz-fusion-20080108-i586-2vl59.tlz in testing :)

InTheWoods

  • Vectorite
  • ***
  • Posts: 302
Re: Compiz on VL 5.9 Gold
« Reply #34 on: February 03, 2008, 08:22:28 am »
I installed the new package from the testing repo
compiz-fusion-20080108-i586-2vl59.tlz
It threw no dependancy errors.

After the initial install it worked the same as compiz built with vpackager as per  the wiki how to. Still no window decorations.

run
Code: [Select]
emerald
emerald: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.

Restart. Run
Code: [Select]
export XLIB_SKIP_ARGB_VISUALS=0 && fusion-icon
 * Detected Session: xfce4
 * Searching for installed applications...
Backend     : ini
Integration : true
Profile     : default
Adding plugin decoration (decoration)
Initializing decoration options...done
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * Starting Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
Backend     : ini
Integration : true
Profile     : default
It continues adding all of the plugins.
Code: [Select]
Initializing core options...done
compiz (dbus) - Error: dbus_bus_get error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
compiz (dbus) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'dbus'
It continues initializing options including
Code: [Select]
Initializing resize options...done
Initializing decoration options...done
then I get this
Code: [Select]
(emerald:4553): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed
Initializing rotate options...done
Initializing scale options...done
Initializing switcher options...done
Initializing workarounds options...done
Initializing zoom options...done
Initializing cubecaps options...done
Setting Update "command"

I then tried M-ake's suggestion
Code: [Select]
LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp &and get these errors
Code: [Select]
compiz (core) - Warn: SmcOpenConnection failed: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

error
compiz (dbus) - Error: dbus_bus_get error: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
compiz (dbus) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'dbus'
Initializing place options...done
Initializing move options...done
Initializing resize options...done
compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Warn: No GLXFBConfig for depth 32
ends
Setting Update "command"

Hopefully there are a few useful clues here.


DarylO

  • Member
  • *
  • Posts: 9
Re: Compiz on VL 5.9 Gold
« Reply #35 on: February 03, 2008, 08:38:51 pm »
I updated my Compiz-Fusion after installing the Nvidia driver for my GeForce 6200, and now I can't even get Vector to load the fusion-icon app.  I get the following message, as others have gotten:

Quote
root:# fusion-icon
 * Detected Session: xfce4
 * Searching for installed applications...
Backend     : ini
Integration : true
Profile     : default
Adding plugin decoration (decoration)
Initializing decoration options...done
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * No module named gtk
 ... Trying another interface
 * Using the Qt4 Interface
 * No module named PyQt4
 ... Trying another interface
 * Using the Qt3 Interface
 * Interface not installed
 *** Error: All interfaces failed, aborting!

I've installed these other xorg packages that have been mentioned on this thread, but that does not fix the problem.  Does anyone have a clue as to what may be wrong?

Daryl

InTheWoods

  • Vectorite
  • ***
  • Posts: 302
Re: Compiz on VL 5.9 Gold
« Reply #36 on: February 04, 2008, 12:12:35 pm »
 
Well Duh!!!

I ran it once as root and all is well.


DarylO

  • Member
  • *
  • Posts: 9
Re: Compiz on VL 5.9 Gold
« Reply #37 on: February 05, 2008, 05:46:21 pm »
Does ANYONE have an idea what I could do to fix this?  It would be really cool to get Compiz working on Vector, as I've only see it work on Mandriva....

Daryl

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Compiz on VL 5.9 Gold
« Reply #38 on: February 05, 2008, 05:52:52 pm »
Does ANYONE have an idea what I could do to fix this?  It would be really cool to get Compiz working on Vector, as I've only see it work on Mandriva....

Daryl
* Using the GTK Interface
 * No module named gtk
it looks like you need pygtk

can you post the output of "ls /var/log/packages/|grep -i ^py"

DarylO

  • Member
  • *
  • Posts: 9
Re: Compiz on VL 5.9 Gold
« Reply #39 on: February 05, 2008, 08:09:49 pm »
Thanks for the reply, but I have pygtk, as well as the others.  It appears that I may not have the right VERSION for all those things.  How would I be able to check to see what version Compiz is wanting?  It's still too easy to break a Linux program.  Linux will never have popular success if things like this remain common!

Daryl

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Compiz on VL 5.9 Gold
« Reply #40 on: February 05, 2008, 08:11:14 pm »
can you post the output of "ls /var/log/packages/|grep -i ^py"

DarylO

  • Member
  • *
  • Posts: 9
Re: Compiz on VL 5.9 Gold
« Reply #41 on: February 08, 2008, 09:37:40 pm »
PyQt-3.17.3-i586-1vl59
pyNeighborhood-0.4-i586-1vl59
pygobject-2.14.0-i586-2vl59
pyrex-0.9.6.4-i586-1vl59
pysol-4.82-i586-1vl59
python-2.5.1-i486-1

By the way, I can now no longer even attempt to launch fusion-icon without it crashing the X-server.

Daryl
« Last Edit: February 08, 2008, 09:46:59 pm by DarylO »

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: Compiz on VL 5.9 Gold
« Reply #42 on: February 09, 2008, 03:10:09 am »
DarylO,

Is this the compiz-fusion package from our repo? Or is it one you built from ports, or hand compiled?

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Compiz on VL 5.9 Gold
« Reply #43 on: February 09, 2008, 09:14:52 am »
PyQt-3.17.3-i586-1vl59
pyNeighborhood-0.4-i586-1vl59
pygobject-2.14.0-i586-2vl59
pyrex-0.9.6.4-i586-1vl59
pysol-4.82-i586-1vl59
python-2.5.1-i486-1

By the way, I can now no longer even attempt to launch fusion-icon without it crashing the X-server.

Daryl

there is no pygtk in that list
i have pygtk-2.10.6-i586-1vl59 here

DarylO

  • Member
  • *
  • Posts: 9
Re: Compiz on VL 5.9 Gold
« Reply #44 on: February 09, 2008, 09:39:52 am »
Yes, I had installed Vector Linux's Compiz-Fusion package.  As for PyGTK, I'm not on the computer right now, but I'm pretty sure I recall seeing it noted as 'installed' in SlaptGet.  The NVidia driver I had installed was one I had downloaded directly from NVidia, as I couldn't get Vector to install the proprietary driver.  By the way, my X-server also crashes when I click on the Open GL properties in NVidia's setup program.

Daryl