VectorLinux
August 28, 2014, 09:13:12 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [solved]Virtualbox kernel driver  (Read 2119 times)
Kerstin
Member
*
Posts: 26


« on: December 27, 2007, 03:01:16 am »

Having problem getting virtualbox working. Following error message appears:


VirtualBox kernel driver not installed.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

(I have added myself as a virtualbox user)

thx
« Last Edit: December 27, 2007, 10:20:36 am by easuter » Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #1 on: December 27, 2007, 05:59:16 am »

Open a terminal, logon as root and then enter this command to insert the kernel driver:

Code:
modprobe vboxdrv
Logged

Kerstin
Member
*
Posts: 26


« Reply #2 on: December 27, 2007, 06:08:57 am »

FATAL: Module vboxdrv not found.

is it VirtualBox-OSE_kernel_module that are missing? anyway i cant install it through gslapt, there is a small lock.
Logged
MikeCindi
Tester
Vectorian
****
Posts: 1073


« Reply #3 on: December 27, 2007, 06:59:27 am »

In gslapt you will have to open the properties and remove "kernel" from the blocked updates. Just make sure that you use the correct VBox kernel. BTW, VirtualBox should do all that on set up but I have had this problem frequently. With pre-1.5.2 versions of VBox I could just reload it but 1.5.2 doesn't seem to want to work. I have not tried it yet with VL5.9 Gold nor have I gone back to VBox 1.5.0 or earlier.
HTH,
Mike
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #4 on: December 27, 2007, 08:13:41 am »

Kerstin, I should have asked this first: what version of VectorLinux are you using and how did you install VirtualBox?
Logged

Kerstin
Member
*
Posts: 26


« Reply #5 on: December 27, 2007, 08:21:27 am »

Still not working :-( im using 5.8, i installed it through gslapt
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #6 on: December 27, 2007, 09:13:42 am »

Ok, what version does GSlapt report was installed?
Logged

Kerstin
Member
*
Posts: 26


« Reply #7 on: December 27, 2007, 09:25:53 am »

VirtualBox-OSE_kernel_module 1.3.3-i586-4vl58

VirtualBox-OSE 1.3.3-i586-4vl58
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #8 on: December 27, 2007, 09:39:42 am »

Hmm...looks like you have one of the older ones installed.

Open a terminal as root, and run this command to enable the testing repository:

Code:
echo "SOURCE=ftp://ftp.osuosl.org/pub/vectorlinux/veclinux-5.8/testing/" >> /etc/slapt-get/slapt-getrc

Then open GSlapt, and hit the "Update" button to refresh the package list. There should be a newer VirtualBox version available. Mark the old VirtualBox packages to be removed, and mark the new ones to be installed (version 1.4.0).
Logged

Kerstin
Member
*
Posts: 26


« Reply #9 on: December 27, 2007, 10:01:41 am »

Finally  Grin Now it works,  thanks for the effort!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!