Please support VectorLinux!

Author Topic: Abiword libiconv Error after removing wv....  (Read 3559 times)

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Abiword libiconv Error after removing wv....
« on: December 29, 2007, 12:03:30 pm »
I seem to have done something silly by removing the packages "wv and wv2". These seemed superfluous but now  I discover they are used by AbiWord to convert MS .doc files. I re-installed them but now get the error:

abiword: error while loading shared libraries: libiconv.so.2: cannot open shared object file: No such file or directory

I attempted to re-install Abiword, but to no avail. There is a post here about libiconv no longer in use on 5.9:
http://www.vectorlinux.com/forum2/index.php?topic=4262.0

Can someone assist me on how to get rid of this strange error? I am a bit lost as to where to start....

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Abiword libiconv Error after removing wv....
« Reply #1 on: December 29, 2007, 12:39:08 pm »
where did you get the wv package from?
it looks like it was built before libiconv was removed

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Abiword libiconv Error after removing wv....
« Reply #2 on: December 29, 2007, 02:46:08 pm »
where did you get the wv package from?
it looks like it was built before libiconv was removed
It was the inbuilt VL5.9 Gold package - I did no upgrades, or anything else. Very strange...
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Abiword libiconv Error after removing wv....
« Reply #3 on: December 29, 2007, 02:59:51 pm »
can you try reinstalling them with slapt-get and see if it helps?

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Abiword libiconv Error after removing wv....
« Reply #4 on: December 29, 2007, 03:45:46 pm »
ok, reinstalled wv and abiword with slapt-get after doing a clean and all OK now. Strange, but my hearty thanks !!!
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: Abiword libiconv Error after removing wv....
« Reply #5 on: December 29, 2007, 04:18:23 pm »
whew  :)

Triarius Fidelis

  • Vecteloper
  • Vectorian
  • ****
  • Posts: 2399
  • Domine, exaudi vocem meam
    • my website
Re: Abiword libiconv Error after removing wv....
« Reply #6 on: December 29, 2007, 05:17:32 pm »
ok, reinstalled wv and abiword with slapt-get after doing a clean and all OK now. Strange, but my hearty thanks !!!

Maybe something weird with library caching.
"Leatherface, you BITCH! Ho Chi Minh, hah hah hah!"

Formerly known as "Epic Fail Guy" and "Döden" in recent months