VectorLinux
November 25, 2014, 07:54:44 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Reducing size of a re-mastered VL5.9 Gold ??  (Read 1676 times)
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« on: December 30, 2007, 11:24:35 am »

As some of you may remember I work with a small charity that donates refurbished older computers to needy citizens. We presently install a remastered version of VL5.8 Gold on those computers. I am now working on a re-mastered version of VL5.9. By re-mastering I mean we burn a new ISO that has some superfluous applications removed and others which our clients prefer we add, we automate part of the VL install scripts, and we make minor changes to images, backgrounds etc.

At present I have the system down to 2.5GB of hard drive space for the root partition. We would like to get this even smaller, if possible, but we want to stick with xfce. I have removed fluxbox and jwm and a host of other stuff, but we have added OO, Xara Xtreeme and the Gimp at the request of users. Initially we were up to 2.9GB. We have since removed dev.tlz and a few other things, but with the X apps now finalized I am trying to find little nooks and crannies and superfluous packages/applications that newbies would probably never use. However, I don't want to break anything. In the past I have been too ruthless, trying to remove things like Tcl/Tk and Python, but with a host of breakages resulting from doing this.

If any developers or others have some suggestions of packages or applications that could probably be safely removed and keep the system from breaking I would appreciate your help. PS: I even went as far as removing vpackager - but that broke vasmCC, which we want to keep - now that was strange...

Any ideas appreciated.   
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #1 on: December 30, 2007, 11:33:51 am »

/usr/doc/* and /usr/share/doc/*  Theres a lot of text and html files in there.
Logged
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #2 on: December 30, 2007, 11:48:53 am »

Only a small amount, but /usr/info is probably not off much use to most people. You could also remove the texinfo package if you strip the info files.

paul.
Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #3 on: December 30, 2007, 01:32:15 pm »

Never tried it but:

/usr/include/*  +- 120 mb
/opt/seamonkey/include/* +- 18 mb
/usr/ports/*  +- 12 mb **might be in the dev bulk though.
/usr/share/X11/doc/* +- 7mb


Then one ones I mentioned already.
/usr/doc/* +- 139 mb
/usr/share/docs/* +- 80 mb

That's about 376 mb (uncompressed) removed.

There's only about 36 mb in manpages so probably not worth the sacrifice.
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #4 on: December 30, 2007, 06:33:54 pm »

vasmCC uses the gambas binary from vpackager. If you look at the vasmCC script in /usr/bin you can see what it uses there and maybe remove the rest of vpackager, Im not sure how much you would save there though.
there is an extra X11-server package that I know you wont need i meant to take it out of 5.9 but forgot.
besides waht exeterdad already said thats all i can think of.
Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #5 on: December 30, 2007, 06:47:29 pm »

there is an extra X11-server package that I know you wont need i meant to take it out of 5.9 but forgot.

Would that be the x11-7.3-i586-1vl59 "fake empty package for backwards compatibility"?
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #6 on: December 30, 2007, 07:00:26 pm »

there is an extra X11-server package that I know you wont need i meant to take it out of 5.9 but forgot.
Would that be the x11-7.3-i586-1vl59 "fake empty package for backwards compatibility"?
No.
it is the xorg-server-xvfb-1.4-i486-4
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!