VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Problem with screen size  (Read 2051 times)

pschoen

  • Member
  • *
  • Posts: 1
Problem with screen size
« on: December 30, 2007, 01:39:14 pm »

I just installed VL, and am having problems getting the right screen size: 1680x1050. I have edited xorg.conf for this value, but it has no effect.

Section "ServerLayout"
Identifier     "X.org Configured"
Screen    0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/X11R6/lib/X11/rgb"
ModulePath   "/usr/X11R6/lib/modules"
FontPath     "/usr/X11R6/lib/X11/fonts/misc/"
FontPath     "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath     "/usr/X11R6/lib/X11/fonts/CID/"
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath     "/usr/X11R6/lib/X11/fonts/truetype/"
FontPath     "/usr/X11R6/lib/X11/fonts/local/"
FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic/"
EndSection

Section "Module"
Load  "glx"
Load  "extmod"
Load  "xtrap"
Load  "record"
Load  "dbe"
#Load  "dri"
Load  "freetype"
Load  "type1"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"   ## KEYBOARD_MAP!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
HorizSync 30-55
VertRefresh 50-65
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
###
[arg]: arg optional
#Option     "DigitalVibrance"       #
#Option     "NoFlip"                #
[<bool>]
#Option     "Dac8Bit"               # [<bool>]
#Option     "NoLogo"                # [<bool>]
#Option     "UBB"                   # [<bool>]
#Option     "Stereo"                #
#Option     "SWcursor"              #
[<bool>]
#Option     "HWcursor"              # [<bool>]
#Option     "VideoKey"              #
#Option     "NvAGP"                 #
#Option     "IgnoreEDID"            #
[<bool>]
#Option     "NoDDC"                 # [<bool>]
#Option     "ConnectedMonitor"      # <str>
#Option     "ConnectedMonitors"     # <str>
#Option     "TVStandard"            # <str>
#Option     "TVOutFormat"           # <str>
#Option     "RenderAccel"           # [<bool>]
#Option     "CursorShadow"          # [<bool>]
#Option     "CursorShadowAlpha"     #
#Option     "CursorShadowXOffset"    #
#Option     "CursorShadowYOffset"    #
#Option     "UseEdidFreqs"          #
[<bool>]
#Option     "FlatPanelProperties"    # <str>
#Option     "TwinView"              # [<bool>]
#Option     "TwinViewOrientation"    # <str>
#Option     "SecondMonitorHorizSync"    # <str>
#Option     "SecondMonitorVertRefresh"    # <str>
#Option     "MetaModes"             # <str>
#Option     "UseInt10Module"        # [<bool>]
#Option     "NoTwinViewXineramaInfo"    # [<bool>]
#Option     "NoRenderExtension"     # [<bool>]
#Option     "Overlay"               # [<bool>]
#Option     "CIOverlay"             # [<bool>]
#Option     "ForceEmulatedOverlay"    # [<bool>]
#Option     "TransparentIndex"      #
#Option     "OverlayDefaultVisual"    #
[<bool>]
#Option     "NvEmulate"             #
#Option     "NoBandWidthTest"       #
[<bool>]
#Option     "CustomEDID-CRT-0"      # <str>
#Option     "CustomEDID-CRT-1"      # <str>
#Option     "CustomEDID-DFP-0"      # <str>
#Option     "CustomEDID-DFP-1"      # <str>
#Option     "CustomEDID-TV-0"       # <str>
#Option     "CustomEDID-TV-1"       # <str>
#Option     "TVOverScan"            # <f>
#Option     "IgnoreDisplayDevices"    # <str>
#Option     "MultisampleCompatibility"    # [<bool>]
#Option     "RegistryDwords"        # <str>
#Option     "RegistryBinary"        # <str>
#Option     "NoPowerConnectorCheck"    # [<bool>]
#Option     "AllowDFPStereo"        # [<bool>]
#Option     "XvMCUsesTextures"      # [<bool>]
#Option     "HorizSync"             # <str>
#Option     "VertRefresh"           # <str>
#Option     "AllowGLXWithComposite"    # [<bool>]
#Option     "RandRRotation"         # [<bool>]
#Option     "ExactModeTimingsDVI"    # [<bool>]
#Option     "LoadKernelModule"      # [<bool>]
Identifier  "Card0"
Driver      "nv"
VendorName  "nVidia Corporation"
BoardName   "Unknown Board"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Modes "1680x1050"
Viewport   0 0
Depth     1

EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4

EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8

EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15

EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16

EndSubSection
SubSection "Display"
Modes "1680x1050"
Viewport   0 0
Depth     24

EndSubSection
EndSection

I tried to use KRandR, but the largest screen size available is 1152x768. An odd thing is that the "settings for screen" in KRandR is for Screen1 instead of Screen0. And that field is greyed-out, so I can't change it. The xorg.conf value is Screen0. Changing xorg.conf to Screen1 didn't help. I am using an Nvidia driver, but that doesn't give me the correct screen size.

I am wondering if the "setting for screen" in KRandR is the key to this problem, and is there a way to change it.

Thanks
Logged

vdb

  • Member
  • *
  • Posts: 22
Re: Problem with screen size
« Reply #1 on: April 01, 2008, 11:45:25 pm »

change the line:
driver   "nv"   into    driver  "nvidia"

remove the line:
load "dri"

or maybe this could help you:
http://us.download.nvidia.com/XFree86/Linux-x86/169.12/README/chapter-06-section-02.html
« Last Edit: April 02, 2008, 12:09:28 am by vdb »
Logged
Vector Linux 5.8 SOHO

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Problem with screen size
« Reply #2 on: April 02, 2008, 04:52:42 am »

It appears that you have a Nvidia video card. Did you install
the drivers from NVIDIA?

If not you can get them from NVIDIA and install them.

Bigpaws
Logged