VectorLinux
October 24, 2014, 12:23:43 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Iomega CDDVD  (Read 1031 times)
wahmd
Member
*
Posts: 7


« on: December 31, 2007, 10:10:33 pm »

Greetings:

Recently installed 5.9 on an ancient Sharp Actius 150 - P266, 64 mb Ram - hoping I would have a more attractive alternative to DSL and Puppy.  This Sharp Actius was an ultralight with an external CDROM linked via PCMCIA and an external floppy as well.  Installation required using two Vector CDs - one in the PCMCIA attached CDROM (to start the install) and another in a USB CDROM that the first would "find" in order to complete the install as the BIOS wouldn't allow booting from USB CDROM and any Linux install I tried in the PCMCIA attached CDROM alone would fail due to not being able to access its own CD (looked everywhere but itself which it couldn't see).  Even the Damn Small install with the "PCMCIA boot floppy" failed as the Sharp uses a driver that the disk didn't contain.  (Apparently there were several manufacturers that attached the CDROM to the ultralight in this fashion.)  Other than the two disk arrangement, I could find no way to install Linux other than via loadlin or via floppies or by pulling the HD.  Somewhere I read that it could be done with Laplink.  Long story short... it works and is faster/prettier/cooler than the Win98 that was on the unit to begin with.  Well that wouldn't be hard... but Vector is faster/prettier/cooler than a whole lot of stuff out there.

So here are my questions...

The Iomega CDDVD identifies itself as "sr0".  In fstab I made the following entries beneath the /dev/sda1... /mnt/pendrive in the USB section.

/dev/sr0 /mnt/cdrom iso9660 defaults,noauto,ro,user 0 0
/dev/sr0 /mnt/cdrecorder iso9660 defaults,noauto,rw,user 0 0
/dev/sr0 /mnt/dvd auto defaults,noauto,ro,user 0 0

Data CD's in the Iomega USB CDROM are mountable/unmountable via the "devices" mounter panel applet.  Thunar opens as it should.
Nothing happens when I try to mount a DVD.  Of course, I don't expect to play movies on a box with 2 mb video but might I be able to access data?  I haven't tried the cdwriter yet.  Is there a better way to set this up?  I tried creating a folder "iomega" in "mnt" and entered /dev/sr0 /mnt/iomega in fstab but it didn't work.

What happened to the icons that would automagically appear on the desktop as in 5.8?

Why does nothing (seem to) happen when I click on the "vl-hot-config" item under "system"?

BTW, I chose vl-hot over HAL when I installed.

Why does nothing (seem to) happen when I click on the "media refresh" item next to the VASMCC applet?

Why am I unable to find the files on a music CD to play in XMMS?  The directory (/mnt/cdrom) is empty.  I realize i don't have to actually mount a music CD ... it automounts, right? But I should be able to navigate to a list of files.

Also (unrelated)... how do I increase the display size when in console mode... it seems to be using 640 x 480 when the display supports 800 x 600? I want to use the maximum area when editing text.  A larger font would be nice too.

Thanks for any suggestions.

Blessings and best wishes to all for a happy, healthy, and prosperous 2008.

WAHMD.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!