VectorLinux
November 24, 2014, 12:06:35 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Wifi on Toshiba  (Read 1184 times)
gondes
Member
*
Posts: 18



« on: January 02, 2008, 07:04:52 pm »

For those having difficulties running VL on Toshiba Satellite M30 using wifi as primary network card automatically, this is my workaround :
1. Add 'alias eth1 ipw2200' in /etc/modprobe.conf and /etc/modules.conf
    (just to making sure eth1 is scanned and not interchangeably between e100 and ipw2200)
2. Modify the rc.inet2 to your setting :
    - set the device setting (dhcp, ipaddr, etc..)
    - add script : 'iwconfig eth1 essid "your AP" mode auto key "your key" '
    - turn on the rc.inet2 (chmod a+x rc.inet2)
3. Change the the order of card setup eth1 before eth0 by modifying /etc/rc.d/
    - for VL 5.9 RC 2: rc.M
    - for VL Final : rc.network
      on "Set Other networks"  from
Quote
     for i in 0 1 2 3 4; do
to
Quote
     for i in 0 2 1 3 4; do
Test the connection by pinging to other compy without parameter "-I eth1"

I do this because I want wifi as the only connection (eth0 unplugged) to my network, but it often fails.
It seems that it is always trying to connect via eth0 and wait until it fails then try eth1, which takes a very long time.

Till now it solve my problem, eventhough ideally it should connect simultaneously without waiting one another.
Just want to share, but I wish a better way than this.
(Pls do not mind my english, not my language).

Thanks,

gondes
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!