VectorLinux
July 24, 2014, 07:07:05 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: smbclient and win 2k incompability?  (Read 3629 times)
Xeon
Vectorite
***
Posts: 115


« on: January 05, 2008, 01:56:34 am »

Last night we have been desperately trying to make smbclient download a bunch of files from a win 2k machine. Currently we are clueless and are about to give up.

The problem is as follows:
We have a Linux machine that has to gather a bunch of files every night. Previously we had a win 98 box and that one never gave a problem. We now had to upgrade to use newer software.
First step: connection

Code:
smbclient //bashful/hrofft -U Administrator

The connection opens as it should and we are able to do a command like 'ls'
Then we try to get a file
Code:
smb /> mget 1.png

At that point it goes terribly wrong. It takes ages, and then the transfer fails with a timeout error.  After that, as usual for windows machines, any communication becomes impossible. A simple ls delivers a timeout too until we close the smbclient and start a new one.
The same occurs when we try to put a file

No firewalls are on the systems, all permissions are set open to scratch out this as possible reason.

We then ended up with a packet sniffer and recorded an attempt. Everything goes nice as it should. The transfer opens and the Linux machine asks for the file. The win2k machine sends the file. Resends it, resends it, resends it, then a few moments later the Linux box ask for the file again and after 20 seconds the Linux box just closes the communication due to no success. We feel like somehow our packets end up in /dev/null  Lips sealed
I took my vector laptop and had exactly the same problem with the latest samba version around. We patched win2k up to service pack 4, but problem persists.

We googled the error and found a few people complaining about the same in mailing lists but no one really knows a solution.

Anyone got the slightest idea whats going wrong here?
Logged
bigpaws
Vectorian
****
Posts: 1843


« Reply #1 on: January 05, 2008, 07:05:24 am »

Sounds like a bad command.

Here is some reading for you to help:

http://learnlinux.tsf.org.za/courses/build/net-admin/ch08s02.html

That should get you going.

Bigpaws
Logged
Xeon
Vectorite
***
Posts: 115


« Reply #2 on: January 05, 2008, 09:56:35 am »

commands are quiet ok :s I ssh'ed into it so i could copy:

$ smbclient \\\\bashful\\temp
Password:
Domain=[BASHFUL] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
smb: \> get 1.png
getting file \1.png of size 17577 as 1.png Short read when getting file \1.png. Only got 0 bytes.
Error Call timed out: server did not respond after 20000 milliseconds closing remote file
(0.0 kb/s) (average 0.0 kb/s)
smb: \>

We use commands exactly as described in your link, and it has worked with another win version  Huh


Logged
bigpaws
Vectorian
****
Posts: 1843


« Reply #3 on: January 05, 2008, 11:27:44 am »

I have just tried on VL 5.8 SOHO and Slackware 12
so both versions of smbclient would be used.

After logging in using:

smbclient \\\\ipaddress\c$ -U administrator

then using get boot.ini both versions of
smbclient work.

I would change to admin see if that is a change, and I
have no problems with ls.

This is against a Win2K pro machine with service pack 4.

See if that works.

Bigpaws
Logged
Xeon
Vectorite
***
Posts: 115


« Reply #4 on: January 05, 2008, 11:46:24 am »

$ smbclient \\\\bashful\\c$ -U Administrator
Password:
Domain=[BASHFUL] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
smb: \> ls
Call timed out: server did not respond after 20000 milliseconds listing \*
Error in dskattr: Call timed out: server did not respond after 20000 milliseconds
smb: \>


I get this. We also have our win 2k patched to exactly sp 4
Logged
bigpaws
Vectorian
****
Posts: 1843


« Reply #5 on: January 05, 2008, 03:34:48 pm »

smbclient \\\\xxx.xxx.xxx.xx\\c$ -U administrator

notice no caps in admin.

Karl
Logged
Xeon
Vectorite
***
Posts: 115


« Reply #6 on: January 08, 2008, 12:46:39 pm »

$ smbclient \\\\192.168.1.48\\c$ -U administrator
Password:
Domain=[BASHFUL] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]
smb: \> ls
Call timed out: server did not respond after 20000 milliseconds listing \*
Error in dskattr: Call timed out: server did not respond after 20000 milliseconds
smb: \>

I don't really believe the syntax is messed :s
All permissions are opened, dummy, admin, whatever, they can connect and do whatever they like in the directory

Joachim
Logged
newt
Vectorian
****
Posts: 1132



« Reply #7 on: January 08, 2008, 01:29:17 pm »

smbclient \\\\ipaddress\c$ -U administrator
$ smbclient \\\\192.168.1.48\\c$ -U administrator
May be irrelevant, but I notice a slash difference in the syntax used (xeon uses two \\'s and bigpaws uses one \).
Logged
Xeon
Vectorite
***
Posts: 115


« Reply #8 on: January 08, 2008, 01:38:39 pm »

Single slash doesn't work, escaping matter. In fact the link is \\bashful\hrofft but every \ needs its escape \
:p
Logged
Xeon
Vectorite
***
Posts: 115


« Reply #9 on: January 14, 2008, 09:54:33 am »

We solved it. Appearantly the network card wasn't functional anymore.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!