Please support VectorLinux!

Author Topic: gambas2-2.0?  (Read 3250 times)

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
gambas2-2.0?
« on: January 05, 2008, 08:57:30 am »
Anyone manage to package gambas2 version 2.0 yet?
I have installed my brand new shiny vl5.9 and I'm ready to resume work on vpackager and vasmCC. I'd like to get gambas2-2.0 final so I can get these projects in it... unfortunately I do not have the time to package it...

Thanks

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: gambas2-2.0?
« Reply #1 on: January 05, 2008, 10:24:24 am »
I'm gonna do some repo work this evening, and I'll try getting a VL 5.9 build up too. 5.8 will have to wait a bit though...

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: gambas2-2.0?
« Reply #2 on: January 05, 2008, 10:30:10 am »
easuter, that would be cool!  I PM'd M0E because I was going to give it a shot, but now the wife has her mother at the emergency room today and everything is a bit upside down at the moment.

I was trying M0E.

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: gambas2-2.0?
« Reply #3 on: January 05, 2008, 10:31:07 am »
I'm gonna do some repo work this evening, and I'll try getting a VL 5.9 build up too. 5.8 will have to wait a bit though...
there is source and build script for the last rc in my folder maybe it will help.
joe1962 mentioned there is a specific way that the gambas devs want the packages to be distributed though.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: gambas2-2.0?
« Reply #4 on: January 05, 2008, 10:39:32 am »
I'm working on my script to package Gambas2 correctly as per Benoit's instructions. I've been way too busy lately, but hopefully I can get it done over the weekend.
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: gambas2-2.0?
« Reply #5 on: January 05, 2008, 11:22:14 am »
i appreciate the effort guys. Looking forward to it

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: gambas2-2.0?
« Reply #6 on: January 05, 2008, 04:16:10 pm »
I'm working on my script to package Gambas2 correctly as per Benoit's instructions. I've been way too busy lately, but hopefully I can get it done over the weekend.

Well, I wont step on your toes then  :)

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: gambas2-2.0?
« Reply #7 on: January 19, 2008, 10:20:00 am »
I'm working on my script to package Gambas2 correctly as per Benoit's instructions. I've been way too busy lately, but hopefully I can get it done over the weekend.

How far are you? Any chance I can help out with 5.8/5.9 builds?

PS: There is a new machine sitting next to me that can't wait to start chewing bits :D

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: gambas2-2.0?
« Reply #8 on: January 20, 2008, 04:56:06 am »
Moe, there are packages up: http://www.vectorlinux.com/forum2/index.php?topic=5359.0
They should be good at least for now.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: gambas2-2.0?
« Reply #9 on: January 21, 2008, 06:09:58 am »
I get this every single time... no matter which repo I use
Code: [Select]
root:# slapt-get --install gambas2
Reading Package Lists... Done
Suggested packages:
  kdelibs >= 3.5.8-i586-2vl59 mysql >= 5.0.45-i586-1vl59 postgresql >=
  8.2.5-i586-1vl59 sqlite >= 2.8.17-i586-4vl59 sqlite3 >= 3.4.2-i586-1vl59
  unixODBC >= 2.2.12-i586-1vl59 kdelibs >= 3.5.8-i586-2vl59 mysql >=
  5.0.45-i586-1vl59 postgresql >= 8.2.5-i586-1vl59 sqlite >= 2.8.17-i586-4vl59
  sqlite3 >= 3.4.2-i586-1vl59 unixODBC >= 2.2.12-i586-1vl59
The following NEW packages will be installed:
  gambas2-runtime gambas2
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.9MB of archives.
After unpacking 29.8MB of additional disk space will be used.
Get ftp://ftp-osl.osuosl.org/pub/vectorlinux/veclinux-5.9/testing/ gambas2-runtime 2.0.0-i586-1vl59 [1.5MB]...Failed to download: FTP: couldn't retrieve (RETR failed) the specified file

easuter

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 2160
Re: gambas2-2.0?
« Reply #10 on: January 21, 2008, 07:14:58 am »
Fixed.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: gambas2-2.0?
« Reply #11 on: January 21, 2008, 07:44:10 am »
It's working now... thanks