VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: LIVE 5.9 Install failure  (Read 3303 times)

mosslack

  • Member
  • *
  • Posts: 7
LIVE 5.9 Install failure
« on: January 05, 2008, 09:37:02 am »

I'm having some difficulties installing VL 5.9 from the live CD.  Everything seems to go okay but when I try to reboot my boot manager cannot locate a bootable image.  I use Boot It NG as my boot manager and I've got several linux distros installed on my system now.  I noticed when the installer asks to install lilo, the only choices were to the mbr or /mnt/hda1.  Shouldn't the root partition be listed as /dev/hda1?  I tried to manually install lilo to the root partition but haven't had any luck so far.  Any ideas?

Just a message from Doug...
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: LIVE 5.9 Install failure
« Reply #1 on: January 05, 2008, 09:55:46 am »

mosslack,
I split your post so we can sort your problem seperately.

you are right the choice should be /dev/hda1 and not /mnt/hda1. This will be fixed in the next installer.
how are you trying to install lilo?
changing the line in /etc/lilo.conf that says
boot = /mnt.hda1 to boot = /dev/hda1
and running lilo should do it
Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #2 on: January 05, 2008, 11:01:19 am »

Yep, that is what I did.  But it seems like I got an error message, something about fat32, but I don't remember the exact wording.  I know it didn't work.
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: LIVE 5.9 Install failure
« Reply #3 on: January 05, 2008, 11:31:23 am »

is there a way you can post the error message?
Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #4 on: January 05, 2008, 11:46:31 am »

Not now, that was last night.  I've reformatted the partition since then.  Thought I would post here before I tried to reinstall.  For what it's worth, I have my partitions set up in Boot It NG as a 10 Gb linux native, a 1 Gb swap partition and I always set it up so that my 40 Gb data partition is accessible from whatever distro I am configuring.  Usually this works fine and I always have lilo or grub installed on the root partition of the install.  I had a really bad time with Ubuntu.  That distro will not let you install to the root partition no matter what you do.  So far I have been able to set up Fedora, Mandriva, Mepis, Absolute, OpenSuse and PCLOS with little problem.  I tried the VL 5.9 std edition, but was not able to get it installed.  When I saw the live version I thought I would give it a try.  I like what I've seen so far.  Of course I like the speed of Slackware with Absolute, but that distro was a little sparse in the window manager department for me.  When I try again to install the VL live, how should I do it?

Just a message from Doug...

Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: LIVE 5.9 Install failure
« Reply #5 on: January 05, 2008, 12:17:12 pm »

Quote
When I try again to install the VL live, how should I do it?
upgrade this package: http://vectorlinux.osuosl.org/Uelsk8s/vl-live-tools-1.0.6-i586-2vl59.tlz
it is fixed to install lilo to partition

Let me know how it goes.
Uelsk8s
Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #6 on: January 05, 2008, 12:20:43 pm »

Okay, I'll give that a try, thanks!

Just a message from Doug...

Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #7 on: January 05, 2008, 01:20:42 pm »

I don't think I did something right.  I clicked on the link in your message and the file downloaded to the desktop.  I double-clicked it and it asked which program I should use to open the file.  I chose the xarchiver and extracted the files to the desktop.  Ran the installer from there and got the same choice for where to install lilo (/mnt/hda1).  Went ahead and installed anyway.  Once it finished I decided to try the other method of installing lilo by changing the conf file to read boot = /dev/hda1 and ran /sbin/lilo.  Here is the message I got:

Warning: LBA32 Addressing assumed
Fatal: Filesystem would be destroyed by lilo boot sector: /dev/hda1

That is the same message I got last night when I tried.  /dev/hda1 was formatted as reiserfs last night and I tried xfs when I did it today.  What should I have done when I downloaded the file from you?  I can try again if I didn't do it right.

Just a message from Doug...
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: LIVE 5.9 Install failure
« Reply #8 on: January 05, 2008, 01:31:35 pm »

your not supposed to use lilo to sector when installing to an XFS filesystem.
you should not get the same error with reiserfs.
right click the package you download and use the install package option or use upgradepkg vl-live-tools-1.0.6-i586-2vl59.tlz from CL
Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #9 on: January 05, 2008, 01:37:45 pm »

Okay, I will try that then.
Logged

mosslack

  • Member
  • *
  • Posts: 7
Re: LIVE 5.9 Install failure
« Reply #10 on: January 05, 2008, 02:20:40 pm »

Yep, that worked just fine.  Now I have another problem though.  Seems I can't get back to my live version settings for xorg.  I think it has something to do with frame buffers, but I'm not sure what.  I'll figure it out though.  Thanks for your help.

Just a message from Doug...
Logged