VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: saving keyboard settings (SOLVED)  (Read 2302 times)

robertito

  • Member
  • *
  • Posts: 15
saving keyboard settings (SOLVED)
« on: January 09, 2008, 11:02:17 am »

I've tried many distros and for me Vector is the best. I've had some hassle getting Internet connected, but I finally made it. The remaining problem is how to save my keyboard settings. I've discovered how to set up my uk keyboard, but next time I log on it hasn't been saved. I only have the root user, maybe the settings will be saved if I set myself up as an individual user, but I don't know how to do that...
Thanks....
« Last Edit: January 14, 2008, 03:17:44 pm by robertito »
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: saving keyboard settings
« Reply #1 on: January 09, 2008, 11:29:13 am »

could you post how you get them to work?

that may help us tell you the best way to "save" them
Logged

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #2 on: January 09, 2008, 01:26:17 pm »

I get the @ and £ keys correct by doing:
VASM.....X Window....Keyboard SetUp....pc101....gb.......basic variant
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: saving keyboard settings
« Reply #3 on: January 09, 2008, 02:48:02 pm »

after you login does running "/etc/rc.d/rc.keymap start" make your keys work?

also what version of VL are you using?
Logged

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #4 on: January 09, 2008, 04:22:57 pm »

Hi..as far as I can tell,  /etc/rc.d/rc.keymap start  doesn't do anything....
Vector version is the current 5.9 Gold
Going off for the night, I'll be back tomorrow !
Logged

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #5 on: January 10, 2008, 01:32:42 am »

Had another try this morning. I set up the uk keyboard as described, then ran
/etc/rc.d/rc.keymap start  in the terminal. It caused a slight flash. Then I switched off and logged in again to see whether the keyboard was now operating as uk mode. Sadly it wasn't ! Any more ideas for me to try ?
Thanks !
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: saving keyboard settings
« Reply #6 on: January 10, 2008, 01:39:52 am »

I have been going through vasm and it looks like to me all it does is run /etc/rc.d/rc.keymap after it sets it up.
If you run that does it change your keymap before you reboot?
Logged

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #7 on: January 10, 2008, 04:40:30 am »

Not sure that I understand....your /etc/ thingy doesn't seem to do anything, and it wouldn't change my keymap because if I don't do the vasm stuff, it wouldn't know what to change the keyboard to...
I really appreciate your interest....if it takes time for me to respond it's because I only use the PC intermittently.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: saving keyboard settings
« Reply #8 on: January 10, 2008, 05:12:26 am »

As root run
Code: [Select]
/etc/rc.d/rc.keymap
In my box this produces:
Code: [Select]
root:# /etc/rc.d/rc.keymap
Loading /usr/share/kbd/keymaps/i386/qwerty/es.map.gz

What about running as root loadkeys uk?
« Last Edit: January 10, 2008, 05:14:54 am by rbistolfi »
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #9 on: January 10, 2008, 07:20:55 am »

OK, I get the line
Loading /usr/share/kbd/keymaps/i386/qwerty/es.map.gz
then one should I do next ?  Sorry about my ignorance..........
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: saving keyboard settings
« Reply #10 on: January 10, 2008, 09:12:16 am »

well, yo have a spanish layout then, is that the result of running /etc/rc.d/rc.keymap as root?

Did you try loadkeys uk as root?

Please when posting copy and paste directly from the terminal so we can see the exact command and the output, we can troubleshoot better with that. Perhaps this info can help, post the output of

Code: [Select]
cat /etc/rc.d/rc.keymap
and
Code: [Select]
ls -l  /etc/rc.d/rc.keymap
Cheers

Edit1: Oh, I have a question too, does rc.keymap in charge of the X apps too? Is there a keyboard option in xorg.conf?

Edit2: there is a Option XkbLayout in xorg.conf, so I guess I got the answer.

Robertito: please check the value of Option XkbLayout in your /etc/X11/xorg.conf
You should do all this with the default keymap, dont do the vasm fix because you will never find the root of the problem then.
« Last Edit: January 10, 2008, 09:30:52 am by rbistolfi »
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

robertito

  • Member
  • *
  • Posts: 15
Re: saving keyboard settings
« Reply #11 on: January 10, 2008, 11:36:11 am »

Well, I didn't have any success with /etc/X11/xorg.conf  it just said I was denied permission and I still haven't discovered where xorg.com is located.

BUT I've solved the keyboard problem, I reloaded the system and left in the X11 stuff etc that I had previously not loaded. Also, my particular hp keyboard wasn't listed, (mine is KB-0316) but I chose another high number.

Well I never, my keyboard now displays @ and £ correctly, and I'm a happy bunny.
So thank you to everyone for their interest.....
Robertito
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: saving keyboard settings
« Reply #12 on: January 10, 2008, 08:17:18 pm »

Well, I didn't have any success with /etc/X11/xorg.conf  it just said I was denied permission and I still haven't discovered where xorg.com is located.

xorg.conf is in /etc/X11/ . You have to be root in order to edit /etc/X11/xorg.conf.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller