VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [SOLVED] VMWare 1.04 Server on VectorLinux 5.9 Standard  (Read 2575 times)

gitarman

  • Member
  • *
  • Posts: 8
[SOLVED] VMWare 1.04 Server on VectorLinux 5.9 Standard
« on: January 10, 2008, 10:35:32 am »

Hi Everyone,

Just wondering if anyone else had success installing VMware 1.04 Server on VectorLinux 5.9 Standard.  It seems the problem is that the Kernel Headers that got downloaded are older then my kernel and that appears to be why it is failing:

The directory of kernel headers (version 2.6.21.5-smp) does not match your
running kernel (version 2.6.22.14).  Even if the module were to compile
successfully, it would not load into the running kernel.

Is there somewhere where I can get the more current Kernel Headers - I got the 2.6.21.5-smp from slapt-get --install kernel-headers

Thoughts?

Steve
« Last Edit: January 12, 2008, 08:38:08 pm by JohnB316 »
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #1 on: January 10, 2008, 10:43:48 am »

Maybe you can find your kernel sources/headers here: http://vectorlinux.osuosl.org/veclinux-5.9/kernels/

although, I don't see 2.6.22.14 - I only see 2.6.22.7 or .15ck... hmm.... ???
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #2 on: January 10, 2008, 10:49:30 am »

the kernel source is on your install ISO.
if you didnt install it at install time you can mount the ISO and install it from there.
Logged

gitarman

  • Member
  • *
  • Posts: 8
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #3 on: January 10, 2008, 10:58:57 am »

hmm, I used the Vector 5.9 Standard Live CD.  Not sure if it's on there, can't seem to see it.  If it isn't it might be a good idea to post the kernel-headers so people who didn't get it can slapt-get --install it.

For now, I'll d/l the non-live cd and see if I can extract it from there...

thx,
Steve
Logged

gitarman

  • Member
  • *
  • Posts: 8
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #4 on: January 10, 2008, 11:04:18 am »

btw- thx for the quick responses, I'm totally floored!  And thanks to all the devs for Vector 5.9 - It has a very stable feel to it and I quite enjoy the new look. 
Logged

uelsk8s

  • Administrator
  • Vectorian
  • *****
  • Posts: 2504
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #5 on: January 10, 2008, 11:09:43 am »

gitarman,
The livecd does not have any of the dev tools or kernel sources you will need to get vmware running.
once you get the install cd downloaded you need to run the commands below as root to install the dev and kernel-source packages.
Code: [Select]
mount /mnt/cdrom
cd /
lzma -cd /mnt/cdrom/veclinux/required/dev.tlz|tar xp
lzma -cd /mnt/cdrom/veclinux/required/kernel-src.tlz|tar xp

HTH, and glad you like VL

Uelsk8s
Logged

gitarman

  • Member
  • *
  • Posts: 8
Re: VMWare 1.04 Server on VectorLinux 5.9 Standard
« Reply #6 on: January 10, 2008, 02:21:09 pm »

thx, just as a heads up to anyone else looking at this thread - the path on the VectorLinux 5.9 Gold Standard CD is in the 'optional' dir, not 'required' ...

cheers, that solved it.
Logged