Please support VectorLinux!

Author Topic: jack audio and ardour  (Read 3342 times)

gitarman

  • Member
  • *
  • Posts: 8
jack audio and ardour
« on: January 15, 2008, 11:17:24 pm »
Hi all,

I followed the steps on Headacher's web site to get Jack/Ardour working on Vector Linux 5.8 for the testing packages of jack and ardour on Vector Linux 5.9 Standard. 

Has anyone done this with success ?  It seems I'm getting stutters in my recordings.  I also notice it during playback - if I  start moving my mouse a lot or open any other apps during playback in Ardour I get more stutters...
This is what I did:
chgrp audio /usr/bin/jackd
adding an extra line to /etc/rc.d/rc.local - modprobe realtime gid=17

Any thoughts on why this is happening.  I've really been enjoying Vector - I switched from Fedora 7, hoping to have a leaner and meaner system - which I have for most intensive purposes.  I'll be quite sad if I can't get the audio working though as that was quite easy in Fedora due to the PlanetCCRMA at home ports... I only got the stuttering happenig in fedora when I tried to use to many plugins...

Ideas?

Thanks in advance,
Steve

The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: jack audio and ardour
« Reply #1 on: January 16, 2008, 12:44:35 am »
Quote
Has anyone done this with success ?
I have to admit I've only tried Ardour for a few minutes. I haven't followed my own HOWTO for a while, perhaps I should do it some time and look for errors / things that may be unclear.
Quote
It seems I'm getting stutters in my recordings.  I also notice it during playback - if I  start moving my mouse a lot or open any other apps during playback in Ardour I get more stutters...
How do you start jackd? Are you sure it´s running with realtime priority? Do you get a lot of xruns (I think you do). If you use qjackctl (give it a try if you haven't, it's well worth it) you can try increasing the buffers/period setting. If not, you should be able to start jack from command line like this (where 4 is the number of buffers/period)
Code: [Select]
jackd -R -d alsa -n 4
Some other tweaks you could try is disabling unused services with vasm, or use a lighter window manager.

Hope this helps.
Most music on my soundcloud page was arranged in programs running on VL.

gitarman

  • Member
  • *
  • Posts: 8
Re: jack audio and ardour
« Reply #2 on: January 16, 2008, 10:33:56 pm »
hey - thx for the reply - i'm reluctant to believe i could be this much of a cracksmoker, but its possible that i didn't click play in qjackctl...   
I tried jack from cmdline as you suggested and i recorded with no prob... I upped the buffers to 4 in qjackctl and all seems to be rockin.  I am a very happy camper - thx headacher - you are my hero. :)




The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1553
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: jack audio and ardour
« Reply #3 on: January 16, 2008, 11:29:17 pm »
Quote
thx headacher - you are my hero.
Sweet!
* The Headacher whistles a heroic tune and flies on to the next person in need
swooosh!!
« Last Edit: January 17, 2008, 12:16:13 am by The Headacher »
Most music on my soundcloud page was arranged in programs running on VL.

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2296
Re: jack audio and ardour
« Reply #4 on: January 17, 2008, 04:24:37 am »

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

exeterdad

  • Packager
  • Vectorian
  • ****
  • Posts: 2046
Re: jack audio and ardour
« Reply #5 on: January 17, 2008, 08:23:55 am »

broozar

  • Member
  • *
  • Posts: 7
Re: jack audio and ardour
« Reply #6 on: March 26, 2008, 12:55:21 pm »
for some reason, i cannot start jack with -R, it produces an error, starting without the realtime option works fine though.

some other questions: sometimes i edit a project in ardour and suddenly the main sound (big play button) stops to work (the track is still transported, but i can hear no sound). however, just selecting the single files (ctrl+rightmousebutton, play) works. any hints?

and i cannot have xmms and ardour playing a sound when both are opened. is this normal behaviour? why do they block each other, as they both rely on alsa (not oss)?

emi

  • Member
  • *
  • Posts: 21
Re: jack audio and ardour
« Reply #7 on: April 03, 2008, 08:20:47 pm »
for some reason, i cannot start jack with -R, it produces an error, starting without the realtime option works fine though.

what kernel are you using? have you loaded the realtime module, and configured the group setting properly (http://the.headacher.googlepages.com/jackonvectorlinux)? if not, you can only get realtime privileges if working as root.

If you want some serious realtime capabilities I highly recommend a 2.6.24.x kernel patched with molnar's realtime preemption patch. (You'll either need a little known program called set_rlimits or be good with PAM to get it to work for non-root users, realtime-lsm won't work.) with it I can get 2.9 ms latency with an older budget laptop and a usb soundcard. it's sweet.

some other questions: sometimes i edit a project in ardour and suddenly the main sound (big play button) stops to work (the track is still transported, but i can hear no sound). however, just selecting the single files (ctrl+rightmousebutton, play) works. any hints?

I have no idea, sorry.

and i cannot have xmms and ardour playing a sound when both are opened. is this normal behaviour? why do they block each other, as they both rely on alsa (not oss)?

you should get xmms-jack from the repository. then you can connect xmms to jack as well and play both at the same time.