Please support VectorLinux!

Author Topic: mysql[solved]  (Read 6276 times)

cse_200509

  • Member
  • *
  • Posts: 14
mysql[solved]
« on: January 19, 2008, 10:56:11 am »
i m using vector linux soho 5.8
i installed mysql 5.0.24 provided in vector today.
till now it is happiness to use vector.
but now i want to use mysql.
so plz help me.............
how to start the server?
« Last Edit: January 27, 2008, 08:39:20 am by cse_200509 »

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #1 on: January 19, 2008, 11:05:13 am »
How did you install mysql?

I think our mysql package is not built correctly. I found out it's missing the startup scripts to the server.
You can install the slackware package http://packages.slackware.it/package.php?q=current/mysql-5.0.51-i486-1
after you install that, you can start the server by issuing the following command as root in a terminal
Code: [Select]
/etc/rc.d/mysqld startHTH

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #2 on: January 19, 2008, 11:10:45 am »
How did you install mysql?

I think our mysql package is not built correctly. I found out it's missing the startup scripts to the server.
You can install the slackware package http://packages.slackware.it/package.php?q=current/mysql-5.0.51-i486-1
after you install that, you can start the server by issuing the following command as root in a terminal
Code: [Select]
/etc/rc.d/mysqld startHTH



thanks !
i installed it by "Gslapt" the software installer
upgraded it to 5.0.45
ERROR
vector:/~
root:# etc/rc.d/mysqld start
-bash: etc/rc.d/mysqld: No such file or directory
« Last Edit: January 19, 2008, 11:18:19 am by cse_200509 »

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #3 on: January 19, 2008, 11:16:27 am »
yeah.. that package you installed via gslapt is not good
go ahead and remove it (you can do that using gslapt too) and then manually download the one I linked you to... after that open a terminal and cd to the directory where you downloaded the .tgz to and issue this command
Code: [Select]
installpkg <name_of_file.tgz>after that start it like I told you to... but dont forget there is a "/" before etc ... so it needs to be
Code: [Select]
/etc/rc.d/mysqld start and NOT "etc/rc.d/mysql start"

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #4 on: January 19, 2008, 11:22:02 am »
yeah.. that package you installed via gslapt is not good
go ahead and remove it (you can do that using gslapt too) and then manually download the one I linked you to... after that open a terminal and cd to the directory where you downloaded the .tgz to and issue this command
Code: [Select]
installpkg <name_of_file.tgz>after that start it like I told you to... but dont forget there is a "/" before etc ... so it needs to be
Code: [Select]
/etc/rc.d/mysqld start and NOT "etc/rc.d/mysql start"


thanks again
i will remember what u said and going to download but which one to be downloaded there is a long list.
« Last Edit: January 19, 2008, 11:24:49 am by cse_200509 »

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #5 on: January 19, 2008, 11:29:46 am »

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #6 on: January 19, 2008, 12:00:04 pm »
yeah.. that package you installed via gslapt is not good
go ahead and remove it (you can do that using gslapt too) and then manually download the one I linked you to... after that open a terminal and cd to the directory where you downloaded the .tgz to and issue this command
Code: [Select]
installpkg <name_of_file.tgz>after that start it like I told you to... but dont forget there is a "/" before etc ... so it needs to be
Code: [Select]
/etc/rc.d/mysqld start and NOT "etc/rc.d/mysql start"


thanks again
i will remember what u said and going to download but which one to be downloaded there is a long list.


/etc/rc.d/mysql start     gives error: root:# /etc/rc.d/mysqld start
                                                        -bash: /etc/rc.d/mysqld: No such file or directory

the error message while executing the following :
    vector://etc/rc.d
    root:# mysql start
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysql/mysql.sock' (2)

this may be becaz "/var/run/mysql/mysql.sock" doesn't exist.
how can i create it?
or any other option available?
« Last Edit: January 19, 2008, 12:05:05 pm by cse_200509 »

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #7 on: January 19, 2008, 12:12:12 pm »
You dont need to create it.. the server creates it when it starts

Here is the script... copy this to /etc/rc.d and save it as mysqld
Code: [Select]
#!/bin/sh
#
# /etc/rc.d/mysqld: start/stop mysqld daemon
#

MYSQL_CFG=/etc/my.cnf

MYSQL_PID=`sed -n 's/^pid-file[ \t]*=[ \t]*//p' $MYSQL_CFG`
MYSQL_USR=`sed -n 's/^user[ \t]*=[ \t]*//p' $MYSQL_CFG`

case $1 in
start)
        touch $MYSQL_PID
        chown $MYSQL_USR $MYSQL_PID
        /usr/sbin/mysqld &
        ;;
stop)
        killall -q /usr/sbin/mysqld
        rm $MYSQL_PID
        ;;
restart)
        $0 stop
        sleep 2
        $0 start
        ;;
*)
        echo "usage: $0 [start|stop|restart]"
        ;;
esac

# End of file
Then set it executable = true
Code: [Select]
chmod +x /etc/rc.d/mysqld

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #8 on: January 19, 2008, 12:21:02 pm »
You dont need to create it.. the server creates it when it starts

Here is the script... copy this to /etc/rc.d and save it as mysqld
Code: [Select]
#!/bin/sh
#
# /etc/rc.d/mysqld: start/stop mysqld daemon
#

MYSQL_CFG=/etc/my.cnf

MYSQL_PID=`sed -n 's/^pid-file[ \t]*=[ \t]*//p' $MYSQL_CFG`
MYSQL_USR=`sed -n 's/^user[ \t]*=[ \t]*//p' $MYSQL_CFG`

case $1 in
start)
        touch $MYSQL_PID
        chown $MYSQL_USR $MYSQL_PID
        /usr/sbin/mysqld &
        ;;
stop)
        killall -q /usr/sbin/mysqld
        rm $MYSQL_PID
        ;;
restart)
        $0 stop
        sleep 2
        $0 start
        ;;
*)
        echo "usage: $0 [start|stop|restart]"
        ;;
esac

# End of file
Then set it executable = true
Code: [Select]
chmod +x /etc/rc.d/mysqld



ERROR message returned i.e.


root:# chmod +x /etc/rc.d/mysqld
vector:/~
root:# /etc/rc.d/mysqld start
sed: can't read /etc/my.cnf: No such file or directory
sed: can't read /etc/my.cnf: No such file or directory
touch: missing file operand
Try `touch --help' for more information.
chown: missing operand
Try `chown --help' for more information.
/etc/rc.d/mysqld: line 16: /usr/sbin/mysqld: No such file or directory

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #9 on: January 19, 2008, 02:01:00 pm »
I'm afraid you are going to need to build it from source then...

I have a working package, but it was built on 5.9, and will most likely not work for your 5.8 SOHO

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #10 on: January 19, 2008, 08:50:22 pm »
I'm afraid you are going to need to build it from source then...

I have a working package, but it was built on 5.9, and will most likely not work for your 5.8 SOHO


ohhh panic
so what to do next?

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: mysql
« Reply #11 on: January 20, 2008, 05:25:46 am »
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #12 on: January 21, 2008, 05:58:33 am »
Johnb316 was building a new mysql package... you may want to give slapt-get another shot

cse_200509

  • Member
  • *
  • Posts: 14
Re: mysql
« Reply #13 on: January 21, 2008, 08:57:33 am »
Johnb316 was building a new mysql package... you may want to give slapt-get another shot

Well 
the Errors retuned:



root:# /etc/rc.d/mysqld start
sed: can't read /etc/my.cnf: No such file or directory
sed: can't read /etc/my.cnf: No such file or directory
touch: missing file operand
Try `touch --help' for more information.
chown: missing operand
Try `chown --help' for more information.
/etc/rc.d/mysqld: line 16: /usr/sbin/mysqld: No such file or directoryroot:# /etc/rc.d/mysqld start


then what i did:

vector:/~
root:# touch -a /etc/my.cnf
vector:/~
root:# touch -m /etc/my.cnf
vector:/~
root:# /etc/rc.d/mysqld start
touch: missing file operand
Try `touch --help' for more information.
chown: missing operand
Try `chown --help' for more information.
/etc/rc.d/mysqld: line 16: /usr/sbin/mysqld: No such file or directory
vector:/~


i don't know what to do next.

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3208
Re: mysql
« Reply #14 on: January 21, 2008, 09:30:41 am »
I'd tell you to build it yourself from ports, but you are running 5.8.... not sure how ports work there