April 18, 2015, 04:45:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: Network Troubleshooting  (Read 2222 times)
Posts: 29

« on: January 19, 2008, 09:22:58 pm »

I'm able to access the network to browse the internet and such without issue, except one annoying problem. When I boot my computer and log in, I receive a prompt telling me:
Could not look up internet address for <hostname>
This will prevent Xfce from operating correctly. It may be possible to correct the problem by adding <hostname> to the file /etc/hosts on your system.
(In the actual text it says my computer's name where I put <hostname>).

Then it gives me the option to "Try Again" or "Cancel." I click cancel. If I open a terminal and run ifconfig, I have no IP address. So, I run
service ipflugd restart
If I do this immediately upon booting, it will take quite awhile, but I still have no IP address. Whereas, if I wait a few minutes, it instantly receives an IP, and I can access the network. I'm on a network where I am assigned an IP by a DHCP server, and the IP can vary from one lease to another.I rarely use Windows, especially on the network, but I seem to have similar behavior there, too. Initially, I receive no IP, and I have to wait a minute or two, otherwise refreshing the connection won't obtain an IP.

What can suggestions are there for troubleshooting? I think if I can identify the problem, I'll know how to solve it. Might it be beyond my control? That is, could it be either the network interface or the network itself? I know that our network has a convention for assigning the hostname of my computer. Should I make sure that my hostname corresponds to that?

I have VL 5.8 standard edition.
Posts: 1868

« Reply #1 on: January 20, 2008, 05:57:21 am »

This is should be an easy problem to solve.

More information is needed.

The NIC card name, model and version <if applicable>

Then lspci | grep Ethernet

Then lsmod

Then ifconfig | grep addr

Do these before the network is up.

You can check dmesg for errors  and /var/log/messages

Posts: 1346

Registered Linux User #386728

« Reply #2 on: January 20, 2008, 09:15:00 am »

Besides the info requested from Bigpaws, also tell us whether your computer's network card is connected to a router or directly to a broadband modem.


VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
Posts: 29

« Reply #3 on: January 22, 2008, 09:16:28 pm »

I ran those commands, and I don't think they turned up anything.

ifconfig shows that I have no IP initially.

I can't remember the exact specs, but I have a Syskonnect network adapter. I also have a Broadcom card that I've never been able to get to work, so I've relegated it to eth2, and I'm pretty sure it's not interfering.  I has no IP address upon boot either.
Here's the output for lspci | grep Ethernet

02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
04:01.0 Ethernet controller: SysKonnect SK-9871 V2.0 Gigabit Ethernet 1000Base-ZX Adapter, PCI64, Fiber ZX/SC (rev 10)

I don't think the module is the problem either. lsmod turns up the skge module both before and after I start the network.

Is there anything specific I can grep in /var/log/messages that might shed some light on this?

I might be misunderstanding the terms, but I think the adapter would be connected directly to a broadband modem. I'm on a college campus network, and the cord is plugged directly into a port on the wall. Our IP addresses are NOT 192.168.*.*. If you need more details about the network, I could talk to the administrators. In other Linux distributions, it was never a problem on this network, but I don't think I've ever had it consistently behave itself in Vector. It was about the same time that I switched to Vector that the network switched to dynamically assigning IP's every time a computer connects to the network.

Also, I tried booting directly to the command line, but experienced the same behavior.

I don't know if this sheds any light on where to look next. Thanks!
Posts: 3261

-- Just being myself --

« Reply #4 on: January 22, 2008, 09:28:02 pm »

btw, what is your output in your /etc/hosts?
Posts: 1132

« Reply #5 on: January 22, 2008, 09:42:25 pm »

I had that same thing happen on a 5.8 Std installation a while back.  I never figured out what the problem was but it didn't seem to affect networking - I suspected it was an upgrade I did (perhaps xfce) but couldn't confirm it.  Anyway, I ended up reinstalling after that for a different reason and the problem didn't reappear.  I'm not suggesting you reinstall; just thought I'd share my experience.
Posts: 2296

« Reply #6 on: January 23, 2008, 04:53:26 am »

Looks like could be a problem in /etc/rc.d/rc.inet* to me. Perhaps the server is taking too much time to serve and address? You are experiencing the same in windows so could be related to the network and not with the os.

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

Posts: 63

« Reply #7 on: January 25, 2008, 01:38:57 am »

I got this problem when I messed up my DNS server. After setting all back to automatic dhcp the message does not appear anymore
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!