VectorLinux
September 19, 2014, 07:35:16 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: vpackager-1.0.10 released  (Read 2504 times)
M0E-lnx
Administrator
Vectorian
*****
Posts: 3180



« on: January 22, 2008, 02:50:21 pm »

It's been a long time since the last vpackager release.
A brand new release has just hit our repos.

Bux fixes include the problem where vpackager was not inserting the slack-desc into the packages (when building from source)

I have also re-worked some of the cruxports GUI code for better performance.
Lots of other minor bug fixes.

NOTICE
Now that gambas2 has gone final, you will notice a major change in the size of the vpackager compressed and installed size. This is because I'm now only shipping the vpackager binary.
As always, this package will require the gambas2-runtime-2.0.0 package and a couple of others (slapt-get should install them)


IMPORTANT
Instead of simply upgrading the package, Please remove the old vpackager package first. If you just upgrade the vpackager package, you'll be left with some left overs from the old package in /opt/vpackager. Please follow the install instructions below

Code:
removepkg vpackager
slapt-get --update
slapt-get --install vpackager

As always, the source code is available at http://vpackager.googlecode.com

Please test and report feedback
Enjoy Wink
Logged

kidd
Packager
Vectorian
****
Posts: 682


« Reply #1 on: January 22, 2008, 03:52:12 pm »

Code:
root@raymobil [ ~ ] #slapt-get --install vpackager
Reading Package Lists... Done
Excluding vpackager, use --ignore-dep to override
The following packages have been EXCLUDED:
  vpackager
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done

The following packages have unmet dependencies:
vpackager: Depends: cruxports4slack >= 20061113


Sad
« Last Edit: January 22, 2008, 03:54:34 pm by kidd » Logged

tomh38
Vectorian
****
Posts: 913



« Reply #2 on: January 22, 2008, 03:56:08 pm »

All I'm seeing in the repos is vpackager-1.0.1RC2-i586-1vl59.tlz ... and I'm getting a dependency error about cruxports.
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
kidd
Packager
Vectorian
****
Posts: 682


« Reply #3 on: January 22, 2008, 04:12:30 pm »

It's ok now for me...  The installation went fine after another slapt-get --update.  I think eas had something to do with it.

I haven't tested its funcitionality.... but it seems to run fine for the moment
Logged

tomh38
Vectorian
****
Posts: 913



« Reply #4 on: January 22, 2008, 04:18:54 pm »

All good here too ... thanks M0E!
Logged

"I'm doing a (free) operating system (just a hobby, won't be big and professional like gnu) for 386(486) AT clones." - Linus Torvalds, April 1991
rbistolfi
Packager
Vectorian
****
Posts: 2283


« Reply #5 on: January 23, 2008, 04:04:25 pm »

I get a dep error using slapt-get on cmake.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
M0E-lnx
Administrator
Vectorian
*****
Posts: 3180



« Reply #6 on: January 23, 2008, 04:46:03 pm »

I installed this via gslapt myself after uploading it, and it worked fine...
DO you have the testing and extra repos enabled?
Can you post the error message?

Logged

rbistolfi
Packager
Vectorian
****
Posts: 2283


« Reply #7 on: January 23, 2008, 05:09:25 pm »

Yes, I have testing and extra enabled, here is the output:

Code:
root:# slapt-get --install vpackager
Reading Package Lists... Done
Excluding vpackager, use --ignore-dep to override
The following packages have unmet dependencies:
  vpackager: Depends: cmake >= 2.4.6
The following packages have been EXCLUDED:
  vpackager
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
rbistolfi
Packager
Vectorian
****
Posts: 2283


« Reply #8 on: January 23, 2008, 05:26:46 pm »

cmake is in the packages repo. I installed it manually and vpackager works fine. Also I noticed some ports are using svn, perhaps it should be included as a dep. I tried to install subversion package using slapt-get and same thing happened. When I look to the repo by myself the package is there. It is so weird.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!