VectorLinux
October 24, 2014, 06:37:20 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: acidrip & gtk2  (Read 4789 times)
overthere
Vectorian
****
Posts: 1281



« on: January 24, 2008, 02:26:53 pm »

Hi-
 I installed acidrip via gslapt
It does not open
in a terminal I get the following error
what is the solution?


Can't locate Gtk2.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i486-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i486-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.8/AcidRip/interface.pm line 1.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/AcidRip/interface.pm line 1.
Logged

Everything Is Relative
federico
Member
*
Posts: 10


« Reply #1 on: January 25, 2008, 01:07:33 pm »

in linuxpackages acidrip is absent,
in slacky.eu is present but doesn't work
i think it's difficult having a working acidrip on a slack 12.0 based
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: January 25, 2008, 05:26:17 pm »

it looks like you need a gtk2 perl module to me
Logged
exeterdad
Packager
Vectorian
****
Posts: 2046



« Reply #3 on: January 25, 2008, 06:31:54 pm »

Quote
Can't locate Gtk2.pm
I have to agree with you Uel.
pm extension = perl module
Logged
easuter
Global Moderator
Vectorian
*****
Posts: 2160



« Reply #4 on: January 25, 2008, 06:53:40 pm »

The Gtk-perl module can be installed using perl's cpan shell, but since you need to fine-tune the build, the best way is to do it manually:

1 - open a terminal, then type

Code:
wget http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Gtk-Perl-0.7009.tar.gz

to download the source code.

2 - decompress the source code:

Code:
tar xvf Gtk-Perl-0.7009.tar.gz

3 - enter the build directory:

Code:
cd Gtk-Perl-0.7009

4 - configure the source code and then build it:

Code:
perl Makefile.PL --without-gnome --without-applets --without-glade --without-gnomeprint
Code:
make

5 - install it:

Code:
su
Code:
make install

That should do it  Smiley
Logged

overthere
Vectorian
****
Posts: 1281



« Reply #5 on: January 26, 2008, 12:21:49 pm »

Hm, So I'm understanding that:
Although gtk-2  perl are included in VL, the installation of acidrip  via gslapt from the VLrepository requires an additional perl module, not available in the repository
- but can be  downloaded from cpam, via package:Gtk-Perl-0.7009.tar.gz, recompiled and installed, making acidrip then functional?
Thus the testing repository for acidrip.?

 Will the module be made available from the repository later?
 Will it later still be an auto installed dependency with the gslapt install?
 
What does @INC mean?

Am I missing something?
Logged

Everything Is Relative
JohnB316
Administrator
Vectorian
*****
Posts: 1346


Registered Linux User #386728


« Reply #6 on: January 27, 2008, 08:35:52 am »

To add to this thread, if you want to package the GTK-Perl module, jaos, the author of slapt-get and gslapt, also has a Slack package that will package CPAN modules. Here is a link to a page about the package on his web site:  http://software.jaos.org/#cpan2tgz

I would strongly recommend reading the documentation before using the cpan2tgz package so that you understand exactly what it does and how you need to invoke it.

HTH,
John
Logged

VL 6.0 SOHO latest alpha on one box, VL 5.9 Lite on the other.
overthere
Vectorian
****
Posts: 1281



« Reply #7 on: January 27, 2008, 10:54:20 am »

Hi.
.I downloaded the file and used the code listed
.all seemed to go well until make install
this is the ending:
vector://home/bootstrap/Gtk-Perl-0.7009
root:# make install
make[1]: Entering directory `/home/bootstrap/Gtk-Perl-0.7009/Gtk'
make[1]: *** No rule to make target `build/perl-gtk-ref.pod', needed by `manifypods'.  Stop.
make[1]: Leaving directory `/home/bootstrap/Gtk-Perl-0.7009/Gtk'
make: *** [subdirs] Error 2
vector://home/bootstrap/Gtk-Perl-0.7009
root:#
what did I do wrong?
I now have a folder of files waiting in the home directory
Logged

Everything Is Relative
federico
Member
*
Posts: 10


« Reply #8 on: January 28, 2008, 09:36:02 am »

idem ( the same for me)


 
Posted by: overthere

.............make: *** [subdirs] Error 2
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #9 on: January 28, 2008, 01:44:52 pm »

Still no luck with ripping dvd...is anyone able to rip dvd on vector 5.9..what are you useing and how did you get it working?

I am not sure if the uninstalled perl module is the only thing holding back acid.
I attempted k3b but transcode is not working.

if it is not possible I just need to know.
Logged

Everything Is Relative
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #10 on: January 28, 2008, 02:04:54 pm »

I have copied one with k9copy
you can get it with slapt-get
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #11 on: January 28, 2008, 02:25:37 pm »

I'll have a look...thanks...
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1281



« Reply #12 on: January 28, 2008, 05:34:14 pm »

well...k9copy is not working either and all this junk has messed up the player so I can not even watch a video.

I can not record sound either..I used audacity,ardour and also mhwaveedit. garbled noise if any record at all...video and sound Hmmm

I guess it's time to shuterdown.
Logged

Everything Is Relative
overthere
Vectorian
****
Posts: 1281



« Reply #13 on: January 29, 2008, 11:46:49 pm »

Ok..a little sleep and a fresh install of VL.

still can not get the GTK-Perl-0.7009 to install..what am I doing wrong?

are there additional dependancies for acidrip

k9copy gives error: error occured while running dvd author
dvd author is installed

again: can anyone rip dvd on vector5.9 and if so with what and how did you get it running

I appreciate the help so far but still not ripping.
Logged

Everything Is Relative
federico
Member
*
Posts: 10


« Reply #14 on: January 30, 2008, 06:39:23 am »


http://www.mplayerhq.hu/DOCS/HTML/en/mencoder.html
man mplayer:
EXAMPLES OF MENCODER USAGE
       Encode DVD title #2, only selected chapters:
       mencoder dvd://2 -chapter 10-15 -o title2.avi -oac copy -ovc lavc -lavcopts vcodec=mpeg4


can anyone rip dvd on vector5.9 and if so with what and how did you get it running ?
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!