VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: CD Rom Not mounted  (Read 2064 times)

clemkonan

  • Member
  • *
  • Posts: 16
CD Rom Not mounted
« on: January 20, 2008, 03:58:40 pm »

 I have two CD ROM devices installed a regular CD burner and a DVD burner. I popped a CD file into the drive hoping to have it detected and opened using openoffice writer which is installed but nothing happens apart from a few chirps. Under devices it says  /dev/cdrom  not mounted.

I played a DVD movie last night with no problem whats up?

Admittedly " not mounted" is not familiar language.
Thanks

N2U4000
AMD Semptron 1300
512 Meg Ram
ATI Rage Video Card
Dual booting VL and Windows XP
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4457
Re: CD Rom Not mounted
« Reply #1 on: January 20, 2008, 07:29:07 pm »

DVD's and Audio CD's can be played without mounting the drives in a file system sense. To read them as data discs, they need mounting.

I have had some problems in the past when using multiple optical drives. If you know how your drives are connected to the motherboard, it is simple to manually configure the system to access them. One way to find this information is by hitting the "Pause" button on boot when (if) you see the summary page that lists drives, memory and other stuff.

Some other info that would be helpful:
What version of Vector are you running?
If you could copy the contents of your /etc/fstab file and post it here that would be good.
In a terminal, issue command fdisk -l (small L) and post the output of that.
Logged

clemkonan

  • Member
  • *
  • Posts: 16
Re: CD Rom Not mounted
« Reply #2 on: January 21, 2008, 06:12:02 pm »

255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2549    20474811    7  HPFS/NTFS
/dev/hda2            2550       19457   135813510    f  W95 Ext'd (LBA)
/dev/hda5            7968        9966    16056967+   b  W95 FAT32
/dev/hda6            9967       10232     2136613+  82  Linux swap
/dev/hda7           10233       12335    16892316   83  Linux
/dev/hda8           12336       19457    57207433+  83  Linux
/dev/hda9            2550        7967    43520022   83  Linux

Partition table entries are not in disk order

Disk /dev/sda: 1017 MB, 1017118720 bytes
255 heads, 63 sectors/track, 123 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1         124      993248+   c  W95 FAT32 (LBA)
Partition 1 has different physical/logical endings:
     phys=(122, 254, 63) logical=(123, 167, 44)
vector://home/colin
root:#


Running 5.9 .
Not sure how to locate  that file or display contents
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4457
Re: CD Rom Not mounted
« Reply #3 on: January 22, 2008, 06:44:08 am »

Try a little experiment: Insert a disc in each optical drive. Log in as root and open a terminal. Type these commands:

cd /mnt
mkdir hdb
mkdir hdc
mkdir hdd
mount /dev/hdb hdb
mount /dev/hdc hdc
mount /dev/hdd hdd


With some luck, two of those mount commands should produce no errors. That will tell us which drive is where. Post your results and we'll use that info to edit the config file.
Logged

clemkonan

  • Member
  • *
  • Posts: 16
Re: CD Rom Not mounted
« Reply #4 on: January 23, 2008, 07:07:50 pm »

Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
vector://home/colin
root:# cd/mnt
bash: cd/mnt: No such file or directory
vector://home/colin
root:# mkdir hdb
vector://home/colin
root:# mkdir hdc
vector://home/colin
root:# mkdir hdd
vector://home/colin
root:# mount /dev/hdb hdb
mount: special device /dev/hdb does not exist
vector://home/colin
root:# mount /dev/hdc hdc
mount: block device /dev/hdc is write-protected, mounting read-only
vector://home/colin
root:# mount /dev/hdd hdd
mount: block device /dev/hdd is write-protected, mounting read-only
vector://home/colin
root:#
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4457
Re: CD Rom Not mounted
« Reply #5 on: January 24, 2008, 05:25:46 am »

Okay, we established that both your optical drives are on the secondary IDE channel.

The reason why you got an error on the "/mnt" command is there needs to be a space between it and the "cd" command. You can delete the hdb, hdc and hdd directories from /home/colin now.

Now, as root, in a terminal:
cd /mnt
mkdir cdrom
mkdir dvd

- the directories may already be there, we're just making sure
mcedit /etc/fstab
- scroll down to find a section something like this:
Code: [Select]
# CDROM, CDWRITER, DVD
/dev/cdrom    /mnt/cdrom        iso9660 defaults,noauto,ro,user 0 0
#/dev/cdwriter /mnt/cdwriter    iso9660 defaults,noauto,rw,user 0 0
#/dev/dvd      /mnt/dvd         auto    defaults,noauto,ro,user 0 0

Change it to something like:
Code: [Select]
# CDROM, CDWRITER, DVD
/dev/hdc    /mnt/cdrom       iso9660 defaults,noauto,ro,user 0 0
/dev/hdd    /mnt/dvd         auto    defaults,noauto,ro,user 0 0

You may have to swap hdc/hdd around to get it right as far as CDROM or DVD goes.
Hit F2 to save, F10 to exit

Try accessing your drives now. What version of VL are you using?
Logged