VectorLinux
October 01, 2014, 04:09:26 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2]
  Print  
Author Topic: Help with "cedega" (solved)  (Read 3491 times)
bigpaws
Vectorian
****
Posts: 1850


« Reply #15 on: January 28, 2008, 03:20:25 am »

Quote
You paid good money for cedega.  And so did everyone else on Google.

Did something change at Cedega I missed? The only way I am aware of to
get Cedega is to be a member (Which I am) and download from the website
or to try to compile from the source builds.

Bigpaws
Logged
reb
Vectorite
***
Posts: 136


The BOSS


« Reply #16 on: January 28, 2008, 07:41:34 am »


Thanks people for all your help, but I'm still mired in error problems and I intend to get them solved one way or another. Wink

exterdad: The error mesg I posted above was generated as 'user',  This morning I went back and ran it again as 'root' and it gave me additional information, so here it is:

Quote
vector://home/rebel/cod
root:# ./codsp*
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
  import gddb_parser
Traceback (most recent call last):
  File "/usr/lib/transgaming_cedega/Point2Play_gui.py", line 2752, in <module>
    Point2Play_ref = Point2Play.Point2Play( config_file )
  File "/usr/lib/transgaming_cedega/Point2Play.py", line 394, in __init__
    config_file.readfp( file( filename, "r" ) )
IOError: [Errno 2] No such file or directory: '/root/.cedegarc'

So how do I correct the mismatch in 'gddb_parser' versions?

I hope this new info sheds more light on the problem

reb
Logged

Ye Ole Montana Saddle Tramp
Nothing is right or wrong, good or bad, only thinking makes it so.  Think about it.
Running a Vector Linux VL3300 with 1 SATA 80GB HDD and 1GB DDR 400 ram, DVD+-RW , and VL 5.9 Delux
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #17 on: January 28, 2008, 08:01:57 am »

I dont think you need to worry about the version mismatch error right off. that is not why it is failing.
the program is looking for a config file (/root/.cedegarc) try copying that file from your user account
Code:
cp /home/rebel/.cedegarc /root
and then run the program again to see if it gets farther
Logged
reb
Vectorite
***
Posts: 136


The BOSS


« Reply #18 on: January 28, 2008, 09:53:41 am »

Hi uelsk8s,

Yes we did get further.  It looks like now we have to contend with the memory corruption thingy.

Quote
rebel:$ ./codsp*
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
  import gddb_parser
*** glibc detected *** python: malloc(): memory corruption: 0x085239e8 ***

reb
Logged

Ye Ole Montana Saddle Tramp
Nothing is right or wrong, good or bad, only thinking makes it so.  Think about it.
Running a Vector Linux VL3300 with 1 SATA 80GB HDD and 1GB DDR 400 ram, DVD+-RW , and VL 5.9 Delux
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #19 on: January 28, 2008, 10:47:48 am »

try this now
MALLOC_CHECK_=0 ./codsp*
Logged
reb
Vectorite
***
Posts: 136


The BOSS


« Reply #20 on: January 28, 2008, 07:13:03 pm »

Hi uelsk8s, here is the result:

Quote
root:# MALLOC_CHECK_=0 ./codsp*
/usr/lib/transgaming_cedega/gddb.py:24: RuntimeWarning: Python C API version mismatch for module gddb_parser: This Python has API version 1013, module gddb_parser has version 1012.
  import gddb_parser
Error: No Cedega engine is currently installed.
Please run the setup wizard to install a Cedega engine.

This is ironic.  while waiting for an answer about the memory corruption problem, I ran "cedega" and got the gui and tried again to figure out what a cedega engine is and where to find it.  In fact I was on the cedega web site when,  the wireless net went down, and shortly after that we had a general power outage in this part of Indiana.  So I have been blacked out since just before noon today.  It is now almost 10:00 pm. So when I finally got your post and ran the command and read the last line about the cedega engine, I was flabbergasted. 

I tried to run the setup wizard, but I can't even connect to the cedega web site. It took me almost 5minutes to just to load this reply page to get this post written.  I just hope it will get sent tonight.

we can continue this tomorrow

reb
Logged

Ye Ole Montana Saddle Tramp
Nothing is right or wrong, good or bad, only thinking makes it so.  Think about it.
Running a Vector Linux VL3300 with 1 SATA 80GB HDD and 1GB DDR 400 ram, DVD+-RW , and VL 5.9 Delux
reb
Vectorite
***
Posts: 136


The BOSS


« Reply #21 on: January 29, 2008, 03:38:15 pm »

Well folks, with a lot of help from you people, I downloaded and install the latest cedega engine, but cedega is still crippled.  I can however play the game by starting it from the command line.  I have the same problem that others have mentioned, the game hangs up upon exit.  But that is just a minor irritation, not a problem.

uelsk8s, here is something else.  You may already be aware of this sort of thing.  When I run the MALLOC command in root I get the mesg in the above post.  When I run MALLOC command from user, I get a slightly different mesg and it starts the game.  Is that normal or is it just another wierd turn of events?

Anyway, now that I can play the game, I'll work on the tweeks at a more leasurely pace.  Cheesy

thanks again people

reb
« Last Edit: February 16, 2008, 12:41:00 pm by reb » Logged

Ye Ole Montana Saddle Tramp
Nothing is right or wrong, good or bad, only thinking makes it so.  Think about it.
Running a Vector Linux VL3300 with 1 SATA 80GB HDD and 1GB DDR 400 ram, DVD+-RW , and VL 5.9 Delux
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!