VectorLinux
July 28, 2014, 04:17:12 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Touchpad occasionally unresponsive  (Read 1246 times)
M-ake
Member
*
Posts: 92


« on: January 28, 2008, 01:58:24 am »

Hi Im using VL59 on my core duo lappy with a Synaptics touchpad. The problem is (which I didnt encounter in earlier VL versions) that the touchpad becomes unresponsive for like 2 seconds if I push any button on my keyboard...Otherwise the touchpad works, scrolling etc....

Xorg conf
Quote
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Synaptics Mouse" "CorePointer"
InputDevice    "Mouse0" "SendCoreEvents"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath      "/usr/share/X11/rgb"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/TTF"
FontPath     "/usr/share/fonts/OTF"
FontPath     "/usr/share/fonts/Type1"
FontPath     "/usr/share/fonts/misc"
FontPath     "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load  "glx"
Load  "extmod"
Load  "xtrap"
Load  "record"
Load  "GLcore"
Load  "dbe"
Load  "dri"
Load  "freetype"
Load  "type1"
Load  "synaptics"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "fi"    ## KEYBOARD_MAP!
Option  "XkbModel"  "pc105"    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  "nodeadkeys"    ## KEYBOARD_VARIANT!
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/input/mice"
Option       "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Synaptics Mouse"
    Driver         "synaptics"
    Option         "SendCoreEvents"
    Option         "Device" "/dev/psaux"
    Option         "Protocol" "auto-dev"
    Option         "LeftEdge" "1700"
    Option         "RightEdge" "5300"
    Option         "TopEdge" "1700"
    Option         "BottomEdge" "4200"
    Option         "FingerLow" "25"
    Option         "FingerHigh" "30"
    Option         "MaxTapTime" "180"
    Option         "MaxTapMove" "220"
    Option         "VertScrollDelta" "100"
    Option         "MinSpeed" "0.09"
    Option         "MaxSpeed" "0.18"
#    Option         "AccelFactor" "0.0015"
    Option         "AccelFactor" "0.002"
    Option         "SHMConfig" "on"
#  Option   "Repeater"   "/dev/ps2mouse"
EndSection

Section "Monitor"
Option "DPMS"
DisplaySize 338 211 # 96 DPI @ 1280x800
Option "UseEdidFreqs" "1"
#DisplaySize     330   210   # mm
Identifier   "Monitor0"
VendorName   "AUO"
ModelName    "1974"
HorizSync 31.5-64
VertRefresh 40-90
EndSection

Section "Device"
### Available Driver options are:-
### Values: : integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [
arg]: arg optional
#Option     "NoAccel"               # [<bool>]
#Option     "SWcursor"              # [<bool>]
#Option     "ColorKey"              #
#Option     "CacheLines"            #
#Option     "Dac6Bit"               # [
<bool>]
#Option     "DRI"                   # [<bool>]
#Option     "NoDDC"                 # [<bool>]
#Option     "ShowCache"             # [<bool>]
#Option     "XvMCSurfaces"          #
#Option     "PageFlip"              # [
<bool>]
Identifier  "Card0"
Driver      "intel"
VendorName  "Intel Corporation"
BoardName   "Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
BusID       "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport   0 0
Depth     1
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

dmesg | grep Synaptics
Quote
Synaptics Touchpad, model: 1, fw: 6.1, id: 0xa3a0b3, caps: 0xa04713/0x10008
input: SynPS/2 Synaptics TouchPad as /class/input/input6

Any ideas mateys how to fix this ?
« Last Edit: January 28, 2008, 02:23:40 am by M-ake » Logged

Jumalauta!!
--
Fish go m00!
InTheWoods
Vectorite
***
Posts: 302


« Reply #1 on: February 12, 2008, 01:18:43 pm »


I can't offer any help but I can confirm it happens.
Code:
dmesg | grep Alps     
input: AlpsPS/2 ALPS DualPoint TouchPad as /class/input/input6

This occurs on Toshiba Tecra but not all the time. Just occasionally. It will be persistant for a few seconds and then clear up.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!