Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Lilo problems [solved]  (Read 2822 times)


  • Member
  • *
  • Posts: 53
Lilo problems [solved]
« on: January 28, 2008, 08:57:14 am »

I have been having quite a few issues with lilo.  First off, I was not able to install lilo directly from VL5.9 installation CD.  I had to chroot myself into my main partition and run liloconfig.  Strangely, I can seem to get the nice boot loader theme that's suppose to come with VL 5.9.  It says my system doesn't support the framebuffer feature.  And I also get a weird error when I run lilo in the terminal.  Here's what I get.

Code: [Select]
root:# lilo -v
LILO version 22.8, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2006 John Coffman
Released 19-Feb-2007 and compiled at 01:09:42 on Jun 10 2007.

Reading boot sector from /dev/sda
Fatal: open /dev/sdc: Read-only file system

I think sdc is my CD/DVD drive which is weird that the bootloader is even looking at it.  And here's my lilo.conf file.

Code: [Select]
# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/sda
message = /boot/boot_message.txt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x32k
vga = 790
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sda1
label = Windows
table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sdb1
label = Linux
# Linux bootable partition config ends

Basically, I would like to know what this config file would look like if it had installed like it should have.
« Last Edit: February 01, 2008, 05:13:30 pm by mithion »


  • Member
  • *
  • Posts: 53
Re: Lilo problems
« Reply #1 on: January 31, 2008, 09:35:28 am »

Ok, I solved my own problem.  But in the process, I believe I discovered a bug or at least an annoying quirk.  On my desktop, I have a total of 3 drives.  Two internal, and one external.  On my first drive (sda), I have windows vista.  On my second drive (sdb), I have Vector Linux.  And the finally, the external (sdd) drive is a fat32 storage bank with no OS or system installed on it.

So my problem was that Lilo kept complaining about an elusive drive labeled sdc.  Well, I finally figured out what it was.  I have a brand new printer.  A canon MP600 to be more precise.  Well... One of the features of this printer is that it lets you plug in a little flash card containing pictures or documents so that you can print them directly to the printer without having to interface to a computer.  But the thing is that when the card is plugged in the printer, the operating system detects it correctly as a separate drive.  But for some reason, it caused quite a bit of hardship to install lilo.  Each time I would try to wipe the MBR and reinstall Lilo, it would give me this error.

Code: [Select]
Fatal: open /dev/sdc: Read-only file system
But it reality, just as with the external hardrive, there were no bootable elements on this flash card and Lilo should not have any business trying to write stuff to it.  So I ended up unplugging it and was able to reinstall lilo correctly with all the right entries and theme.  Has anybody had the same problem before?